summaryrefslogtreecommitdiffstats
path: root/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb')
-rw-r--r--meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb b/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb
new file mode 100644
index 000000000..466f44381
--- /dev/null
+++ b/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "Closed source binary files to help boot the ARM on the BCM2835."
+LICENSE = "Proprietary"
+
+LIC_FILES_CHKSUM = "file://LICENCE.broadcom;md5=4a4d169737c0786fb9482bb6d30401d1"
+
+inherit deploy nopackages
+
+include recipes-bsp/common/firmware.inc
+
+INHIBIT_DEFAULT_DEPS = "1"
+
+DEPENDS = "rpi-config"
+
+COMPATIBLE_MACHINE = "^rpi$"
+
+S = "${RPIFW_S}/boot"
+
+PR = "r3"
+
+do_deploy() {
+ install -d ${DEPLOYDIR}/${PN}
+
+ for i in ${S}/*.elf ; do
+ cp $i ${DEPLOYDIR}/${PN}
+ done
+ for i in ${S}/*.dat ; do
+ cp $i ${DEPLOYDIR}/${PN}
+ done
+ for i in ${S}/*.bin ; do
+ cp $i ${DEPLOYDIR}/${PN}
+ done
+
+ # Add stamp in deploy directory
+ touch ${DEPLOYDIR}/${PN}/${PN}-${PV}.stamp
+}
+
+addtask deploy before do_build after do_install
+do_deploy[dirs] += "${DEPLOYDIR}/${PN}"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
OpenPOWER on IntegriCloud