summaryrefslogtreecommitdiffstats
path: root/meta-quanta/meta-q71l/conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-quanta/meta-q71l/conf')
-rw-r--r--meta-quanta/meta-q71l/conf/bblayers.conf.sample35
-rw-r--r--meta-quanta/meta-q71l/conf/conf-notes.txt2
-rw-r--r--meta-quanta/meta-q71l/conf/layer.conf9
-rw-r--r--meta-quanta/meta-q71l/conf/local.conf.sample21
-rw-r--r--meta-quanta/meta-q71l/conf/machine/quanta-q71l.conf38
5 files changed, 105 insertions, 0 deletions
diff --git a/meta-quanta/meta-q71l/conf/bblayers.conf.sample b/meta-quanta/meta-q71l/conf/bblayers.conf.sample
new file mode 100644
index 000000000..4797c565b
--- /dev/null
+++ b/meta-quanta/meta-q71l/conf/bblayers.conf.sample
@@ -0,0 +1,35 @@
+# LAYER_CONF_VERSION is increased each time build/conf/bblayers.conf
+# changes incompatibly
+LCONF_VERSION = "8"
+
+BBPATH = "${TOPDIR}"
+BBFILES ?= ""
+
+BBLAYERS ?= " \
+ ##OEROOT##/meta \
+ ##OEROOT##/meta-poky \
+ ##OEROOT##/meta-openembedded/meta-oe \
+ ##OEROOT##/meta-openembedded/meta-networking \
+ ##OEROOT##/meta-openembedded/meta-perl \
+ ##OEROOT##/meta-openembedded/meta-python \
+ ##OEROOT##/meta-openembedded/meta-webserver \
+ ##OEROOT##/meta-phosphor \
+ ##OEROOT##/meta-aspeed \
+ ##OEROOT##/meta-x86 \
+ ##OEROOT##/meta-quanta \
+ ##OEROOT##/meta-quanta/meta-q71l \
+ "
+BBLAYERS_NON_REMOVABLE ?= " \
+ ##OEROOT##/meta \
+ ##OEROOT##/meta-poky \
+ ##OEROOT##/meta-openembedded/meta-oe \
+ ##OEROOT##/meta-openembedded/meta-networking \
+ ##OEROOT##/meta-openembedded/meta-perl \
+ ##OEROOT##/meta-openembedded/meta-python \
+ ##OEROOT##/meta-openembedded/meta-webserver \
+ ##OEROOT##/meta-phosphor \
+ ##OEROOT##/meta-aspeed \
+ ##OEROOT##/meta-x86 \
+ ##OEROOT##/meta-quanta \
+ ##OEROOT##/meta-quanta/meta-q71l \
+ "
diff --git a/meta-quanta/meta-q71l/conf/conf-notes.txt b/meta-quanta/meta-q71l/conf/conf-notes.txt
new file mode 100644
index 000000000..9b3c01a55
--- /dev/null
+++ b/meta-quanta/meta-q71l/conf/conf-notes.txt
@@ -0,0 +1,2 @@
+Common targets are:
+ obmc-phosphor-image
diff --git a/meta-quanta/meta-q71l/conf/layer.conf b/meta-quanta/meta-q71l/conf/layer.conf
new file mode 100644
index 000000000..80bae52e9
--- /dev/null
+++ b/meta-quanta/meta-q71l/conf/layer.conf
@@ -0,0 +1,9 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "q71l"
+BBFILE_PATTERN_q71l = ""
diff --git a/meta-quanta/meta-q71l/conf/local.conf.sample b/meta-quanta/meta-q71l/conf/local.conf.sample
new file mode 100644
index 000000000..8862b5c68
--- /dev/null
+++ b/meta-quanta/meta-q71l/conf/local.conf.sample
@@ -0,0 +1,21 @@
+MACHINE ??= "quanta-q71l"
+DISTRO ?= "openbmc-phosphor"
+PACKAGE_CLASSES ?= "package_rpm"
+SANITY_TESTED_DISTROS_append ?= " RedHatEnterpriseWorkstation-6.*"
+EXTRA_IMAGE_FEATURES = "debug-tweaks"
+USER_CLASSES ?= "buildstats image-mklibs image-prelink"
+PATCHRESOLVE = "noop"
+BB_DISKMON_DIRS = "\
+ STOPTASKS,${TMPDIR},1G,100K \
+ STOPTASKS,${DL_DIR},1G,100K \
+ STOPTASKS,${SSTATE_DIR},1G,100K \
+ STOPTASKS,/tmp,100M,100K \
+ ABORT,${TMPDIR},100M,1K \
+ ABORT,${DL_DIR},100M,1K \
+ ABORT,${SSTATE_DIR},100M,1K \
+ ABORT,/tmp,10M,1K"
+CONF_VERSION = "1"
+INHERIT += "extrausers"
+EXTRA_USERS_PARAMS = " \
+ usermod -p '\$1\$UGMqyqdG\$FZiylVFmRRfl9Z0Ue8G7e/' root; \
+ "
diff --git a/meta-quanta/meta-q71l/conf/machine/quanta-q71l.conf b/meta-quanta/meta-q71l/conf/machine/quanta-q71l.conf
new file mode 100644
index 000000000..b36a09821
--- /dev/null
+++ b/meta-quanta/meta-q71l/conf/machine/quanta-q71l.conf
@@ -0,0 +1,38 @@
+KMACHINE = "aspeed"
+KERNEL_DEVICETREE = "${KMACHINE}-bmc-${MACHINE}.dtb"
+
+require conf/machine/include/ast2400.inc
+require conf/machine/include/obmc-bsp-common.inc
+
+UBOOT_MACHINE_palmetto = "ast_g4_ncsi_config"
+UBOOT_ENTRYPOINT = "0x40008000"
+UBOOT_LOADADDRESS = "0x40008000"
+
+FLASH_SIZE = "32768"
+
+# If we included the openpower.inc we'd get these from that.
+#OBMC_MACHINE_FEATURES += "\
+# obmc-phosphor-fan-mgmt \
+# obmc-phosphor-chassis-mgmt \
+# obmc-phosphor-flash-mgmt \
+# obmc-host-ipmi \
+# obmc-host-ctl \
+# obmc-host-state-mgmt \
+# obmc-chassis-state-mgmt \
+# obmc-bmc-state-mgmt \
+# "
+# But we don't, and it's ok :D We're pulling in specific packages in an image recipe.
+
+# This sets up our own Quanta-q71l.py inclusion based on the Zaius.py in the skeleton repo.
+# As something temporarily required.
+VIRTUAL-RUNTIME_skeleton_workbook = "${MACHINE}-config"
+PREFERRED_PROVIDER_virtual/obmc-inventory-data ?= "${VIRTUAL-RUNTIME_skeleton_workbook}"
+
+# These are meant to include the inventory config.yaml and so on.
+PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-inventory = "q71l-ipmi-inventory-map-native"
+PREFERRED_PROVIDER_virtual/phosphor-ipmi-sensor-inventory = "q71l-ipmi-sensor-map-native"
+PREFERRED_PROVIDER_virtual/phosphor-ipmi-channel-config = "q71l-ipmi-channel-config-native"
+PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-merge-config = "q71l-ipmi-fru-merge-config-native"
+
+
+PREFERRED_PROVIDER_virtual/obmc-host-ipmi-hw = "phosphor-ipmi-bt"
OpenPOWER on IntegriCloud