summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager-config-example-native_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/leds/phosphor-led-manager-config-example-native_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/leds/phosphor-led-manager-config-example-native_git.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager-config-example-native_git.bb b/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager-config-example-native_git.bb
new file mode 100644
index 000000000..4b546d05f
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/leds/phosphor-led-manager-config-example-native_git.bb
@@ -0,0 +1,16 @@
+SUMMARY = "Phosphor LED Group Management with example data"
+PR = "r1"
+
+inherit native
+require phosphor-led-manager.inc
+
+PROVIDES += "virtual/phosphor-led-manager-config-native"
+
+S = "${WORKDIR}/git"
+
+# Copies example led layout yaml file
+do_install() {
+ SRC=${S}
+ DEST=${D}${datadir}/phosphor-led-manager
+ install -D ${SRC}/led.yaml ${DEST}/led.yaml
+}
OpenPOWER on IntegriCloud