summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor.bb b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor.bb
new file mode 100644
index 000000000..cfa684aa0
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor.bb
@@ -0,0 +1,46 @@
+SUMMARY = "Phosphor DBus Monitor"
+DESCRIPTION = "Phosphor DBus Monitor is a general purpose DBus application \
+that watches DBus traffic for events and takes actions based on those events."
+PR = "r1"
+
+HOMEPAGE = "http://github.com/openbmc/phosphor-dbus-monitor"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+SRC_URI = "git://github.com/openbmc/phosphor-dbus-monitor"
+SRCREV = "2ded5e1e3993913be34e8122f2b835468a2f9e91"
+
+inherit autotools \
+ pkgconfig \
+ pythonnative \
+ phosphor-dbus-monitor \
+ obmc-phosphor-systemd
+
+PACKAGE_BEFORE_PN = "phosphor-msl-verify"
+SYSTEMD_PACKAGES = "${PN} phosphor-msl-verify"
+SYSTEMD_SERVICE_phosphor-msl-verify = "phosphor-msl-verify.service"
+
+DEPENDS += " \
+ ${PN}-config-native \
+ phosphor-logging \
+ autoconf-archive-native \
+ sdbusplus-native \
+ gtest \
+ "
+RDEPENDS_${PN} += " \
+ sdbusplus \
+ phosphor-dbus-interfaces \
+ phosphor-logging \
+ "
+
+RDEPENDS_phosphor-msl-verify += " \
+ sdbusplus \
+ phosphor-dbus-interfaces \
+ phosphor-logging \
+ "
+FILES_phosphor-msl-verify = "${sbindir}/phosphor-msl-verify"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OECONF = " \
+ YAML_PATH=${STAGING_DIR_NATIVE}${config_dir} \
+ "
OpenPOWER on IntegriCloud