summaryrefslogtreecommitdiffstats
path: root/meta-openpower/recipes-phosphor
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/recipes-phosphor')
-rw-r--r--meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd.bb47
-rw-r--r--[l---------]meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd_git.bb49
2 files changed, 48 insertions, 48 deletions
diff --git a/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd.bb b/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd.bb
deleted file mode 100644
index 4d7114a73..000000000
--- a/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd.bb
+++ /dev/null
@@ -1,47 +0,0 @@
-SUMMARY = "Parser for OpenPOWER-format FRU VPD"
-DESCRIPTION = "Parse OpenPOWER-format FRU VPD and update inventory"
-PR = "r1"
-
-inherit autotools pkgconfig
-inherit openpower-fru-vpd
-inherit pythonnative
-inherit obmc-phosphor-systemd
-
-require ${PN}.inc
-
-SRC_URI += "file://70-op-vpd.rules"
-
-DEPENDS += " \
- virtual/openpower-fru-vpd-layout \
- virtual/openpower-fru-inventory \
- virtual/openpower-fru-properties \
- sdbusplus \
- phosphor-logging \
- python-mako-native \
- python-pyyaml-native \
- autoconf-archive-native \
- "
-
-RDEPENDS_${PN} += " \
- sdbusplus \
- phosphor-logging \
- "
-
-SYSTEMD_SERVICE_${PN} += "op-vpd-parser.service"
-
-S = "${WORKDIR}/git"
-
-EXTRA_OECONF = " \
- FRU_YAML=${STAGING_DIR_NATIVE}${vpdlayout_datadir}/layout.yaml \
- PROP_YAML=${STAGING_DIR_NATIVE}${properties_datadir}/out.yaml \
- "
-
-do_install_append() {
- SRC=${STAGING_DATADIR_NATIVE}${inventory_datadir_name}
- DEST=${D}${inventory_envdir}
- install -d ${DEST}
- install ${SRC}/inventory ${DEST}
-
- install -d ${D}/${base_libdir}/udev/rules.d/
- install ${WORKDIR}/70-op-vpd.rules ${D}/${base_libdir}/udev/rules.d/
-}
diff --git a/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd_git.bb b/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd_git.bb
index b3ebcd6a1..c9d3b66c0 120000..100644
--- a/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd_git.bb
+++ b/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd_git.bb
@@ -1 +1,48 @@
-openpower-fru-vpd.bb \ No newline at end of file
+SUMMARY = "Parser for OpenPOWER-format FRU VPD"
+DESCRIPTION = "Parse OpenPOWER-format FRU VPD and update inventory"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+
+inherit autotools pkgconfig
+inherit openpower-fru-vpd
+inherit pythonnative
+inherit obmc-phosphor-systemd
+
+require ${PN}.inc
+
+SRC_URI += "file://70-op-vpd.rules"
+
+DEPENDS += " \
+ virtual/openpower-fru-vpd-layout \
+ virtual/openpower-fru-inventory \
+ virtual/openpower-fru-properties \
+ sdbusplus \
+ phosphor-logging \
+ python-mako-native \
+ python-pyyaml-native \
+ autoconf-archive-native \
+ "
+
+RDEPENDS_${PN} += " \
+ sdbusplus \
+ phosphor-logging \
+ "
+
+SYSTEMD_SERVICE_${PN} += "op-vpd-parser.service"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OECONF = " \
+ FRU_YAML=${STAGING_DIR_NATIVE}${vpdlayout_datadir}/layout.yaml \
+ PROP_YAML=${STAGING_DIR_NATIVE}${properties_datadir}/out.yaml \
+ "
+
+do_install_append() {
+ SRC=${STAGING_DATADIR_NATIVE}${inventory_datadir_name}
+ DEST=${D}${inventory_envdir}
+ install -d ${DEST}
+ install ${SRC}/inventory ${DEST}
+
+ install -d ${D}/${base_libdir}/udev/rules.d/
+ install ${WORKDIR}/70-op-vpd.rules ${D}/${base_libdir}/udev/rules.d/
+}
OpenPOWER on IntegriCloud