summaryrefslogtreecommitdiffstats
path: root/meta-openpower/common/recipes-phosphor/host/p9-host-start.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/common/recipes-phosphor/host/p9-host-start.bb')
-rw-r--r--meta-openpower/common/recipes-phosphor/host/p9-host-start.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-openpower/common/recipes-phosphor/host/p9-host-start.bb b/meta-openpower/common/recipes-phosphor/host/p9-host-start.bb
new file mode 100644
index 000000000..24b1b9c1f
--- /dev/null
+++ b/meta-openpower/common/recipes-phosphor/host/p9-host-start.bb
@@ -0,0 +1,23 @@
+SUMMARY = "POWER9 start host"
+DESCRIPTION = "Service to start POWER9 IPL through SBE"
+PR = "r1"
+
+inherit obmc-phosphor-systemd
+inherit obmc-phosphor-license
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/op-host-control:"
+
+PROVIDES += 'virtual/obmc-host-ctl'
+RPROVIDES_${PN} += 'virtual-obmc-host-ctl'
+
+RDEPENDS_${PN} += "p9-vcs-workaround op-proc-control"
+
+S = "${WORKDIR}"
+
+TMPL = "start_host@.service"
+INSTFMT = "start_host@{0}.service"
+TGTFMT = "obmc-host-startmin@{0}.target"
+FMT = "../${TMPL}:${TGTFMT}.requires/${INSTFMT}"
+
+SYSTEMD_SERVICE_${PN} += "${TMPL}"
+SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
OpenPOWER on IntegriCloud