summaryrefslogtreecommitdiffstats
path: root/meta-openpower/common/recipes-phosphor/host/hostboot-settings.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/common/recipes-phosphor/host/hostboot-settings.bb')
-rw-r--r--meta-openpower/common/recipes-phosphor/host/hostboot-settings.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-openpower/common/recipes-phosphor/host/hostboot-settings.bb b/meta-openpower/common/recipes-phosphor/host/hostboot-settings.bb
new file mode 100644
index 000000000..39beb480c
--- /dev/null
+++ b/meta-openpower/common/recipes-phosphor/host/hostboot-settings.bb
@@ -0,0 +1,19 @@
+SUMMARY = "OpenPower Hostboot Boot settings tool"
+PR = "r1"
+
+inherit obmc-phosphor-license
+inherit obmc-phosphor-systemd
+inherit allarch
+
+SRC_URI = "file://hb_settings"
+SYSTEMD_SERVICE_${PN} += "hostboot-settings.service"
+
+do_fetch[noexec] = "1"
+do_patch[noexec] = "1"
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/hb_settings ${D}${bindir}
+}
OpenPOWER on IntegriCloud