summaryrefslogtreecommitdiffstats
path: root/meta-openembedded/meta-oe/recipes-navigation/geos/files
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-navigation/geos/files')
-rw-r--r--meta-openembedded/meta-oe/recipes-navigation/geos/files/fix-gcc6-isnan.patch22
-rw-r--r--meta-openembedded/meta-oe/recipes-navigation/geos/files/geos-config-Add-includedir-variable.patch39
2 files changed, 61 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-navigation/geos/files/fix-gcc6-isnan.patch b/meta-openembedded/meta-oe/recipes-navigation/geos/files/fix-gcc6-isnan.patch
new file mode 100644
index 000000000..5c5fbd1d9
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-navigation/geos/files/fix-gcc6-isnan.patch
@@ -0,0 +1,22 @@
+--- geos-3.4.2/configure.in.orig 2016-06-08 17:46:43.002250304 +0000
++++ geos-3.4.2/configure.in 2016-06-08 17:57:36.342241606 +0000
+@@ -197,7 +197,7 @@
+ AC_LANG_PUSH([C++])
+ AC_CACHE_CHECK([for isnan], ac_cv_isnan,
+ [AC_TRY_LINK([#include <cmath>],
+- [double x; int y; y = isnan(x);],
++ [double x; int y; y = std::isnan(x);],
+ ac_cv_isnan=yes,
+ ac_cv_isnan=no
+ )])
+--- geos-3.4.2/include/geos/platform.h.in.orig 2016-06-08 14:06:53.910234182 -0400
++++ geos-3.4.2/include/geos/platform.h.in 2016-06-08 14:07:19.298233844 -0400
+@@ -84,7 +84,7 @@
+ #endif
+
+ #if defined(HAVE_ISNAN)
+-# define ISNAN(x) (isnan(x))
++# define ISNAN(x) (std::isnan(x))
+ #else
+ # if defined(_MSC_VER)
+ # define ISNAN(x) _isnan(x)
diff --git a/meta-openembedded/meta-oe/recipes-navigation/geos/files/geos-config-Add-includedir-variable.patch b/meta-openembedded/meta-oe/recipes-navigation/geos/files/geos-config-Add-includedir-variable.patch
new file mode 100644
index 000000000..645e6f62a
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-navigation/geos/files/geos-config-Add-includedir-variable.patch
@@ -0,0 +1,39 @@
+From 9d51027c228dafd7db2d0cffca1f0fc695e950fd Mon Sep 17 00:00:00 2001
+From: Otavio Salvador <otavio@ossystems.com.br>
+Date: Mon, 2 Dec 2013 11:33:26 -0200
+Subject: [PATCH] geos-config: Add includedir variable
+
+This fixes cross-compile as it is easier to mangle the includedir
+during sysroot generation.
+
+Upstream-Status: Pending
+
+Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
+---
+ tools/geos-config.in | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/tools/geos-config.in b/tools/geos-config.in
+index 9b45b5f..1749892 100644
+--- a/tools/geos-config.in
++++ b/tools/geos-config.in
+@@ -1,6 +1,7 @@
+ #!/bin/sh
+ prefix=@prefix@
+ exec_prefix=@exec_prefix@
++includedir=@includedir@
+ libdir=@libdir@
+
+ usage()
+@@ -38,7 +39,7 @@ case $1 in
+ echo @VERSION@
+ ;;
+ --cflags)
+- echo -I${prefix}/include
++ echo -I${includedir}
+ ;;
+ --libs)
+ # TODO: make an alias for --clibs
+--
+1.7.10.4
+
OpenPOWER on IntegriCloud