summaryrefslogtreecommitdiffstats
path: root/meta-openembedded/meta-filesystems/recipes-support
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-filesystems/recipes-support')
-rw-r--r--meta-openembedded/meta-filesystems/recipes-support/fuse/files/CVE-2018-10906-1.patch52
-rw-r--r--meta-openembedded/meta-filesystems/recipes-support/fuse/files/CVE-2018-10906-2.patch48
-rw-r--r--meta-openembedded/meta-filesystems/recipes-support/fuse/fuse_2.9.8.bb (renamed from meta-openembedded/meta-filesystems/recipes-support/fuse/fuse_2.9.7.bb)17
-rw-r--r--meta-openembedded/meta-filesystems/recipes-support/physfs/physfs_3.0.1.bb (renamed from meta-openembedded/meta-filesystems/recipes-support/physfs/physfs_2.0.3.bb)6
4 files changed, 12 insertions, 111 deletions
diff --git a/meta-openembedded/meta-filesystems/recipes-support/fuse/files/CVE-2018-10906-1.patch b/meta-openembedded/meta-filesystems/recipes-support/fuse/files/CVE-2018-10906-1.patch
deleted file mode 100644
index 83bef3022..000000000
--- a/meta-openembedded/meta-filesystems/recipes-support/fuse/files/CVE-2018-10906-1.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-From 28bdae3d113ef479c1660a581ef720cdc33bf466 Mon Sep 17 00:00:00 2001
-From: Jann Horn <jannh@google.com>
-Date: Fri, 13 Jul 2018 15:15:36 -0700
-Subject: [PATCH] fusermount: don't feed "escaped commas" into mount options
-
-The old code permits the following behavior:
-
-$ _FUSE_COMMFD=10000 priv_strace -etrace=mount -s200 fusermount -o 'foobar=\,allow_other' mount
-mount("/dev/fuse", ".", "fuse", MS_NOSUID|MS_NODEV, "foobar=\\,allow_other,fd=3,rootmode=40000,user_id=1000,group_id=1000") = -1 EINVAL (Invalid argument)
-
-However, backslashes do not have any special meaning for the kernel here.
-
-As it happens, you can't abuse this because there is no FUSE mount option
-that takes a string value that can contain backslashes; but this is very
-brittle. Don't interpret "escape characters" in places where they don't
-work.
-
-CVE: CVE-2018-10906
-Upstream-Status: Backport [https://github.com/libfuse/libfuse/commit/28bdae3d113ef479c1660a581ef720cdc33bf466]
-
-Signed-off-by: Jagadeesh Krishnanjanappa <jkrishnanjanappa@mvista.com>
----
- util/fusermount.c | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/util/fusermount.c b/util/fusermount.c
-index 0e1d34d..143bd4a 100644
---- a/util/fusermount.c
-+++ b/util/fusermount.c
-@@ -29,6 +29,7 @@
- #include <sys/socket.h>
- #include <sys/utsname.h>
- #include <sched.h>
-+#include <stdbool.h>
-
- #define FUSE_COMMFD_ENV "_FUSE_COMMFD"
-
-@@ -754,8 +755,10 @@ static int do_mount(const char *mnt, char **typep, mode_t rootmode,
- unsigned len;
- const char *fsname_str = "fsname=";
- const char *subtype_str = "subtype=";
-+ bool escape_ok = begins_with(s, fsname_str) ||
-+ begins_with(s, subtype_str);
- for (len = 0; s[len]; len++) {
-- if (s[len] == '\\' && s[len + 1])
-+ if (escape_ok && s[len] == '\\' && s[len + 1])
- len++;
- else if (s[len] == ',')
- break;
---
-2.13.3
-
diff --git a/meta-openembedded/meta-filesystems/recipes-support/fuse/files/CVE-2018-10906-2.patch b/meta-openembedded/meta-filesystems/recipes-support/fuse/files/CVE-2018-10906-2.patch
deleted file mode 100644
index 104aa171b..000000000
--- a/meta-openembedded/meta-filesystems/recipes-support/fuse/files/CVE-2018-10906-2.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From 5018a0c016495155ee598b7e0167b43d5d902414 Mon Sep 17 00:00:00 2001
-From: Jann Horn <jannh@google.com>
-Date: Sat, 14 Jul 2018 03:47:50 -0700
-Subject: [PATCH] fusermount: refuse unknown options
-
-Blacklists are notoriously fragile; especially if the kernel wishes to add
-some security-critical mount option at a later date, all existing systems
-with older versions of fusermount installed will suddenly have a security
-problem.
-Additionally, if the kernel's option parsing became a tiny bit laxer, the
-blacklist could probably be bypassed.
-
-Whitelist known-harmless flags instead, even if it's slightly more
-inconvenient.
-
-CVE: CVE-2018-10906
-Upstream-Status: Backport [https://github.com/libfuse/libfuse/commit/5018a0c016495155ee598b7e0167b43d5d902414]
-
-Signed-off-by: Jagadeesh Krishnanjanappa <jkrishnanjanappa@mvista.com>
----
- util/fusermount.c | 8 +++++++-
- 1 file changed, 7 insertions(+), 1 deletion(-)
-
-diff --git a/util/fusermount.c b/util/fusermount.c
-index 4e0f51a..2792407 100644
---- a/util/fusermount.c
-+++ b/util/fusermount.c
-@@ -819,10 +819,16 @@ static int do_mount(const char *mnt, char **typep, mode_t rootmode,
- flags |= flag;
- else
- flags &= ~flag;
-- } else {
-+ } else if (opt_eq(s, len, "default_permissions") ||
-+ opt_eq(s, len, "allow_other") ||
-+ begins_with(s, "max_read=") ||
-+ begins_with(s, "blksize=")) {
- memcpy(d, s, len);
- d += len;
- *d++ = ',';
-+ } else {
-+ fprintf(stderr, "%s: unknown option '%.*s'\n", progname, len, s);
-+ exit(1);
- }
- }
- }
---
-2.13.3
-
diff --git a/meta-openembedded/meta-filesystems/recipes-support/fuse/fuse_2.9.7.bb b/meta-openembedded/meta-filesystems/recipes-support/fuse/fuse_2.9.8.bb
index 1eb9b7007..caa75c7f5 100644
--- a/meta-openembedded/meta-filesystems/recipes-support/fuse/fuse_2.9.7.bb
+++ b/meta-openembedded/meta-filesystems/recipes-support/fuse/fuse_2.9.8.bb
@@ -15,11 +15,12 @@ SRC_URI = "https://github.com/libfuse/libfuse/releases/download/${BP}/${BP}.tar.
file://aarch64.patch \
file://0001-fuse-fix-the-return-value-of-help-option.patch \
file://fuse.conf \
- file://CVE-2018-10906-1.patch \
- file://CVE-2018-10906-2.patch \
"
-SRC_URI[md5sum] = "9bd4ce8184745fd3d000ca2692adacdb"
-SRC_URI[sha256sum] = "832432d1ad4f833c20e13b57cf40ce5277a9d33e483205fc63c78111b3358874"
+SRC_URI[md5sum] = "f365e848a82504edb0b7a33df790ca78"
+SRC_URI[sha256sum] = "5e84f81d8dd527ea74f39b6bc001c874c02bad6871d7a9b0c14efb57430eafe3"
+
+UPSTREAM_CHECK_URI = "https://github.com/libfuse/libfuse/releases"
+UPSTREAM_CHECK_REGEX = "fuse\-(?P<pver>2(\.\d+)+).tar.gz"
inherit autotools pkgconfig update-rc.d systemd
@@ -30,7 +31,9 @@ SYSTEMD_SERVICE_${PN} = ""
DEPENDS = "gettext-native"
-PACKAGES =+ "fuse-utils-dbg fuse-utils libulockmgr libulockmgr-dev libulockmgr-dbg"
+PACKAGES =+ "fuse-utils libulockmgr libulockmgr-dev"
+
+RPROVIDES_${PN}-dbg += "fuse-utils-dbg libulockmgr-dbg"
RRECOMMENDS_${PN}_class-target = "kernel-module-fuse libulockmgr fuse-utils"
@@ -39,13 +42,11 @@ FILES_${PN}-dev += "${libdir}/libfuse*.la"
FILES_libulockmgr = "${libdir}/libulockmgr.so.*"
FILES_libulockmgr-dev += "${libdir}/libulock*.la"
-FILES_libulockmgr-dbg += "${libdir}/.debug/libulock*"
# Forbid auto-renaming to libfuse-utils
FILES_fuse-utils = "${bindir} ${base_sbindir}"
-FILES_fuse-utils-dbg = "${bindir}/.debug ${base_sbindir}/.debug"
DEBIAN_NOAUTONAME_fuse-utils = "1"
-DEBIAN_NOAUTONAME_fuse-utils-dbg = "1"
+DEBIAN_NOAUTONAME_${PN}-dbg = "1"
do_configure_prepend() {
# Make this explicit so overriding base_sbindir propagates properly.
diff --git a/meta-openembedded/meta-filesystems/recipes-support/physfs/physfs_2.0.3.bb b/meta-openembedded/meta-filesystems/recipes-support/physfs/physfs_3.0.1.bb
index dc2c10649..cc97dead5 100644
--- a/meta-openembedded/meta-filesystems/recipes-support/physfs/physfs_2.0.3.bb
+++ b/meta-openembedded/meta-filesystems/recipes-support/physfs/physfs_3.0.1.bb
@@ -1,7 +1,7 @@
SUMMARY = "PhysicsFS is a library to provide abstract access to various archives"
HOMEAPAGE = "http://icculus.org/physfs"
LICENSE = "Zlib"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5d94e3eaaa10b00ca803ba35a3e87cde"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2668e2fb051c3e564198e146a9a2d9f0"
DEPENDS = "readline zlib"
inherit cmake
@@ -9,5 +9,5 @@ inherit cmake
PE = "1"
SRC_URI = "http://icculus.org/${BPN}/downloads/${BP}.tar.bz2"
-SRC_URI[md5sum] = "c2c727a8a8deb623b521b52d0080f613"
-SRC_URI[sha256sum] = "ca862097c0fb451f2cacd286194d071289342c107b6fe69079c079883ff66b69"
+SRC_URI[md5sum] = "359f102bcbd62accf84ef32f4863255d"
+SRC_URI[sha256sum] = "b77b9f853168d9636a44f75fca372b363106f52d789d18a2f776397bf117f2f1"
OpenPOWER on IntegriCloud