summaryrefslogtreecommitdiffstats
path: root/meta-openbmc-machines/meta-openpower/common
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openbmc-machines/meta-openpower/common')
-rw-r--r--meta-openbmc-machines/meta-openpower/common/recipes-phosphor/occ/openpower-occ-control-config-mrw-native.bb3
-rw-r--r--meta-openbmc-machines/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-inventory-mrw-native.bb3
-rw-r--r--meta-openbmc-machines/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-properties-mrw-native.bb3
3 files changed, 6 insertions, 3 deletions
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/occ/openpower-occ-control-config-mrw-native.bb b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/occ/openpower-occ-control-config-mrw-native.bb
index aa831a58a..887b74163 100644
--- a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/occ/openpower-occ-control-config-mrw-native.bb
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/occ/openpower-occ-control-config-mrw-native.bb
@@ -5,6 +5,7 @@ inherit native
inherit obmc-phosphor-utils
inherit obmc-phosphor-license
inherit openpower-occ-control
+inherit mrw-xml
PROVIDES += "virtual/openpower-occ-control-config-native"
DEPENDS += "mrw-native mrw-perl-tools-native"
@@ -14,6 +15,6 @@ do_install_append() {
install -d ${YAML_DEST}/
${STAGING_BINDIR_NATIVE}/perl-native/perl \
${STAGING_BINDIR_NATIVE}/gen_occ_map.pl \
- -i ${STAGING_DATADIR_NATIVE}/obmc-mrw/${MACHINE}.xml \
+ -i ${mrw_datadir}/${MRW_XML} \
-o ${YAML_DEST}/occ_sensor.yaml
}
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-inventory-mrw-native.bb b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-inventory-mrw-native.bb
index 01ed362d6..6eb76ac4e 100644
--- a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-inventory-mrw-native.bb
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-inventory-mrw-native.bb
@@ -4,6 +4,7 @@ PR = "r1"
inherit native
inherit obmc-phosphor-license
inherit openpower-fru-vpd
+inherit mrw-xml
DEPENDS += " \
mrw-native \
@@ -21,7 +22,7 @@ do_install() {
${bindir}/perl-native/perl \
${bindir}/gen_openpower_fru.pl \
- -m ${datadir}/obmc-mrw/${MACHINE}.xml \
+ -m ${mrw_datadir}/${MRW_XML} \
-c ${vpdlayout_datadir}/layout.yaml \
-o ${DEST}/inventory
}
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-properties-mrw-native.bb b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-properties-mrw-native.bb
index 71194848d..2dc5820e3 100644
--- a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-properties-mrw-native.bb
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-properties-mrw-native.bb
@@ -4,6 +4,7 @@ PR = "r1"
inherit native
inherit obmc-phosphor-license
inherit openpower-fru-vpd
+inherit mrw-xml
SRC_URI += "file://config.yaml"
@@ -22,7 +23,7 @@ do_install() {
${bindir}/perl-native/perl \
${bindir}/gen_fru_properties.pl \
- -m ${datadir}/obmc-mrw/${MACHINE}.xml \
+ -m ${mrw_datadir}/${MRW_XML} \
-c config.yaml \
-o ${DEST}/out.yaml
}
OpenPOWER on IntegriCloud