summaryrefslogtreecommitdiffstats
path: root/poky/meta-yocto-bsp/conf
diff options
context:
space:
mode:
authorDave Cobbley <david.j.cobbley@linux.intel.com>2018-08-14 10:05:37 -0700
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-22 21:26:31 -0400
commiteb8dc40360f0cfef56fb6947cc817a547d6d9bc6 (patch)
treede291a73dc37168da6370e2cf16c347d1eba9df8 /poky/meta-yocto-bsp/conf
parent9c3cf826d853102535ead04cebc2d6023eff3032 (diff)
downloadtalos-openbmc-eb8dc40360f0cfef56fb6947cc817a547d6d9bc6.tar.gz
talos-openbmc-eb8dc40360f0cfef56fb6947cc817a547d6d9bc6.zip
[Subtree] Removing import-layers directory
As part of the move to subtrees, need to bring all the import layers content to the top level. Change-Id: I4a163d10898cbc6e11c27f776f60e1a470049d8f Signed-off-by: Dave Cobbley <david.j.cobbley@linux.intel.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'poky/meta-yocto-bsp/conf')
-rw-r--r--poky/meta-yocto-bsp/conf/layer.conf12
-rw-r--r--poky/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf40
-rw-r--r--poky/meta-yocto-bsp/conf/machine/edgerouter.conf26
-rw-r--r--poky/meta-yocto-bsp/conf/machine/genericx86-64.conf10
-rw-r--r--poky/meta-yocto-bsp/conf/machine/genericx86.conf10
-rw-r--r--poky/meta-yocto-bsp/conf/machine/include/genericx86-common.inc25
-rw-r--r--poky/meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf35
7 files changed, 158 insertions, 0 deletions
diff --git a/poky/meta-yocto-bsp/conf/layer.conf b/poky/meta-yocto-bsp/conf/layer.conf
new file mode 100644
index 000000000..6472238e6
--- /dev/null
+++ b/poky/meta-yocto-bsp/conf/layer.conf
@@ -0,0 +1,12 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "yoctobsp"
+BBFILE_PATTERN_yoctobsp = "^${LAYERDIR}/"
+BBFILE_PRIORITY_yoctobsp = "5"
+LAYERVERSION_yoctobsp = "4"
+LAYERSERIES_COMPAT_yoctobsp = "sumo"
diff --git a/poky/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf b/poky/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf
new file mode 100644
index 000000000..ae682a47d
--- /dev/null
+++ b/poky/meta-yocto-bsp/conf/machine/beaglebone-yocto.conf
@@ -0,0 +1,40 @@
+#@TYPE: Machine
+#@NAME: Beaglebone-yocto machine
+#@DESCRIPTION: Reference machine configuration for http://beagleboard.org/bone and http://beagleboard.org/black boards
+
+PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
+XSERVER ?= "xserver-xorg \
+ xf86-video-modesetting \
+ "
+
+MACHINE_EXTRA_RRECOMMENDS = "kernel-modules kernel-devicetree"
+
+EXTRA_IMAGEDEPENDS += "u-boot"
+
+DEFAULTTUNE ?= "cortexa8hf-neon"
+include conf/machine/include/tune-cortexa8.inc
+
+IMAGE_FSTYPES += "tar.bz2 jffs2 wic wic.bmap"
+EXTRA_IMAGECMD_jffs2 = "-lnp "
+WKS_FILE ?= "beaglebone-yocto.wks"
+IMAGE_INSTALL_append = " kernel-devicetree kernel-image-zimage"
+do_image_wic[depends] += "mtools-native:do_populate_sysroot dosfstools-native:do_populate_sysroot"
+
+SERIAL_CONSOLE = "115200 ttyO0"
+
+PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
+PREFERRED_VERSION_linux-yocto ?= "4.15%"
+
+KERNEL_IMAGETYPE = "zImage"
+KERNEL_DEVICETREE = "am335x-bone.dtb am335x-boneblack.dtb am335x-bonegreen.dtb"
+KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}"
+
+SPL_BINARY = "MLO"
+UBOOT_SUFFIX = "img"
+UBOOT_MACHINE = "am335x_boneblack_config"
+UBOOT_ENTRYPOINT = "0x80008000"
+UBOOT_LOADADDRESS = "0x80008000"
+
+MACHINE_FEATURES = "usbgadget usbhost vfat alsa"
+
+IMAGE_BOOT_FILES ?= "u-boot.${UBOOT_SUFFIX} MLO"
diff --git a/poky/meta-yocto-bsp/conf/machine/edgerouter.conf b/poky/meta-yocto-bsp/conf/machine/edgerouter.conf
new file mode 100644
index 000000000..61f2145fd
--- /dev/null
+++ b/poky/meta-yocto-bsp/conf/machine/edgerouter.conf
@@ -0,0 +1,26 @@
+#@TYPE: Machine
+#@NAME: Edgerouter
+#@DESCRIPTION: Edgerouter
+
+require conf/machine/include/tune-mips64.inc
+
+MACHINE_FEATURES = "pci ext2 ext3 serial"
+
+KERNEL_IMAGETYPE = "vmlinux"
+KERNEL_ALT_IMAGETYPE = "vmlinux.bin"
+KERNEL_IMAGE_STRIP_EXTRA_SECTIONS = ".comment"
+
+PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
+PREFERRED_VERSION_linux-yocto ?= "4.15%"
+
+SERIAL_CONSOLE = "115200 ttyS0"
+USE_VT ?= "0"
+
+MACHINE_EXTRA_RRECOMMENDS = "kernel-modules"
+
+IMAGE_FSTYPES ?= "jffs2 tar.bz2 wic wic.bmap"
+JFFS2_ERASEBLOCK = "0x10000"
+
+WKS_FILE ?= "edgerouter.wks"
+IMAGE_BOOT_FILES ?= "vmlinux;vmlinux.64"
+do_image_wic[depends] += "mtools-native:do_populate_sysroot dosfstools-native:do_populate_sysroot"
diff --git a/poky/meta-yocto-bsp/conf/machine/genericx86-64.conf b/poky/meta-yocto-bsp/conf/machine/genericx86-64.conf
new file mode 100644
index 000000000..12f7c0d20
--- /dev/null
+++ b/poky/meta-yocto-bsp/conf/machine/genericx86-64.conf
@@ -0,0 +1,10 @@
+#@TYPE: Machine
+#@NAME: Generic X86_64.
+
+#@DESCRIPTION: Machine configuration for generic X86_64 (64-bit) PCs and servers. Supports a moderately wide range of drivers that should boot and be usable on "typical" hardware.
+
+DEFAULTTUNE ?= "core2-64"
+require conf/machine/include/tune-core2.inc
+require conf/machine/include/genericx86-common.inc
+
+SERIAL_CONSOLES_CHECK = "ttyS0"
diff --git a/poky/meta-yocto-bsp/conf/machine/genericx86.conf b/poky/meta-yocto-bsp/conf/machine/genericx86.conf
new file mode 100644
index 000000000..798b62ec2
--- /dev/null
+++ b/poky/meta-yocto-bsp/conf/machine/genericx86.conf
@@ -0,0 +1,10 @@
+#@TYPE: Machine
+#@NAME: Generic X86.
+
+#@DESCRIPTION: Machine configuration for generic X86 (32-bit) PCs. Supports a moderately wide range of drivers that should boot and be usable on "typical" hardware.
+
+DEFAULTTUNE ?= "core2-32"
+require conf/machine/include/tune-core2.inc
+require conf/machine/include/genericx86-common.inc
+
+MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += "gma500-gfx-check"
diff --git a/poky/meta-yocto-bsp/conf/machine/include/genericx86-common.inc b/poky/meta-yocto-bsp/conf/machine/include/genericx86-common.inc
new file mode 100644
index 000000000..e35685cb2
--- /dev/null
+++ b/poky/meta-yocto-bsp/conf/machine/include/genericx86-common.inc
@@ -0,0 +1,25 @@
+include conf/machine/include/x86-base.inc
+require conf/machine/include/qemuboot-x86.inc
+MACHINE_FEATURES += "wifi efi pcbios"
+
+PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
+PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
+XSERVER ?= "${XSERVER_X86_BASE} \
+ ${XSERVER_X86_EXT} \
+ ${XSERVER_X86_I915} \
+ ${XSERVER_X86_I965} \
+ ${XSERVER_X86_FBDEV} \
+ ${XSERVER_X86_VESA} \
+ ${XSERVER_X86_MODESETTING} \
+ "
+
+MACHINE_EXTRA_RRECOMMENDS += "linux-firmware eee-acpi-scripts"
+
+GLIBC_ADDONS = "nptl"
+
+EXTRA_OECONF_append_pn-matchbox-panel-2 = " --with-battery=acpi"
+
+IMAGE_FSTYPES += "wic wic.bmap"
+WKS_FILE ?= "genericx86.wks"
+do_image_wic[depends] += "gptfdisk-native:do_populate_sysroot"
+do_image_wic[recrdeptask] += "do_bootimg"
diff --git a/poky/meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf b/poky/meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf
new file mode 100644
index 000000000..34f12303a
--- /dev/null
+++ b/poky/meta-yocto-bsp/conf/machine/mpc8315e-rdb.conf
@@ -0,0 +1,35 @@
+#@TYPE: Machine
+#@DESCRIPTION: Machine configuration for running
+
+TARGET_FPU = ""
+
+require conf/machine/include/tune-ppce300c3.inc
+
+KERNEL_IMAGETYPE = "uImage"
+
+EXTRA_IMAGEDEPENDS += "u-boot"
+UBOOT_MACHINE = "MPC8315ERDB_config"
+
+SERIAL_CONSOLE = "115200 ttyS0"
+
+MACHINE_FEATURES = "keyboard pci ext2 ext3 serial"
+
+PREFERRED_VERSION_linux-yocto ?= "4.15%"
+PREFERRED_PROVIDER_virtual/kernel = "linux-yocto"
+
+PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
+XSERVER ?= "xserver-xorg \
+ xf86-video-fbdev"
+
+UBOOT_ENTRYPOINT = "0x00000000"
+
+KERNEL_DEVICETREE = "mpc8315erdb.dtb"
+
+MACHINE_EXTRA_RRECOMMENDS = "kernel-modules"
+
+IMAGE_FSTYPES ?= "jffs2 tar.bz2"
+JFFS2_ERASEBLOCK = "0x4000"
+
+IMAGE_FSTYPES += "wic wic.bmap"
+WKS_FILE ?= 'mpc8315e-rdb.wks'
+IMAGE_BOOT_FILES ?= "u-boot.bin uImage uImage-mpc8315erdb.dtb;dtb"
OpenPOWER on IntegriCloud