summaryrefslogtreecommitdiffstats
path: root/meta-security/recipes-security/keynote/keynote_2.3.bb
diff options
context:
space:
mode:
authorDave Cobbley <david.j.cobbley@linux.intel.com>2018-08-14 10:05:37 -0700
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-22 21:26:31 -0400
commiteb8dc40360f0cfef56fb6947cc817a547d6d9bc6 (patch)
treede291a73dc37168da6370e2cf16c347d1eba9df8 /meta-security/recipes-security/keynote/keynote_2.3.bb
parent9c3cf826d853102535ead04cebc2d6023eff3032 (diff)
downloadtalos-openbmc-eb8dc40360f0cfef56fb6947cc817a547d6d9bc6.tar.gz
talos-openbmc-eb8dc40360f0cfef56fb6947cc817a547d6d9bc6.zip
[Subtree] Removing import-layers directory
As part of the move to subtrees, need to bring all the import layers content to the top level. Change-Id: I4a163d10898cbc6e11c27f776f60e1a470049d8f Signed-off-by: Dave Cobbley <david.j.cobbley@linux.intel.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-security/recipes-security/keynote/keynote_2.3.bb')
-rw-r--r--meta-security/recipes-security/keynote/keynote_2.3.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-security/recipes-security/keynote/keynote_2.3.bb b/meta-security/recipes-security/keynote/keynote_2.3.bb
new file mode 100644
index 000000000..e6924858d
--- /dev/null
+++ b/meta-security/recipes-security/keynote/keynote_2.3.bb
@@ -0,0 +1,40 @@
+SUMMARY = "Keynote tool and library"
+DESCRIPTION = "KeyNote is a simple and flexible trust-management \
+ system designed to work well for a variety of large- and small- \
+ scale Internet-based applications. \
+"
+HOMEPAGE = "http://www.cs.columbia.edu/~angelos/keynote.html"
+SECTION = "security"
+
+LICENSE = "ISC"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3a265095c549c1808686a676f2699c98"
+
+MAIN_ID = "${@d.getVar('PV').split('.')[0]}"
+MINOR_ID = "${@d.getVar('PV').split('.')[1]}"
+SRC_URI = "${SOURCEFORGE_MIRROR}/project/${BPN}-${MAIN_ID}-${MINOR_ID}/${BPN}_${PV}.tar.gz \
+ file://configure-remove-hardcode-path.patch \
+ file://makefile-add-ldflags.patch \
+ file://run-ptest \
+"
+S = "${WORKDIR}/${BPN}-${PV}+dfsg.orig"
+
+inherit autotools-brokensep ptest
+
+SRC_URI[md5sum] = "a14553e6ad921b5c85026ce5bec3afe7"
+SRC_URI[sha256sum] = "38d2acfa1c3630a07adcb5c8fe92d2aef7f0e6d242b8998b2bbb1c6e4c408d46"
+
+DEPENDS = "flex openssl"
+
+EXTRA_OEMAKE += "test-sample -j1"
+
+do_install() {
+ install -D -m 0755 ${S}/keynote ${D}${bindir}/keynote
+ install -D -m 0644 ${S}/libkeynote.a ${D}${libdir}/libkeynote.a
+ install -D -m 0644 ${S}/keynote.h ${D}${includedir}/keynote.h
+}
+
+do_install_ptest() {
+ install -D -m 0755 ${S}/sample-app ${D}${PTEST_PATH}
+ cp -r ${S}/testsuite ${D}${PTEST_PATH}
+ sed -i 's|@PTEST_PATH@|${PTEST_PATH}|' ${D}${PTEST_PATH}/run-ptest
+}
OpenPOWER on IntegriCloud