summaryrefslogtreecommitdiffstats
path: root/meta-security/recipes-perl/perl/libwhisker2-perl_2.5.bb
diff options
context:
space:
mode:
authorDave Cobbley <david.j.cobbley@linux.intel.com>2018-08-14 10:05:37 -0700
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-22 21:26:31 -0400
commiteb8dc40360f0cfef56fb6947cc817a547d6d9bc6 (patch)
treede291a73dc37168da6370e2cf16c347d1eba9df8 /meta-security/recipes-perl/perl/libwhisker2-perl_2.5.bb
parent9c3cf826d853102535ead04cebc2d6023eff3032 (diff)
downloadtalos-openbmc-eb8dc40360f0cfef56fb6947cc817a547d6d9bc6.tar.gz
talos-openbmc-eb8dc40360f0cfef56fb6947cc817a547d6d9bc6.zip
[Subtree] Removing import-layers directory
As part of the move to subtrees, need to bring all the import layers content to the top level. Change-Id: I4a163d10898cbc6e11c27f776f60e1a470049d8f Signed-off-by: Dave Cobbley <david.j.cobbley@linux.intel.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-security/recipes-perl/perl/libwhisker2-perl_2.5.bb')
-rw-r--r--meta-security/recipes-perl/perl/libwhisker2-perl_2.5.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-security/recipes-perl/perl/libwhisker2-perl_2.5.bb b/meta-security/recipes-perl/perl/libwhisker2-perl_2.5.bb
new file mode 100644
index 000000000..d9af4300a
--- /dev/null
+++ b/meta-security/recipes-perl/perl/libwhisker2-perl_2.5.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Libwhisker is a Perl module geared specificly for HTTP testing."
+
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=254b8e29606fce6d1c1a4c9e32354573"
+
+SRC_URI = "http://sourceforge.net/projects/whisker/files/libwhisker/${PV}/libwhisker2-${PV}.tar.gz \
+ file://libwhisker2.patch"
+
+SRC_URI[md5sum] = "7cc1718dddde8f9a439d5622ae2f37eb"
+SRC_URI[sha256sum] = "f45a1cf2ad2637b29dd1b13d7221ea12e3923ea09d107ced446400f19070a42f"
+
+S = "${WORKDIR}/libwhisker2-2.5"
+
+inherit cpan-base
+
+PACKAGEGROUP ??=""
+PACKAGEGROUP[ssl] = ", , libnet-ssleay-perl, libnet-ssleay-perl"
+
+do_install() {
+ install -d 755 ${D}${PERLLIBDIRS}/vendor_perl/${PERLVERSION}
+ install -d 755 ${D}${datadir}/perl/${PERLVERSION}
+ oe_runmake install DESTDIR=${D} INSTALLDIR=${PERLLIBDIRS}/vendor_perl/${PERLVERSION} MANDIR=${datadir}/perl/${PERLVERSION}
+}
+
+BBCLASSEXTEND = "native"
OpenPOWER on IntegriCloud