summaryrefslogtreecommitdiffstats
path: root/meta-phosphor
diff options
context:
space:
mode:
authorSaqib Khan <khansa@us.ibm.com>2017-03-09 10:28:09 -0600
committerPatrick Williams <patrick@stwcx.xyz>2017-03-29 21:31:49 +0000
commitc8afc6a4110a9c34cd08862fb67ebf6286ce3313 (patch)
treece089e7a493f37ffb18b2f192cd4eb8edaf735f1 /meta-phosphor
parent0f38f855869f80898d131c2b30e2a43a908688c2 (diff)
downloadtalos-openbmc-c8afc6a4110a9c34cd08862fb67ebf6286ce3313.tar.gz
talos-openbmc-c8afc6a4110a9c34cd08862fb67ebf6286ce3313.zip
meta-phosphor: missing space on CFLAG_append
FOO_append is effectively an alias for 'FOO=FOO+FOO_append', so it is a common pattern to preceed the FOO_append string with a space. Right: FOO_append = " bar" Results in FOO="foo bar" Wrong: FOO_append = "bar" Results in FOO="foobar" Fix incorrect CFLAG_append entries in recipes to avoid compile errors like: Error: configure: error: C compiler cannot create executables Change-Id: Id81af5666b173aca35eb28f541a8325db1d438fd Signed-off-by: Saqib Khan <khansa@us.ibm.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-bt.bb2
-rw-r--r--meta-phosphor/common/recipes-phosphor/mboxd/mboxd.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-bt.bb b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-bt.bb
index 438e2fd8a..f83c8732b 100644
--- a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-bt.bb
+++ b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-bt.bb
@@ -22,5 +22,5 @@ SRC_URI += "git://github.com/openbmc/btbridge"
SRCREV="68bcce035ac7029d3110b53fb07848067da56b40"
# This is how linux-libc-headers says to include custom uapi headers
-CFLAGS_append = "-I ${STAGING_KERNEL_DIR}/include/uapi"
+CFLAGS_append = " -I ${STAGING_KERNEL_DIR}/include/uapi"
do_configure[depends] += "virtual/kernel:do_shared_workdir"
diff --git a/meta-phosphor/common/recipes-phosphor/mboxd/mboxd.bb b/meta-phosphor/common/recipes-phosphor/mboxd/mboxd.bb
index 0a55f247c..9a7f716f3 100644
--- a/meta-phosphor/common/recipes-phosphor/mboxd/mboxd.bb
+++ b/meta-phosphor/common/recipes-phosphor/mboxd/mboxd.bb
@@ -24,7 +24,7 @@ SYSTEMD_SUBSTITUTIONS += "FLASH_SIZE:${MBOXD_FLASH_SIZE}:${PN}.service"
# Hacks because ${STAGING_KERNEL_DIR} points to the kernel source tree, not the
# installed, pre-processed headers. Requires the aspeed-lpc-ctrl-h patch above.
-CFLAGS_append = "-I include"
+CFLAGS_append = " -I include"
do_install_append() {
install -d ${D}/lib/udev/rules.d
OpenPOWER on IntegriCloud