summaryrefslogtreecommitdiffstats
path: root/meta-phosphor
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2018-06-21 13:13:52 -0500
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-07-19 12:45:24 +0000
commita48f7f6fc06351794f348633f2db4c105a437961 (patch)
treee844f73fcb9dc0f06c49bf0e62e21ad0350749b0 /meta-phosphor
parent4d4042d1021ef892c65726504d2600b1e40f39d6 (diff)
downloadtalos-openbmc-a48f7f6fc06351794f348633f2db4c105a437961.tar.gz
talos-openbmc-a48f7f6fc06351794f348633f2db4c105a437961.zip
Tell phosphor-logging about the LED error yaml
This needs to be done so phosphor-logging will know to grab the error log's metadata from the journal and add it to the log in the AdditionalData field. Resolves openbmc/openbmc#3015 Tested: Check that the LED errors now show up in the elog-lookup.cpp file generated during the build by phosphor-logging. Change-Id: I9bcbf1b1c8d7499e4ef8e384005c34b858d25a7d Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/common/recipes-phosphor/leds/phosphor-led-manager-error-native.bb21
-rw-r--r--meta-phosphor/common/recipes-phosphor/leds/phosphor-logging-error-logs-native.bbappend1
2 files changed, 22 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/leds/phosphor-led-manager-error-native.bb b/meta-phosphor/common/recipes-phosphor/leds/phosphor-led-manager-error-native.bb
new file mode 100644
index 000000000..c8ec04127
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/leds/phosphor-led-manager-error-native.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Copy error yaml files to known path for elog parsing"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit native
+inherit phosphor-dbus-yaml
+
+require phosphor-led-manager.inc
+
+S = "${WORKDIR}/git"
+
+do_install_append() {
+ SRC=${S}/xyz/openbmc_project/Led/
+ DEST=${D}${yaml_dir}/xyz/openbmc_project/Led/
+ install -d ${DEST}/Fru
+ install ${SRC}/*.errors.yaml ${DEST}
+ install ${SRC}/*.metadata.yaml ${DEST}
+ install ${SRC}/Fru/*.errors.yaml ${DEST}/Fru
+ install ${SRC}/Fru/*.metadata.yaml ${DEST}/Fru
+}
diff --git a/meta-phosphor/common/recipes-phosphor/leds/phosphor-logging-error-logs-native.bbappend b/meta-phosphor/common/recipes-phosphor/leds/phosphor-logging-error-logs-native.bbappend
new file mode 100644
index 000000000..3f2c5c811
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/leds/phosphor-logging-error-logs-native.bbappend
@@ -0,0 +1 @@
+DEPENDS += "phosphor-led-manager-error-native"
OpenPOWER on IntegriCloud