summaryrefslogtreecommitdiffstats
path: root/meta-phosphor
diff options
context:
space:
mode:
authorMarri Devender Rao <devenrao@in.ibm.com>2018-01-18 11:21:19 -0600
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-01-30 18:57:40 +0000
commit95eaf4978f6f92a848ba53accf02dcb52cee29b6 (patch)
treedc1ddfa657eccae3d7441f9366d0dcc9e0fc502a /meta-phosphor
parentb867da70c54d4d8f82c29059bfdd12e6edfaeece (diff)
downloadtalos-openbmc-95eaf4978f6f92a848ba53accf02dcb52cee29b6.tar.gz
talos-openbmc-95eaf4978f6f92a848ba53accf02dcb52cee29b6.zip
DCMI: Get power reading - add config file
The D-Bus object that captures the power reading varies from system to system, using JSON config file to specify the D-Bus object to read based on the system. Change-Id: Iad153c2871d1ffa73f1bc02b6afb824a60c1ea80 Signed-off-by: Marri Devender Rao <devenrao@in.ibm.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb5
-rw-r--r--meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host/power_reading.json3
2 files changed, 8 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
index 8d82fef20..ec59b68a2 100644
--- a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
+++ b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
@@ -54,6 +54,7 @@ EXTRA_OECONF = " \
INVSENSOR_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/invsensor.yaml \
FRU_YAML_GEN=${STAGING_DIR_NATIVE}${config_datadir}/fru_config.yaml \
CHANNEL_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/channel.yaml \
+ POWER_READING_SENSOR=${datadir}/ipmi-providers/power_reading.json\
"
S = "${WORKDIR}/git"
@@ -61,6 +62,7 @@ S = "${WORKDIR}/git"
SRC_URI += "file://merge_yamls.py \
file://dev_id.json \
file://dcmi_cap.json \
+ file://power_reading.json \
"
HOSTIPMI_PROVIDER_LIBRARY += "libapphandler.so"
@@ -73,6 +75,7 @@ FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
FILES_${PN}_append = " ${datadir}/ipmi-providers/dev_id.json"
FILES_${PN}_append = " ${datadir}/ipmi-providers/dcmi_cap.json"
+FILES_${PN}_append = " ${datadir}/ipmi-providers/power_reading.json"
FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
# Soft Power Off
@@ -116,6 +119,8 @@ do_install_append(){
${D}${datadir}/ipmi-providers/dev_id.json
install -m 0644 -D ${WORKDIR}/dcmi_cap.json \
${D}${datadir}/ipmi-providers/dcmi_cap.json
+ install -m 0644 -D ${WORKDIR}/power_reading.json \
+ ${D}${datadir}/ipmi-providers/power_reading.json
}
# python-pyyaml-native is installed by do_configure, so put this task after
addtask merge_sensors after do_configure before do_compile
diff --git a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host/power_reading.json b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host/power_reading.json
new file mode 100644
index 000000000..f3d051f6e
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host/power_reading.json
@@ -0,0 +1,3 @@
+{
+ "path": ""
+}
OpenPOWER on IntegriCloud