summaryrefslogtreecommitdiffstats
path: root/meta-phosphor
diff options
context:
space:
mode:
authorBenjamin Fair <benjaminfair@google.com>2018-06-29 13:00:14 -0700
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-07-19 01:41:21 +0000
commit89e86cd92f38f4816b95e3c243be0e44c11cd01f (patch)
treeae1bd1af1346be19ddfe5b889efb11d13a0e595b /meta-phosphor
parent75ac5f43941a7fae88cec7d41215a168532e62a1 (diff)
downloadtalos-openbmc-89e86cd92f38f4816b95e3c243be0e44c11cd01f.tar.gz
talos-openbmc-89e86cd92f38f4816b95e3c243be0e44c11cd01f.zip
phosphor-host-postd: allow configuring the daemon
This adds variables to the recipe file which specify the name of the LPC snoop device and the number of bytes per POST code. The variables can be easily overridden in a platform-specific bbappend. Change-Id: Ia7778a72b62225238d2142c62b8e88e5e8ca33ee Signed-off-by: Benjamin Fair <benjaminfair@google.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/common/recipes-phosphor/host/phosphor-host-postd.bb8
-rw-r--r--meta-phosphor/common/recipes-phosphor/host/phosphor-host-postd/lpcsnoop.service2
2 files changed, 8 insertions, 2 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/host/phosphor-host-postd.bb b/meta-phosphor/common/recipes-phosphor/host/phosphor-host-postd.bb
index 3edf1e7fc..92ff4890e 100644
--- a/meta-phosphor/common/recipes-phosphor/host/phosphor-host-postd.bb
+++ b/meta-phosphor/common/recipes-phosphor/host/phosphor-host-postd.bb
@@ -12,7 +12,13 @@ DEPENDS += "systemd"
RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
-SYSTEMD_SERVICE_${PN} += "lpcsnoop.service"
+SNOOP_DEVICE ?= "aspeed-lpc-snoop0"
+POST_CODE_BYTES ?= "1"
+
+SERVICE_FILE = "lpcsnoop.service"
+SYSTEMD_SERVICE_${PN} += "${SERVICE_FILE}"
+SYSTEMD_SUBSTITUTIONS += "SNOOP_DEVICE:${SNOOP_DEVICE}:${SERVICE_FILE}"
+SYSTEMD_SUBSTITUTIONS += "POST_CODE_BYTES:${POST_CODE_BYTES}:${SERVICE_FILE}"
require ${PN}.inc
diff --git a/meta-phosphor/common/recipes-phosphor/host/phosphor-host-postd/lpcsnoop.service b/meta-phosphor/common/recipes-phosphor/host/phosphor-host-postd/lpcsnoop.service
index 23dfd98af..117702c04 100644
--- a/meta-phosphor/common/recipes-phosphor/host/phosphor-host-postd/lpcsnoop.service
+++ b/meta-phosphor/common/recipes-phosphor/host/phosphor-host-postd/lpcsnoop.service
@@ -4,7 +4,7 @@ After=systemd-modules-load.service
[Service]
Restart=always
-ExecStart={sbindir}/snoopd
+ExecStart={sbindir}/snoopd -d "/dev/{SNOOP_DEVICE}" -b "{POST_CODE_BYTES}"
[Install]
WantedBy={SYSTEMD_DEFAULT_TARGET}
OpenPOWER on IntegriCloud