summaryrefslogtreecommitdiffstats
path: root/meta-phosphor
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2018-08-07 16:35:19 -0500
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-28 11:19:34 -0400
commit71c1c926d7406730783ab663686efa7616e7a79e (patch)
treef3db95040e6583c172c8e55d6099b5d24dcf7d86 /meta-phosphor
parent8a56da7c28765ba967dd14789e0dbbc847cb8f6e (diff)
downloadtalos-openbmc-71c1c926d7406730783ab663686efa7616e7a79e.tar.gz
talos-openbmc-71c1c926d7406730783ab663686efa7616e7a79e.zip
Install GPIO definition JSON
The code in libopenbmc_intf.so looks for the GPIO definition file /etc/default/obmc/gpio/gpios_defs.json. Install it from this recipe. The actual JSON files should go into the corresponding directories in the machine layers along with a bbappend of this recipe to set FILESEXTRAPATHS_prepend. (From meta-phosphor rev: 728258c6a235f75176ea213e671d7a93904ca72a) Change-Id: I3969e005cbdfd04ae8cec1c13c3c3bb625dca574 Signed-off-by: Matt Spinler <spinler@us.ibm.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/common/recipes-phosphor/skeleton/obmc-libobmc-intf.bb6
-rw-r--r--meta-phosphor/common/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json3
2 files changed, 9 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/skeleton/obmc-libobmc-intf.bb b/meta-phosphor/common/recipes-phosphor/skeleton/obmc-libobmc-intf.bb
index 09027dde3..b02b83234 100644
--- a/meta-phosphor/common/recipes-phosphor/skeleton/obmc-libobmc-intf.bb
+++ b/meta-phosphor/common/recipes-phosphor/skeleton/obmc-libobmc-intf.bb
@@ -7,9 +7,15 @@ inherit skeleton
inherit pkgconfig
DEPENDS += "glib-2.0"
+DEPENDS += "cjson"
SKELETON_DIR = "libopenbmc_intf"
+SRC_URI += "file://gpio_defs.json"
+
do_install() {
oe_runmake install DESTDIR=${D}
+
+ install -d ${D}${sysconfdir}/default/obmc/gpio/
+ install -m 0644 ${WORKDIR}/gpio_defs.json ${D}/${sysconfdir}/default/obmc/gpio/
}
diff --git a/meta-phosphor/common/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json b/meta-phosphor/common/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json
new file mode 100644
index 000000000..6e4ef9ff9
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json
@@ -0,0 +1,3 @@
+{
+ "_comments": "This file should be overridden with one from the machine layer."
+}
OpenPOWER on IntegriCloud