summaryrefslogtreecommitdiffstats
path: root/meta-phosphor
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2015-08-14 03:11:24 -0400
committerEdward A. James <eajames@us.ibm.com>2016-07-12 16:43:04 -0500
commit699b58aa7e16aca20dac22a35b25edc0650787ef (patch)
tree12fee0bd8c36e80419680df9787d0b9e973c51e1 /meta-phosphor
parentdbf496725f591e5d5cd46e20362d6a4025294ed2 (diff)
downloadtalos-openbmc-699b58aa7e16aca20dac22a35b25edc0650787ef.tar.gz
talos-openbmc-699b58aa7e16aca20dac22a35b25edc0650787ef.zip
python-ipy: update 0.81 -> 0.83
* update SRC_URI checksums * remove PKG-INFO that is not in 0.83 Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com> Signed-off-by: Edward A. James <eajames@us.ibm.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/common/recipes-devtools/python/python-ipy_0.83.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-devtools/python/python-ipy_0.83.bb b/meta-phosphor/common/recipes-devtools/python/python-ipy_0.83.bb
new file mode 100644
index 000000000..b2a973997
--- /dev/null
+++ b/meta-phosphor/common/recipes-devtools/python/python-ipy_0.83.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Python module for handling IPv4 and IPv6 Addresses and Networks"
+DESCRIPTION = "IPy is a Python module for handling IPv4 and IPv6 Addresses and Networks \
+in a fashion similar to perl's Net::IP and friends. The IP class allows \
+a comfortable parsing and handling for most notations in use for IPv4 \
+and IPv6 Addresses and Networks."
+SECTION = "devel/python"
+HOMEPAGE = "https://github.com/haypo/python-ipy"
+DEPENDS = "python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=ebc0028ff5cdaf7796604875027dcd55"
+
+SRC_URI = "http://pypi.python.org/packages/source/I/IPy/IPy-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "7b8c6eb4111b15aea31b67108e769712"
+SRC_URI[sha256sum] = "61da5a532b159b387176f6eabf11946e7458b6df8fb8b91ff1d345ca7a6edab8"
+
+S = "${WORKDIR}/IPy-${PV}"
+
+inherit distutils
+
+# need to export these variables for python-config to work
+export BUILD_SYS
+export HOST_SYS
+export STAGING_INCDIR
+export STAGING_LIBDIR
+
+BBCLASSEXTEND = "native"
+
+do_install_append() {
+ install -d ${D}/${datadir}/doc/${BPN}-${PV}
+ install AUTHORS COPYING ChangeLog README ${D}/${datadir}/doc/${BPN}-${PV}
+}
OpenPOWER on IntegriCloud