summaryrefslogtreecommitdiffstats
path: root/meta-phosphor
diff options
context:
space:
mode:
authorRaptor Engineering Development Team <support@raptorengineering.com>2018-01-19 14:11:58 -0600
committerTimothy Pearson <tpearson@raptorengineering.com>2019-04-25 08:01:49 +0000
commit336e31aa1d3f1b04eac8c403669c597251d0d1ec (patch)
tree94e2a4a89afa12e2b75eeca9112930a0f9ff9ab6 /meta-phosphor
parent7d6652108e3e5db00fa488305e8ed693b91ae7cf (diff)
downloadtalos-openbmc-336e31aa1d3f1b04eac8c403669c597251d0d1ec.tar.gz
talos-openbmc-336e31aa1d3f1b04eac8c403669c597251d0d1ec.zip
Add IPL status observer
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/common/recipes-phosphor/system/obmc-ipl-status-observer.bb23
-rw-r--r--meta-phosphor/common/recipes-phosphor/system/obmc-ipl-status-observer/org.openbmc.status.IPL.service15
2 files changed, 38 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/system/obmc-ipl-status-observer.bb b/meta-phosphor/common/recipes-phosphor/system/obmc-ipl-status-observer.bb
new file mode 100644
index 000000000..95d358e3d
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/system/obmc-ipl-status-observer.bb
@@ -0,0 +1,23 @@
+SUMMARY = "OpenBMC IPL status observer"
+DESCRIPTION = "OpenBMC IPL status observer."
+PR = "r1"
+
+inherit skeleton-python
+inherit obmc-phosphor-dbus-service
+
+VIRTUAL-RUNTIME_skeleton_workbook ?= ""
+
+RDEPENDS_${PN} += "\
+ python-dbus \
+ python-json \
+ python-subprocess \
+ python-pygobject \
+ pyphosphor \
+ pyphosphor-dbus \
+ ${VIRTUAL-RUNTIME_skeleton_workbook} \
+ pdbg \
+ "
+
+SKELETON_DIR = "pyiplobserver"
+
+DBUS_SERVICE_${PN} += "org.openbmc.status.IPL.service"
diff --git a/meta-phosphor/common/recipes-phosphor/system/obmc-ipl-status-observer/org.openbmc.status.IPL.service b/meta-phosphor/common/recipes-phosphor/system/obmc-ipl-status-observer/org.openbmc.status.IPL.service
new file mode 100644
index 000000000..a92b2f146
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/system/obmc-ipl-status-observer/org.openbmc.status.IPL.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=Phoshpor IPL Status Observer
+Wants=xyz.openbmc_project.State.Host.service
+After=xyz.openbmc_project.State.Host.service
+
+[Service]
+Restart=always
+ExecStart=/usr/bin/env ipl_status_observer.py
+SyslogIdentifier=ipl_status_observer.py
+Type=dbus
+BusName={BUSNAME}
+Environment="PYTHONUNBUFFERED=1"
+
+[Install]
+WantedBy={SYSTEMD_DEFAULT_TARGET}
OpenPOWER on IntegriCloud