summaryrefslogtreecommitdiffstats
path: root/meta-phosphor
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2017-04-07 14:21:33 -0500
committerPatrick Williams <patrick@stwcx.xyz>2017-04-12 21:27:58 +0000
commit25b36e246d74a9c324aa39e9ac19a1586309897f (patch)
treec71fe2346faff8a1b98650ab0d154b42db277f49 /meta-phosphor
parent89bc5a1994576e08117fde868afb075867d897b1 (diff)
downloadtalos-openbmc-25b36e246d74a9c324aa39e9ac19a1586309897f.tar.gz
talos-openbmc-25b36e246d74a9c324aa39e9ac19a1586309897f.zip
Move FSI recipe and services to meta-openpower
FSI is an OpenPower concept. Change-Id: I0043d6d7b4783179b0893bbf7995aa229df2463f Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/common/recipes-phosphor/chassis/obmc-fsi.bb21
-rw-r--r--meta-phosphor/common/recipes-phosphor/chassis/obmc-fsi/fsi-bind@.service18
-rw-r--r--meta-phosphor/common/recipes-phosphor/chassis/obmc-fsi/fsi-disable.service8
-rw-r--r--meta-phosphor/common/recipes-phosphor/chassis/obmc-fsi/fsi-enable.service10
-rw-r--r--meta-phosphor/common/recipes-phosphor/chassis/obmc-fsi/fsi-scan@.service15
5 files changed, 0 insertions, 72 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/chassis/obmc-fsi.bb b/meta-phosphor/common/recipes-phosphor/chassis/obmc-fsi.bb
deleted file mode 100644
index 37a326fd0..000000000
--- a/meta-phosphor/common/recipes-phosphor/chassis/obmc-fsi.bb
+++ /dev/null
@@ -1,21 +0,0 @@
-SUMMARY = "FSI Services"
-DESCRIPTION = "Install FSI related services"
-PR = "r1"
-
-inherit obmc-phosphor-systemd
-inherit obmc-phosphor-license
-
-TGTFMT = "obmc-power-chassis-on@{0}.target"
-
-TMPL_SCAN = "fsi-scan@.service"
-INSTFMT_SCAN = "fsi-scan@{0}.service"
-FMT_SCAN = "../${TMPL_SCAN}:${TGTFMT}.requires/${INSTFMT_SCAN}"
-
-TMPL_BIND = "fsi-bind@.service"
-INSTFMT_BIND = "fsi-bind@{0}.service"
-FMT_BIND = "../${TMPL_BIND}:${TGTFMT}.requires/${INSTFMT_BIND}"
-
-SYSTEMD_SERVICE_${PN} += "${TMPL_SCAN} ${TMPL_BIND} fsi-enable.service fsi-disable.service"
-
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_SCAN', 'OBMC_CHASSIS_INSTANCES')}"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_BIND', 'OBMC_CHASSIS_INSTANCES')}"
diff --git a/meta-phosphor/common/recipes-phosphor/chassis/obmc-fsi/fsi-bind@.service b/meta-phosphor/common/recipes-phosphor/chassis/obmc-fsi/fsi-bind@.service
deleted file mode 100644
index 77c61f414..000000000
--- a/meta-phosphor/common/recipes-phosphor/chassis/obmc-fsi/fsi-bind@.service
+++ /dev/null
@@ -1,18 +0,0 @@
-[Unit]
-Description=Bind FSI Driver
-Wants=obmc-power-on@%i.target
-After=obmc-power-on@%i.target
-Wants=obmc-host-start-pre@%i.target
-Before=obmc-host-start-pre@%i.target
-Wants=fsi-scan@%i.service
-Before=fsi-scan@%i.service
-Conflicts=obmc-power-chassis-off@%i.target
-ConditionDirectoryNotEmpty=!/sys/bus/platform/drivers/fsi-master-gpio/fsi-master
-
-[Service]
-ExecStart=/bin/sh -c "echo fsi-master > /sys/bus/platform/drivers/fsi-master-gpio/bind"
-Type=oneshot
-RemainAfterExit=yes
-
-[Install]
-RequiredBy=obmc-power-chassis-on@%i.target
diff --git a/meta-phosphor/common/recipes-phosphor/chassis/obmc-fsi/fsi-disable.service b/meta-phosphor/common/recipes-phosphor/chassis/obmc-fsi/fsi-disable.service
deleted file mode 100644
index a58af0445..000000000
--- a/meta-phosphor/common/recipes-phosphor/chassis/obmc-fsi/fsi-disable.service
+++ /dev/null
@@ -1,8 +0,0 @@
-[Unit]
-Description=Disable FSI
-Conflicts=fsi-enable.service
-
-[Service]
-ExecStart=/bin/sh -c "echo fsi-master > /sys/bus/platform/drivers/fsi-master-gpio/unbind"
-Type=oneshot
-RemainAfterExit=yes
diff --git a/meta-phosphor/common/recipes-phosphor/chassis/obmc-fsi/fsi-enable.service b/meta-phosphor/common/recipes-phosphor/chassis/obmc-fsi/fsi-enable.service
deleted file mode 100644
index c5b1ea139..000000000
--- a/meta-phosphor/common/recipes-phosphor/chassis/obmc-fsi/fsi-enable.service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=Enable FSI
-Conflicts=fsi-disable.service
-ConditionDirectoryNotEmpty=!/sys/bus/platform/drivers/fsi-master-gpio/fsi-master
-
-[Service]
-ExecStart=/bin/sh -c "echo fsi-master > /sys/bus/platform/drivers/fsi-master-gpio/bind"
-ExecStart=/bin/sh -c "echo 1 > /sys/bus/platform/devices/fsi-master/scan"
-Type=oneshot
-RemainAfterExit=yes
diff --git a/meta-phosphor/common/recipes-phosphor/chassis/obmc-fsi/fsi-scan@.service b/meta-phosphor/common/recipes-phosphor/chassis/obmc-fsi/fsi-scan@.service
deleted file mode 100644
index 8f94e28ab..000000000
--- a/meta-phosphor/common/recipes-phosphor/chassis/obmc-fsi/fsi-scan@.service
+++ /dev/null
@@ -1,15 +0,0 @@
-[Unit]
-Description=Scan FSI devices
-Wants=obmc-power-on@%i.target
-After=obmc-power-on@%i.target
-Wants=obmc-host-start-pre@%i.target
-Before=obmc-host-start-pre@%i.target
-Conflicts=obmc-power-chassis-off@%i.target
-
-[Service]
-ExecStart=/bin/sh -c "echo 1 > /sys/bus/platform/devices/fsi-master/scan"
-Type=oneshot
-RemainAfterExit=yes
-
-[Install]
-RequiredBy=obmc-power-chassis-on@%i.target
OpenPOWER on IntegriCloud