summaryrefslogtreecommitdiffstats
path: root/meta-phosphor
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-03-23 00:18:53 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-04-04 13:38:19 +0000
commit211ccf33fb57ddede03d26cf7cb05924d039b2df (patch)
treedd48d4379798885ff51310d02e609e6dd1ec8b19 /meta-phosphor
parent2f2163c1d6e4f6d0e004709e21f51ad20ee72ee4 (diff)
downloadtalos-openbmc-211ccf33fb57ddede03d26cf7cb05924d039b2df.tar.gz
talos-openbmc-211ccf33fb57ddede03d26cf7cb05924d039b2df.zip
Remove ipmi distro feature, virtual
We don't need a distro feature for net IPMI at this point, so simplify things a bit. Additionally, remove the net-ipmi virtual since we don't have any alternative implementations today and it just adds unnecessary complexity. Tested: Built a witherspoon image and validated manifest Change-Id: I2784f13b3e8897e855ac128422081ec3ee207bf1 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/classes/obmc-phosphor-image.bbclass7
-rw-r--r--meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-net.bb2
-rw-r--r--meta-phosphor/conf/distro/include/phosphor-base.inc1
-rw-r--r--meta-phosphor/conf/distro/include/phosphor-defaults.inc2
4 files changed, 6 insertions, 6 deletions
diff --git a/meta-phosphor/classes/obmc-phosphor-image.bbclass b/meta-phosphor/classes/obmc-phosphor-image.bbclass
index ab72debf9..a4aaeae7f 100644
--- a/meta-phosphor/classes/obmc-phosphor-image.bbclass
+++ b/meta-phosphor/classes/obmc-phosphor-image.bbclass
@@ -37,7 +37,7 @@ FEATURE_PACKAGES_obmc-host-state-mgmt ?= "packagegroup-obmc-apps-host-state-mgmt
FEATURE_PACKAGES_obmc-inventory ?= "packagegroup-obmc-apps-inventory"
FEATURE_PACKAGES_obmc-leds ?= "packagegroup-obmc-apps-leds"
FEATURE_PACKAGES_obmc-logging-mgmt ?= "${@df_enabled(d, 'obmc-logging-mgmt', 'packagegroup-obmc-apps-logging')}"
-FEATURE_PACKAGES_obmc-net-ipmi ?= "${@df_enabled(d, 'obmc-net-ipmi', 'virtual-obmc-net-ipmi')}"
+FEATURE_PACKAGES_obmc-net-ipmi ?= "phosphor-ipmi-net"
FEATURE_PACKAGES_obmc-sensors ?= "packagegroup-obmc-apps-sensors"
FEATURE_PACKAGES_obmc-software ?= "packagegroup-obmc-apps-software"
FEATURE_PACKAGES_obmc-system-mgmt ?= "${@df_enabled(d, 'obmc-phosphor-system-mgmt', 'virtual-obmc-system-mgmt')}"
@@ -46,6 +46,11 @@ FEATURE_PACKAGES_obmc-settings-mgmt ?= "packagegroup-obmc-apps-settings"
FEATURE_PACKAGES_obmc-network-mgmt ?= "packagegroup-obmc-apps-network"
FEATURE_PACKAGES_obmc-user-mgmt ?= "packagegroup-obmc-apps-user-mgmt"
+# FIXME: phosphor-net-ipmi depends on phosphor-ipmi-host !?!? and
+# cannot be built on core-qemu machines because of the dependency
+# tree under phosphor-ipmi-host
+FEATURE_PACKAGES_obmc-net-ipmi_qemuall = ""
+
# Install entire Phosphor application stack by default
IMAGE_FEATURES += " \
obmc-bmc-state-mgmt \
diff --git a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-net.bb b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-net.bb
index d1c00f328..6d1a42502 100644
--- a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-net.bb
+++ b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-net.bb
@@ -13,8 +13,6 @@ DEPENDS += "systemd"
DEPENDS += "phosphor-ipmi-host"
RDEPENDS_${PN} += "libmapper"
RDEPENDS_${PN} += "libsystemd"
-PROVIDES += "virtual/obmc-net-ipmi"
-RPROVIDES_${PN} += "virtual-obmc-net-ipmi"
SRC_URI += "git://github.com/openbmc/phosphor-net-ipmid"
SRCREV = "1d9d41668fcdaeb99708be784ce04402578182b4"
diff --git a/meta-phosphor/conf/distro/include/phosphor-base.inc b/meta-phosphor/conf/distro/include/phosphor-base.inc
index 236a47e6b..203ed7471 100644
--- a/meta-phosphor/conf/distro/include/phosphor-base.inc
+++ b/meta-phosphor/conf/distro/include/phosphor-base.inc
@@ -26,7 +26,6 @@ DISTRO_FEATURES_OBMC = " \
obmc-host-ctl \
obmc-host-ipmi \
obmc-logging-mgmt \
- obmc-net-ipmi \
obmc-phosphor-chassis-mgmt \
obmc-phosphor-fan-mgmt \
obmc-phosphor-flash-mgmt \
diff --git a/meta-phosphor/conf/distro/include/phosphor-defaults.inc b/meta-phosphor/conf/distro/include/phosphor-defaults.inc
index 82d947392..ed2cd741d 100644
--- a/meta-phosphor/conf/distro/include/phosphor-defaults.inc
+++ b/meta-phosphor/conf/distro/include/phosphor-defaults.inc
@@ -88,8 +88,6 @@ VIRTUAL-RUNTIME_obmc-bmc-version ?= "phosphor-software-manager-version"
# interface.
VIRTUAL-RUNTIME_obmc-bmc-updater ?= "phosphor-software-manager-updater"
-PREFERRED_PROVIDER_virtual/obmc-net-ipmi ?= "phosphor-ipmi-net"
-
# obmc-sensors-hwmon
#
# Provides an implementation of xyz.openbmc_project.Sensor.Value
OpenPOWER on IntegriCloud