summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/recipes-phosphor/system
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-31 06:25:51 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-06 07:44:12 -0400
commitff075f6ee795a590b244d70a90cc312ba1f2d83d (patch)
treea617790bdbfdeef960665ba0242e1f0c93e5301a /meta-phosphor/recipes-phosphor/system
parent3e4da38c127bb7e7641adc2fc41f4c33744cb918 (diff)
downloadtalos-openbmc-ff075f6ee795a590b244d70a90cc312ba1f2d83d.tar.gz
talos-openbmc-ff075f6ee795a590b244d70a90cc312ba1f2d83d.zip
meta-phosphor: Move layer content from common/
Adopt a more conventional directory hierarchy. meta-phosphor is still a _long_ way from suitable for hosting on yoctoproject.org but things like this don't help. (From meta-phosphor rev: 471cfcefa74b8c7ceb704cb670e6d915cf27c63b) Change-Id: I3f106b2f6cdc6cec734be28a6090800546f362eb Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/system')
-rw-r--r--meta-phosphor/recipes-phosphor/system/files/obmc-phosphor-sysd.py29
-rw-r--r--meta-phosphor/recipes-phosphor/system/files/obmc-phosphor-sysd.service10
-rw-r--r--meta-phosphor/recipes-phosphor/system/obmc-control-bmc.bb13
-rw-r--r--meta-phosphor/recipes-phosphor/system/obmc-control-bmc/org.openbmc.control.Bmc@.service12
-rw-r--r--meta-phosphor/recipes-phosphor/system/obmc-mgr-system.bb22
-rw-r--r--meta-phosphor/recipes-phosphor/system/obmc-mgr-system/org.openbmc.managers.System.service16
-rw-r--r--meta-phosphor/recipes-phosphor/system/obmc-phosphor-sysd.bb11
7 files changed, 113 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/system/files/obmc-phosphor-sysd.py b/meta-phosphor/recipes-phosphor/system/files/obmc-phosphor-sysd.py
new file mode 100644
index 000000000..c8080ac2c
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/system/files/obmc-phosphor-sysd.py
@@ -0,0 +1,29 @@
+#!/usr/bin/env python
+
+# Contributors Listed Below - COPYRIGHT 2015
+# [+] International Business Machines Corp.
+#
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+# implied. See the License for the specific language governing
+# permissions and limitations under the License.
+
+import time
+import sys
+import dbus
+import dbus.service
+import dbus.mainloop.glib
+
+if __name__ == '__main__':
+ print "obmc-phosphor-watchdogd starting..."
+
+ while 1:
+ time.sleep(5)
diff --git a/meta-phosphor/recipes-phosphor/system/files/obmc-phosphor-sysd.service b/meta-phosphor/recipes-phosphor/system/files/obmc-phosphor-sysd.service
new file mode 100644
index 000000000..d4dacf546
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/system/files/obmc-phosphor-sysd.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Phosphor System Manager
+
+[Service]
+Restart=always
+ExecStart=/usr/bin/env obmc-phosphor-sysd
+SyslogIdentifier=obmc-phosphor-sysd
+
+[Install]
+WantedBy={SYSTEMD_DEFAULT_TARGET}
diff --git a/meta-phosphor/recipes-phosphor/system/obmc-control-bmc.bb b/meta-phosphor/recipes-phosphor/system/obmc-control-bmc.bb
new file mode 100644
index 000000000..eb5b4a810
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/system/obmc-control-bmc.bb
@@ -0,0 +1,13 @@
+SUMMARY = "OpenBMC org.openbmc.control.Bmc example implementation"
+DESCRIPTION = "A sample implementation for the org.openbmc.control.Bmc DBUS API. \
+org.openbmc.control.Bmc provides APIs for functions like resetting the BMC."
+PR = "r1"
+
+inherit skeleton-gdbus
+inherit obmc-phosphor-dbus-service
+inherit pkgconfig
+
+SKELETON_DIR = "bmcctl"
+
+FMT = "org.openbmc.control.Bmc@{0}.service"
+DBUS_SERVICE_${PN} += "${@compose_list(d, 'FMT', 'OBMC_BMC_INSTANCES')}"
diff --git a/meta-phosphor/recipes-phosphor/system/obmc-control-bmc/org.openbmc.control.Bmc@.service b/meta-phosphor/recipes-phosphor/system/obmc-control-bmc/org.openbmc.control.Bmc@.service
new file mode 100644
index 000000000..9685efecd
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/system/obmc-control-bmc/org.openbmc.control.Bmc@.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Phosphor BMC%i Control
+
+[Service]
+Restart=always
+ExecStart=/usr/bin/env control_bmc.exe
+SyslogIdentifier=control_bmc.exe
+Type=dbus
+BusName={BUSNAME}
+
+[Install]
+WantedBy={SYSTEMD_DEFAULT_TARGET}
diff --git a/meta-phosphor/recipes-phosphor/system/obmc-mgr-system.bb b/meta-phosphor/recipes-phosphor/system/obmc-mgr-system.bb
new file mode 100644
index 000000000..0df36f9c1
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/system/obmc-mgr-system.bb
@@ -0,0 +1,22 @@
+SUMMARY = "OpenBMC system manager"
+DESCRIPTION = "OpenBMC system manager."
+PR = "r1"
+
+inherit skeleton-python
+inherit obmc-phosphor-dbus-service
+
+VIRTUAL-RUNTIME_skeleton_workbook ?= ""
+
+RDEPENDS_${PN} += "\
+ python-dbus \
+ python-json \
+ python-subprocess \
+ python-pygobject \
+ pyphosphor \
+ pyphosphor-dbus \
+ ${VIRTUAL-RUNTIME_skeleton_workbook} \
+ "
+
+SKELETON_DIR = "pysystemmgr"
+
+DBUS_SERVICE_${PN} += "org.openbmc.managers.System.service"
diff --git a/meta-phosphor/recipes-phosphor/system/obmc-mgr-system/org.openbmc.managers.System.service b/meta-phosphor/recipes-phosphor/system/obmc-mgr-system/org.openbmc.managers.System.service
new file mode 100644
index 000000000..9d1761fd8
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/system/obmc-mgr-system/org.openbmc.managers.System.service
@@ -0,0 +1,16 @@
+[Unit]
+Description=Phosphor System Manager
+Wants=obmc-mapper.target
+After=obmc-mapper.target
+
+[Service]
+Restart=always
+ExecStart=/usr/bin/env system_manager.py
+SyslogIdentifier=system_manager.py
+Type=dbus
+BusName={BUSNAME}
+Environment="PYTHONUNBUFFERED=1"
+TimeoutStartSec=180s
+
+[Install]
+WantedBy={SYSTEMD_DEFAULT_TARGET}
diff --git a/meta-phosphor/recipes-phosphor/system/obmc-phosphor-sysd.bb b/meta-phosphor/recipes-phosphor/system/obmc-phosphor-sysd.bb
new file mode 100644
index 000000000..7a21c2fe6
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/system/obmc-phosphor-sysd.bb
@@ -0,0 +1,11 @@
+SUMMARY = "Phosphor OpenBMC System Management"
+DESCRIPTION = "Phosphor OpenBMC system management reference implementation."
+PR = "r1"
+
+inherit obmc-phosphor-pydbus-service
+
+PROVIDES += "virtual/obmc-system-mgmt"
+RPROVIDES_${PN} += "virtual-obmc-system-mgmt"
+
+S = "${WORKDIR}"
+SRC_URI += "file://${PN}.py"
OpenPOWER on IntegriCloud