summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/recipes-phosphor/packagegroups
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-31 06:25:51 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-06 07:44:12 -0400
commitff075f6ee795a590b244d70a90cc312ba1f2d83d (patch)
treea617790bdbfdeef960665ba0242e1f0c93e5301a /meta-phosphor/recipes-phosphor/packagegroups
parent3e4da38c127bb7e7641adc2fc41f4c33744cb918 (diff)
downloadtalos-openbmc-ff075f6ee795a590b244d70a90cc312ba1f2d83d.tar.gz
talos-openbmc-ff075f6ee795a590b244d70a90cc312ba1f2d83d.zip
meta-phosphor: Move layer content from common/
Adopt a more conventional directory hierarchy. meta-phosphor is still a _long_ way from suitable for hosting on yoctoproject.org but things like this don't help. (From meta-phosphor rev: 471cfcefa74b8c7ceb704cb670e6d915cf27c63b) Change-Id: I3f106b2f6cdc6cec734be28a6090800546f362eb Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/packagegroups')
-rw-r--r--meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb133
-rw-r--r--meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-ipmid-providers.bb11
-rw-r--r--meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-phosphor-debugtools.bb15
3 files changed, 159 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb b/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb
new file mode 100644
index 000000000..5c184babf
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb
@@ -0,0 +1,133 @@
+SUMMARY = "OpenBMC - Applications"
+PR = "r1"
+
+inherit packagegroup
+inherit obmc-phosphor-license
+
+PROVIDES = "${PACKAGES}"
+PACKAGES = " \
+ ${PN}-bmc-state-mgmt \
+ ${PN}-chassis-state-mgmt \
+ ${PN}-extras \
+ ${PN}-extrasdev \
+ ${PN}-extrasdevtools \
+ ${PN}-fan-control \
+ ${PN}-host-state-mgmt \
+ ${PN}-inventory \
+ ${PN}-leds \
+ ${PN}-logging \
+ ${PN}-sensors \
+ ${PN}-software \
+ ${PN}-host-check-mgmt \
+ ${PN}-debug-collector \
+ ${PN}-settings \
+ ${PN}-network \
+ ${PN}-user-mgmt \
+ "
+
+SUMMARY_${PN}-bmc-state-mgmt = "BMC state management"
+RDEPENDS_${PN}-bmc-state-mgmt = " \
+ ${VIRTUAL-RUNTIME_obmc-bmc-state-manager} \
+ "
+
+SUMMARY_${PN}-chassis-state-mgmt = "Chassis state management"
+RDEPENDS_${PN}-chassis-state-mgmt = " \
+ ${VIRTUAL-RUNTIME_obmc-chassis-state-manager} \
+ "
+
+SUMMARY_${PN}-extras = "Extra features"
+RDEPENDS_${PN}-extras = " \
+ phosphor-rest \
+ phosphor-dbus-monitor \
+ phosphor-systemd-policy \
+ "
+
+SUMMARY_${PN}-extrasdev = "Development features"
+RDEPENDS_${PN}-extrasdev = " \
+ rest-dbus \
+ "
+
+SUMMARY_${PN}-extrasdevtools = "Development tools"
+RDEPENDS_${PN}-extrasdevtools = " \
+ "
+
+# Use the fan control package group for applications
+# implementing fan control or system fan policy only.
+# Applications that create inventory or sensors should
+# be added those respective package groups instead.
+SUMMARY_${PN}-fan-control = "Fan control"
+RDEPENDS_${PN}-fan-control = " \
+ ${VIRTUAL-RUNTIME_obmc-fan-control} \
+ phosphor-fan-monitor \
+ "
+
+SUMMARY_${PN}-host-state-mgmt = "Host state management"
+RDEPENDS_${PN}-host-state-mgmt = " \
+ ${VIRTUAL-RUNTIME_obmc-host-state-manager} \
+ ${VIRTUAL-RUNTIME_obmc-discover-system-state} \
+ "
+
+SUMMARY_${PN}-inventory = "Inventory applications"
+RDEPENDS_${PN}-inventory = " \
+ ${VIRTUAL-RUNTIME_obmc-inventory-manager} \
+ ${VIRTUAL-RUNTIME_obmc-fan-presence} \
+ "
+
+SUMMARY_${PN}-leds = "LED applications"
+RDEPENDS_${PN}-leds = " \
+ ${VIRTUAL-RUNTIME_obmc-leds-manager} \
+ ${VIRTUAL-RUNTIME_obmc-leds-sysfs} \
+ ${VIRTUAL-RUNTIME_obmc-led-monitor} \
+ "
+
+SUMMARY_${PN}-logging = "Logging applications"
+RDEPENDS_${PN}-logging = " \
+ phosphor-logging \
+ "
+
+SUMMARY_${PN}-sensors = "Sensor applications"
+RDEPENDS_${PN}-sensors = " \
+ ${VIRTUAL-RUNTIME_obmc-sensors-hwmon} \
+ "
+
+# These packages are not required with UBI enabled
+${PN}-software-extras = " \
+ obmc-flash-bmc \
+ obmc-mgr-download \
+ "
+
+${PN}-software-extras_df-obmc-ubi-fs = " \
+ phosphor-image-signing \
+ phosphor-software-manager-updater-ubi \
+ "
+
+SUMMARY_${PN}-software = "Software applications"
+RDEPENDS_${PN}-software = " \
+ ${VIRTUAL-RUNTIME_obmc-bmc-download-mgr} \
+ ${VIRTUAL-RUNTIME_obmc-bmc-updater} \
+ ${VIRTUAL-RUNTIME_obmc-bmc-version} \
+ ${${PN}-software-extras} \
+ "
+
+SUMMARY_${PN}-debug-collector = "BMC debug collector"
+RDEPENDS_${PN}-debug-collector = " \
+ ${VIRTUAL-RUNTIME_obmc-dump-manager} \
+ ${VIRTUAL-RUNTIME_obmc-dump-monitor} \
+ phosphor-debug-collector-dreport \
+ phosphor-debug-collector-scripts \
+ "
+
+SUMMARY_${PN}-settings = "Settings applications"
+RDEPENDS_${PN}-settings = " \
+ ${VIRTUAL-RUNTIME_obmc-settings-mgmt} \
+ "
+
+SUMMARY_${PN}-network = "BMC Network Manager"
+RDEPENDS_${PN}-network = " \
+ ${VIRTUAL-RUNTIME_obmc-network-manager} \
+ "
+
+SUMMARY_${PN}-user-mgmt = "User management applications"
+RDEPENDS_${PN}-user-mgmt = " \
+ ${VIRTUAL-RUNTIME_obmc-user-mgmt} \
+ "
diff --git a/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-ipmid-providers.bb b/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-ipmid-providers.bb
new file mode 100644
index 000000000..cbe7e7fb9
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-ipmid-providers.bb
@@ -0,0 +1,11 @@
+SUMMARY = "OpenBMC - IPMI providers"
+PR = "r1"
+
+inherit packagegroup
+inherit obmc-phosphor-license
+
+PROVIDES = "${PACKAGES}"
+PACKAGES = "${PN}-libs"
+
+SUMMARY_${PN}-libs = "Extra providers for ipmid."
+RDEPENDS_${PN}-libs = "${VIRTUAL-RUNTIME_phosphor-ipmi-providers}"
diff --git a/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-phosphor-debugtools.bb b/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-phosphor-debugtools.bb
new file mode 100644
index 000000000..1a6d4b787
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/packagegroups/packagegroup-obmc-phosphor-debugtools.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Phosphor OpenBMC - Debug Tools"
+PR = "r1"
+
+inherit packagegroup
+inherit obmc-phosphor-license
+
+RDEPENDS_${PN} = " \
+ strace \
+ ldd \
+ ethtool \
+ net-tools \
+ phosphor-logging-test \
+ lmsensors-sensors \
+ tcpdump \
+ "
OpenPOWER on IntegriCloud