summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-31 06:25:51 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-06 07:44:12 -0400
commitff075f6ee795a590b244d70a90cc312ba1f2d83d (patch)
treea617790bdbfdeef960665ba0242e1f0c93e5301a /meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru.bb
parent3e4da38c127bb7e7641adc2fc41f4c33744cb918 (diff)
downloadtalos-openbmc-ff075f6ee795a590b244d70a90cc312ba1f2d83d.tar.gz
talos-openbmc-ff075f6ee795a590b244d70a90cc312ba1f2d83d.zip
meta-phosphor: Move layer content from common/
Adopt a more conventional directory hierarchy. meta-phosphor is still a _long_ way from suitable for hosting on yoctoproject.org but things like this don't help. (From meta-phosphor rev: 471cfcefa74b8c7ceb704cb670e6d915cf27c63b) Change-Id: I3f106b2f6cdc6cec734be28a6090800546f362eb Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru.bb
new file mode 100644
index 000000000..251df427c
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-fru.bb
@@ -0,0 +1,50 @@
+SUMMARY = "Phosphor IPMI Inventory Plugin"
+DESCRIPTION = "A Phosphor IPMI plugin that updates inventory."
+PR = "r1"
+
+inherit autotools pkgconfig
+inherit obmc-phosphor-systemd
+inherit obmc-phosphor-ipmiprovider-symlink
+inherit phosphor-ipmi-fru
+inherit pythonnative
+
+require ${PN}.inc
+
+DEPENDS += " \
+ virtual/phosphor-ipmi-fru-hostfw-config\
+ virtual/phosphor-ipmi-fru-inventory \
+ virtual/phosphor-ipmi-fru-properties \
+ systemd \
+ sdbusplus \
+ python-mako-native \
+ python-pyyaml-native \
+ phosphor-ipmi-host \
+ phosphor-mapper \
+ autoconf-archive-native \
+ "
+
+RDEPENDS_${PN} += " \
+ sdbusplus \
+ "
+
+SYSTEMD_SERVICE_${PN} += "obmc-read-eeprom@.service"
+
+S = "${WORKDIR}/git"
+
+HOSTIPMI_PROVIDER_LIBRARY += "libstrgfnhandler.so"
+
+FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
+FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
+FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
+
+# TODO: Fix the the ipmi-fru-parser code generator to handle split
+# host firmware / inventory YAML and replace the OECONF below with:
+#
+# EXTRA_OECONF += "INVENTORY_YAML=${inventory_datadir}/config.yaml"
+# EXTRA_OECONF += "HOSTFW_YAML=${hostfw_datadir}/config.yaml"
+#
+# For now the generator requires them to already be combined so we have:
+EXTRA_OECONF = " \
+ YAML_GEN=${STAGING_DIR_NATIVE}${config_datadir}/config.yaml \
+ PROP_YAML=${STAGING_DIR_NATIVE}${properties_datadir}/extra-properties.yaml \
+ "
OpenPOWER on IntegriCloud