summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/recipes-phosphor/host/obmc-op-control-host_git.bb
diff options
context:
space:
mode:
authorPatrick Venture <venture@google.com>2018-10-09 20:20:36 -0700
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-10-16 02:13:10 +0000
commitc233b005ac166e27a21e9c1267367d063d7cd80a (patch)
treeecbd4d2566407f5dd37e0700478180610f3c8166 /meta-phosphor/recipes-phosphor/host/obmc-op-control-host_git.bb
parentbecc7205c10b82ab105e0f4ceccfec142a1ea2a3 (diff)
downloadtalos-openbmc-c233b005ac166e27a21e9c1267367d063d7cd80a.tar.gz
talos-openbmc-c233b005ac166e27a21e9c1267367d063d7cd80a.zip
meta-phosphor: host: obmc-op-control-host: rename as git
obmc-op-control-host.bb inherits skeleton-gdbus, which is git-based. (From meta-phosphor rev: 6188642272fa7cc4282421f8585329ceed4d8d04) Change-Id: I9e2a37cbacc3141c429c1b09d7c25b5c875ae953 Signed-off-by: Patrick Venture <venture@google.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/host/obmc-op-control-host_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/host/obmc-op-control-host_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/host/obmc-op-control-host_git.bb b/meta-phosphor/recipes-phosphor/host/obmc-op-control-host_git.bb
new file mode 100644
index 000000000..81b51394c
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/host/obmc-op-control-host_git.bb
@@ -0,0 +1,26 @@
+SUMMARY = "org.openbmc.control.Host implementation for OpenPOWER"
+DESCRIPTION = "A host control implementation suitable for OpenPOWER systems."
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+
+inherit skeleton-gdbus
+inherit obmc-phosphor-dbus-service
+inherit pkgconfig
+
+PROVIDES += "virtual/obmc-host-ctl"
+RPROVIDES_${PN} += "virtual-obmc-host-ctl"
+
+SKELETON_DIR = "op-hostctl"
+
+FMT = "org.openbmc.control.Host@{0}.service"
+DBUS_SERVICE_${PN} += "${@compose_list(d, 'FMT', 'OBMC_HOST_INSTANCES')}"
+SYSTEMD_SERVICE_${PN} = " \
+ op-start-host@.service \
+ "
+
+START_TMPL = "op-start-host@.service"
+START_TGTFMT = "obmc-host-startmin@{1}.target"
+START_INSTFMT = "op-start-host@{0}.service"
+START_FMT = "../${START_TMPL}:${START_TGTFMT}.requires/${START_INSTFMT}"
+
+SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'START_FMT', 'OBMC_HOST_INSTANCES', 'OBMC_CHASSIS_INSTANCES')}"
OpenPOWER on IntegriCloud