summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/recipes-phosphor/gpio/phosphor-gpio-monitor.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-31 06:25:51 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-06 07:44:12 -0400
commitff075f6ee795a590b244d70a90cc312ba1f2d83d (patch)
treea617790bdbfdeef960665ba0242e1f0c93e5301a /meta-phosphor/recipes-phosphor/gpio/phosphor-gpio-monitor.bb
parent3e4da38c127bb7e7641adc2fc41f4c33744cb918 (diff)
downloadtalos-openbmc-ff075f6ee795a590b244d70a90cc312ba1f2d83d.tar.gz
talos-openbmc-ff075f6ee795a590b244d70a90cc312ba1f2d83d.zip
meta-phosphor: Move layer content from common/
Adopt a more conventional directory hierarchy. meta-phosphor is still a _long_ way from suitable for hosting on yoctoproject.org but things like this don't help. (From meta-phosphor rev: 471cfcefa74b8c7ceb704cb670e6d915cf27c63b) Change-Id: I3f106b2f6cdc6cec734be28a6090800546f362eb Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/gpio/phosphor-gpio-monitor.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/gpio/phosphor-gpio-monitor.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/gpio/phosphor-gpio-monitor.bb b/meta-phosphor/recipes-phosphor/gpio/phosphor-gpio-monitor.bb
new file mode 100644
index 000000000..b6b92fd6c
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/gpio/phosphor-gpio-monitor.bb
@@ -0,0 +1,53 @@
+SUMMARY = "Phosphor GPIO monitor application"
+DESCRIPTION = "Application to monitor gpio assertions"
+HOMEPAGE = "http://github.com/openbmc/phosphor-gpio-monitor"
+PR = "r1"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+inherit autotools pkgconfig
+inherit obmc-phosphor-dbus-service
+
+GPIO_PACKAGES = " \
+ ${PN}-monitor \
+ ${PN}-presence \
+"
+
+PACKAGE_BEFORE_PN += "${GPIO_PACKAGES}"
+ALLOW_EMPTY_${PN} = "1"
+SYSTEMD_PACKAGES = "${GPIO_PACKAGES}"
+
+RPROVIDES_${PN}-monitor += "virtual/obmc-gpio-monitor"
+RPROVIDES_${PN}-presence += "virtual/obmc-gpio-presence"
+
+PROVIDES += "virtual/obmc-gpio-monitor"
+PROVIDES += "virtual/obmc-gpio-presence"
+
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "sdbusplus sdbusplus-native"
+DEPENDS += "phosphor-dbus-interfaces"
+DEPENDS += "libevdev"
+DEPENDS += "phosphor-logging"
+
+RDEPENDS_${PN}-monitor += " \
+ libsystemd \
+ libevdev \
+ phosphor-logging \
+"
+RDEPENDS_${PN}-presence += " \
+ libsystemd \
+ libevdev \
+ phosphor-logging \
+ sdbusplus \
+"
+
+SYSTEMD_SERVICE_${PN}-monitor += "phosphor-gpio-monitor@.service"
+SYSTEMD_SERVICE_${PN}-presence += "phosphor-gpio-presence@.service"
+
+FILES_${PN}-monitor += "${sbindir}/phosphor-gpio-monitor"
+FILES_${PN}-monitor += "${sbindir}/phosphor-gpio-util"
+FILES_${PN}-presence += "${sbindir}/phosphor-gpio-presence"
+
+SRC_URI += "git://github.com/openbmc/phosphor-gpio-monitor"
+SRCREV = "96e01b7c110219bef0b0f68b6054454ae27dee95"
+S = "${WORKDIR}/git"
OpenPOWER on IntegriCloud