summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/recipes-phosphor/dbus
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-10-22 18:34:58 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-10-26 09:28:58 -0400
commite58d3371418445d8a04cb35bcf0c3fb64f747bc1 (patch)
treeff1b529e975b65415539e20114c1aceb478b7a52 /meta-phosphor/recipes-phosphor/dbus
parentaa5d94588b0eac59bd7903297d255a67286ae3e2 (diff)
downloadtalos-openbmc-e58d3371418445d8a04cb35bcf0c3fb64f747bc1.tar.gz
talos-openbmc-e58d3371418445d8a04cb35bcf0c3fb64f747bc1.zip
phosphor-mapper: Drop blacklist feature
An interface and path blacklisting feature was implemented in the python mapper but it isn't used, and it wasn't implemented in the c++ mapper. Drop support to make a small improvement to comprehensional complexity and ease the transition to the c++ mapper. (From meta-phosphor rev: 6b10fd583d7c1baed14f6076322548f4f097d9db) Change-Id: I3346f1929689b75553b8331a6ac1b5df0d5c87cb Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/dbus')
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/phosphor-mapper-config-native.bb8
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/phosphor-mapper/xyz.openbmc_project.ObjectMapper.service4
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb16
3 files changed, 1 insertions, 27 deletions
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper-config-native.bb b/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper-config-native.bb
index 976c59b9c..dcc5bd3c1 100644
--- a/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper-config-native.bb
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper-config-native.bb
@@ -27,15 +27,7 @@ PHOSPHOR_MAPPER_NAMESPACE = ""
# Add interfaces to be monitored.
PHOSPHOR_MAPPER_INTERFACE = ""
-# Blacklist paths from being monitored.
-PHOSPHOR_MAPPER_NAMESPACE_BLACKLIST = ""
-
-# Blacklist interfaces from being monitored.
-PHOSPHOR_MAPPER_INTERFACE_BLACKLIST = ""
-
do_install() {
install -d ${D}/${namespace_dir}
install -d ${D}/${interface_dir}
- install -d ${D}/${blacklist_dir}
- install -d ${D}/${interfaceblacklist_dir}
}
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper/xyz.openbmc_project.ObjectMapper.service b/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper/xyz.openbmc_project.ObjectMapper.service
index aeb734da7..394e0edd1 100644
--- a/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper/xyz.openbmc_project.ObjectMapper.service
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper/xyz.openbmc_project.ObjectMapper.service
@@ -8,9 +8,7 @@ Restart=always
Type=dbus
ExecStart=/usr/bin/env phosphor-mapper \
--path_namespaces="${{MAPPER_NAMESPACES}}" \
- --interface_namespaces="${{MAPPER_INTERFACES}}" \
- --blacklists="${{MAPPER_BLACKLISTS}}" \
- --interface_blacklists="${{MAPPER_INTERFACEBLACKLISTS}}"
+ --interface_namespaces="${{MAPPER_INTERFACES}}"
SyslogIdentifier=phosphor-mapper
BusName={BUSNAME}
TimeoutStartSec=300
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb b/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb
index a67a3cae9..6b6cadf7a 100644
--- a/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb
@@ -64,18 +64,6 @@ python do_emit_env() {
for i in os.listdir(path):
interfaces.append('.'.join(i.split('-')))
- path = d.getVar('STAGING_DIR_NATIVE', True) + \
- d.getVar('blacklist_dir', True)
- blacklists = []
- for b in os.listdir(path):
- blacklists.append(os.sep + os.sep.join(b.split('-')))
-
- path = d.getVar('STAGING_DIR_NATIVE', True) + \
- d.getVar('interfaceblacklist_dir', True)
- interface_blacklists = []
- for ib in os.listdir(path):
- interface_blacklists.append('.'.join(ib.split('-')))
-
path = [d.getVar('D', True) + d.getVar('envfiledir', True)]
path.append('obmc')
path.append('mapper')
@@ -89,10 +77,6 @@ python do_emit_env() {
fd.write('\n')
fd.write('MAPPER_INTERFACES="{}"'.format(' '.join(interfaces)))
fd.write('\n')
- fd.write('MAPPER_BLACKLISTS="{}"'.format(' '.join(blacklists)))
- fd.write('\n')
- fd.write('MAPPER_INTERFACEBLACKLISTS="{}"'.format(' '.join(interface_blacklists)))
- fd.write('\n')
}
do_install[postfuncs] += "do_emit_env"
OpenPOWER on IntegriCloud