summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/recipes-phosphor/dbus
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-10-22 22:52:33 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-10-31 22:55:16 -0400
commit711ae0ebce1f127412be3cfd232ee1762bbd0cc0 (patch)
tree07898768da2257b874df9a16a62448d5ab7349bd /meta-phosphor/recipes-phosphor/dbus
parentac3fc9491a00edc39f06c09c719223c6cceb8911 (diff)
downloadtalos-openbmc-711ae0ebce1f127412be3cfd232ee1762bbd0cc0.tar.gz
talos-openbmc-711ae0ebce1f127412be3cfd232ee1762bbd0cc0.zip
phosphor-mapper: remove deprecated path whitelist
The c++ mapper implements dbus service whitelists in place of path based whitelists. Drop support for path whitelists. (From meta-phosphor rev: d4816d2868a251a0a4048219de0e9411eed8c853) Change-Id: I7ca6c4b01e644b8008169cc63c9259801c42f27f Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/dbus')
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces-mapper-config-native.bb5
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/phosphor-legacy-namespace-mapper-config-native.bb7
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/phosphor-mapper-config-native.bb3
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/phosphor-mapper/xyz.openbmc_project.ObjectMapper.service1
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb9
5 files changed, 5 insertions, 20 deletions
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces-mapper-config-native.bb b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces-mapper-config-native.bb
index e87f22546..0869c3f6a 100644
--- a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces-mapper-config-native.bb
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces-mapper-config-native.bb
@@ -1,5 +1,5 @@
-SUMMARY="Add /xyz/openbmc_project namespace to phosphor-mapper"
-DESCRIPTION="Add the /xyz/openbmc_project path namespace and \
+SUMMARY="Add xyz.openbmc_project namespace to phosphor-mapper"
+DESCRIPTION="Add the xyz.openbmc_project service namespace and \
xyz.openbmc_project interface prefix to the mapper \
watch list."
@@ -7,6 +7,5 @@ inherit phosphor-mapper
inherit native
inherit obmc-phosphor-license
-PHOSPHOR_MAPPER_NAMESPACE_append = " /xyz/openbmc_project"
PHOSPHOR_MAPPER_SERVICE_append = " xyz.openbmc_project"
PHOSPHOR_MAPPER_INTERFACE_append = " xyz.openbmc_project"
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-legacy-namespace-mapper-config-native.bb b/meta-phosphor/recipes-phosphor/dbus/phosphor-legacy-namespace-mapper-config-native.bb
index 69c777944..2cb5b76d7 100644
--- a/meta-phosphor/recipes-phosphor/dbus/phosphor-legacy-namespace-mapper-config-native.bb
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-legacy-namespace-mapper-config-native.bb
@@ -1,11 +1,10 @@
-SUMMARY="Add /org/openbmc namespace to phosphor-mapper"
-DESCRIPTION="Add the legacy /org/openbmc path namespace and \
-org.openbmc nterface prefix to the mapper watch list."
+SUMMARY="Add org.openbmc namespace to phosphor-mapper"
+DESCRIPTION="Add the legacy org.openbmc service namespace and \
+org.openbmc interface prefix to the mapper watch list."
inherit phosphor-mapper
inherit native
inherit obmc-phosphor-license
-PHOSPHOR_MAPPER_NAMESPACE_append = " /org/openbmc"
PHOSPHOR_MAPPER_SERVICE_append = " org.openbmc"
PHOSPHOR_MAPPER_INTERFACE_append = " org.openbmc"
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper-config-native.bb b/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper-config-native.bb
index 9e2f43f24..befbdbc92 100644
--- a/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper-config-native.bb
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper-config-native.bb
@@ -21,9 +21,6 @@ DEPENDS += "${PHOSPHOR_MAPPER_CONFIGS}"
# Recipes should set one of the variables below.
# Consult phosphor-mapper.bbclass for additional information.
-# Add path namespaces to be monitored.
-PHOSPHOR_MAPPER_NAMESPACE = ""
-
# Add services to be monitored.
PHOSPHOR_MAPPER_SERVICE = ""
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper/xyz.openbmc_project.ObjectMapper.service b/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper/xyz.openbmc_project.ObjectMapper.service
index 69fb1e212..8787c6ee7 100644
--- a/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper/xyz.openbmc_project.ObjectMapper.service
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper/xyz.openbmc_project.ObjectMapper.service
@@ -7,7 +7,6 @@ After=dbus.service
Restart=always
Type=dbus
ExecStart=/usr/bin/env phosphor-mapper \
- --path_namespaces="${{MAPPER_NAMESPACES}}" \
--service_namespaces="${{MAPPER_SERVICES}}" \
--interface_namespaces="${{MAPPER_INTERFACES}}" \
--service_blacklists="${{MAPPER_SERVICEBLACKLISTS}}"
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb b/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb
index 7b793ec9b..ee5fa0e58 100644
--- a/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb
@@ -53,12 +53,6 @@ FILES_${PN}_remove = "${libdir}/lib*.so.* ${libdir}/*"
# from the native sysroot /usr/share/phosphor-mapper filesystem.
python do_emit_env() {
path = d.getVar('STAGING_DIR_NATIVE', True) + \
- d.getVar('namespace_dir', True)
- paths = []
- for p in os.listdir(path):
- paths.append(os.sep.join(p.split('-')))
-
- path = d.getVar('STAGING_DIR_NATIVE', True) + \
d.getVar('service_dir', True)
services = []
for s in os.listdir(path):
@@ -85,8 +79,6 @@ python do_emit_env() {
if not os.path.exists(parent):
os.makedirs(parent)
with open(path, 'w+') as fd:
- fd.write('MAPPER_NAMESPACES="{}"'.format(' '.join(paths)))
- fd.write('\n')
fd.write('MAPPER_SERVICES="{}"'.format(' '.join(services)))
fd.write('\n')
fd.write('MAPPER_INTERFACES="{}"'.format(' '.join(interfaces)))
@@ -96,4 +88,3 @@ python do_emit_env() {
}
do_install[postfuncs] += "do_emit_env"
-do_install[vardeps] += "PHOSPHOR_MAPPER_NAMESPACES"
OpenPOWER on IntegriCloud