summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/recipes-devtools
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-03-22 16:04:29 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-03-29 08:00:24 -0400
commit5b94bc058835be06b26ce1e6ee8667b1f0839f70 (patch)
treed42ed882f4ea56e8ee311b90722bb288bd012bf5 /meta-phosphor/recipes-devtools
parent37f1da47b8771e3119b1cd2c2ac3a27911395af4 (diff)
downloadtalos-openbmc-5b94bc058835be06b26ce1e6ee8667b1f0839f70.tar.gz
talos-openbmc-5b94bc058835be06b26ce1e6ee8667b1f0839f70.zip
meta-phosphor: Drop recipe for phosphor-rest
This application doesn't have any in-tree users. As such, drop the recipe and its dependencies. (From meta-phosphor rev: 296cc521f5a1c8c87c63a5b475b23c876241bf22) Change-Id: Ie0ce809f84a133c023f96b4727550690583cb9df Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-devtools')
-rw-r--r--meta-phosphor/recipes-devtools/python/pamela_0.3.0.bb15
-rw-r--r--meta-phosphor/recipes-devtools/python/python-bottle.inc29
-rw-r--r--meta-phosphor/recipes-devtools/python/python-bottle/LICENSE19
-rw-r--r--meta-phosphor/recipes-devtools/python/python-bottle/json-format.patch31
-rw-r--r--meta-phosphor/recipes-devtools/python/python-bottle_0.12.13.bb10
-rw-r--r--meta-phosphor/recipes-devtools/python/python-gevent-websocket_0.10.1.bb17
-rw-r--r--meta-phosphor/recipes-devtools/python/python-gevent_1.2.2.bbappend6
-rw-r--r--meta-phosphor/recipes-devtools/python/python_2.%.bbappend11
-rw-r--r--meta-phosphor/recipes-devtools/python/wsgiref-2.7-manifest.inc33
9 files changed, 0 insertions, 171 deletions
diff --git a/meta-phosphor/recipes-devtools/python/pamela_0.3.0.bb b/meta-phosphor/recipes-devtools/python/pamela_0.3.0.bb
deleted file mode 100644
index 8071fcb04..000000000
--- a/meta-phosphor/recipes-devtools/python/pamela_0.3.0.bb
+++ /dev/null
@@ -1,15 +0,0 @@
-DESCRIPTION = "Pamela: yet another Python wrapper for PAM"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://PKG-INFO;md5=bfb663f37eb99232bc8ccfa4ea8f1202"
-
-SRC_URI[md5sum] = "de6516118d51eb5fc97017f3b6d5c68b"
-SRC_URI[sha256sum] = "1e198446a6cdd87704aa0def7621d62e7c20b0e6068e2788b9a866a8355e5d6b"
-
-PYPI_PACKAGE = "pamela"
-
-inherit pypi setuptools
-
-RDEPENDS_${PN} = "libpam"
-
-inherit distro_features_check
-REQUIRED_DISTRO_FEATURES = "pam"
diff --git a/meta-phosphor/recipes-devtools/python/python-bottle.inc b/meta-phosphor/recipes-devtools/python/python-bottle.inc
deleted file mode 100644
index 159ded660..000000000
--- a/meta-phosphor/recipes-devtools/python/python-bottle.inc
+++ /dev/null
@@ -1,29 +0,0 @@
-SUMMARY = "Fast and simple WSGI-framework for small web-applications."
-DESCRIPTION = "Bottle is a fast and simple micro-framework for small web \
-applications. It offers request dispatching (Routes) with url parameter \
-support, templates, a built-in HTTP Server and adapters for many third \
-party WSGI/HTTP-server and template engines - all in a single file and \
-with no dependencies other than the Python Standard Library."
-HOMEPAGE = "http://bottlepy.org/"
-SECTION = "devel/python"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=94b9b2cc7e46ccea87e00af8970826b5"
-
-inherit allarch
-inherit setuptools
-inherit pypi
-
-RDEPENDS_${PN} += " \
- python-email \
- python-json \
- python-netserver \
- "
-
-PROVIDES += "${PN}-app"
-PACKAGE_BEFORE_PN += "${PN}-app"
-
-SUMMARY_${PN}-app = "${SRCNAME} app"
-RDEPENDS_${PN}-app = "${PN}"
-FILES_${PN}-app = "${bindir}/bottle.py*"
-
-BBCLASSEXTEND = "nativesdk"
diff --git a/meta-phosphor/recipes-devtools/python/python-bottle/LICENSE b/meta-phosphor/recipes-devtools/python/python-bottle/LICENSE
deleted file mode 100644
index 5f3e8de3a..000000000
--- a/meta-phosphor/recipes-devtools/python/python-bottle/LICENSE
+++ /dev/null
@@ -1,19 +0,0 @@
-Copyright (c) 2014, Marcel Hellkamp.
-
-Permission is hereby granted, free of charge, to any person obtaining a copy
-of this software and associated documentation files (the "Software"), to deal
-in the Software without restriction, including without limitation the rights
-to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-copies of the Software, and to permit persons to whom the Software is
-furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in
-all copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
-THE SOFTWARE.
diff --git a/meta-phosphor/recipes-devtools/python/python-bottle/json-format.patch b/meta-phosphor/recipes-devtools/python/python-bottle/json-format.patch
deleted file mode 100644
index 9e754a996..000000000
--- a/meta-phosphor/recipes-devtools/python/python-bottle/json-format.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-Index: bottle-0.12.9/bottle.py
-===================================================================
---- bottle-0.12.9.orig/bottle.py
-+++ bottle-0.12.9/bottle.py
-@@ -1721,8 +1721,10 @@ class JSONPlugin(object):
- name = 'json'
- api = 2
-
-- def __init__(self, json_dumps=json_dumps):
-+ def __init__(self, json_dumps=json_dumps, **kw):
- self.json_dumps = json_dumps
-+ self.json_kw = { x:y for x,y in kw.iteritems() \
-+ if x in ['indent','sort_keys'] }
-
- def apply(self, callback, route):
- dumps = self.json_dumps
-@@ -1735,12 +1737,12 @@ class JSONPlugin(object):
-
- if isinstance(rv, dict):
- #Attempt to serialize, raises exception on failure
-- json_response = dumps(rv)
-+ json_response = dumps(rv, **self.json_kw)
- #Set content type only if serialization succesful
- response.content_type = 'application/json'
- return json_response
- elif isinstance(rv, HTTPResponse) and isinstance(rv.body, dict):
-- rv.body = dumps(rv.body)
-+ rv.body = dumps(rv.body, **self.json_kw)
- rv.content_type = 'application/json'
- return rv
-
diff --git a/meta-phosphor/recipes-devtools/python/python-bottle_0.12.13.bb b/meta-phosphor/recipes-devtools/python/python-bottle_0.12.13.bb
deleted file mode 100644
index 08d84ff4a..000000000
--- a/meta-phosphor/recipes-devtools/python/python-bottle_0.12.13.bb
+++ /dev/null
@@ -1,10 +0,0 @@
-SRC_URI[sha256sum] = "39b751aee0b167be8dffb63ca81b735bbf1dd0905b3bc42761efedee8f123355"
-SRC_URI[md5sum] = "d2fe1b48c1d49217e78bf326b1cad437"
-
-# There is no license on pypi. See:
-# https://github.com/bottlepy/bottle/commit/55a505b3a54bb7de23e9554cb8ce7f8e160c31a0
-SRC_URI += "file://LICENSE"
-
-SRC_URI += "file://json-format.patch"
-
-require python-bottle.inc
diff --git a/meta-phosphor/recipes-devtools/python/python-gevent-websocket_0.10.1.bb b/meta-phosphor/recipes-devtools/python/python-gevent-websocket_0.10.1.bb
deleted file mode 100644
index 8ac2a8982..000000000
--- a/meta-phosphor/recipes-devtools/python/python-gevent-websocket_0.10.1.bb
+++ /dev/null
@@ -1,17 +0,0 @@
-HOMEPAGE = "https://bitbucket.org/noppo/gevent-websocket"
-SUMMARY = "A websocket library for gevent Python networking library"
-DESCRIPTION = "\
- WebSocket is a computer communications protocol, providing full-duplex \
- communication channels over a single TCP connection. gevent-websocket \
- library provides websocket support for gevent. \
- "
-SECTION = "devel/python"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=5aa2f1d4ea55d60497aa8c3debf29ab2"
-
-RDEPENDS_${PN} = "python-gevent"
-
-SRC_URI[md5sum] = "e095bf3358175489a956949c1b4de9ff"
-SRC_URI[sha256sum] = "7eaef32968290c9121f7c35b973e2cc302ffb076d018c9068d2f5ca8b2d85fb0"
-
-inherit setuptools pypi
diff --git a/meta-phosphor/recipes-devtools/python/python-gevent_1.2.2.bbappend b/meta-phosphor/recipes-devtools/python/python-gevent_1.2.2.bbappend
deleted file mode 100644
index 924d10800..000000000
--- a/meta-phosphor/recipes-devtools/python/python-gevent_1.2.2.bbappend
+++ /dev/null
@@ -1,6 +0,0 @@
-# Remove all python .py files from gevent recipe. Only the .pyc
-# files are required. Only do if openbmc-phosphor-tiny distro
-# feature is enabled.
-do_install_append_openbmc-phosphor-tiny() {
- find ${D}/${PYTHON_SITEPACKAGES_DIR}/gevent/ -name \*.py -exec rm {} \;
-}
diff --git a/meta-phosphor/recipes-devtools/python/python_2.%.bbappend b/meta-phosphor/recipes-devtools/python/python_2.%.bbappend
index 500497318..ae0078bac 100644
--- a/meta-phosphor/recipes-devtools/python/python_2.%.bbappend
+++ b/meta-phosphor/recipes-devtools/python/python_2.%.bbappend
@@ -1,17 +1,6 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI += "file://0001-json-Use-int-long.__str__-to-convert-subclasses.patch"
-require wsgiref-${PYTHON_MAJMIN}-manifest.inc
-
-PROVIDES_prepend = "${PN}-spwd "
-PACKAGES_prepend = "${PN}-spwd "
-
-SUMMARY_${PN}-spwd = "Shadow database support"
-RDEPENDS_${PN}-spwd = "${PN}-core"
-FILES_${PN}-spwd= " \
- ${libdir}/python${PYTHON_MAJMIN}/lib-dynload/spwd.so \
- ${libdir}/python${PYTHON_MAJMIN}/lib-dynload/grp.so \
- "
# Remove all python .py files from python recipe. Only the .pyc
# files are required. Only do this if the openbmc-phosphor-tiny
# distro feature is enabled
diff --git a/meta-phosphor/recipes-devtools/python/wsgiref-2.7-manifest.inc b/meta-phosphor/recipes-devtools/python/wsgiref-2.7-manifest.inc
deleted file mode 100644
index a21d05ee2..000000000
--- a/meta-phosphor/recipes-devtools/python/wsgiref-2.7-manifest.inc
+++ /dev/null
@@ -1,33 +0,0 @@
-NAME = "wsgiref"
-
-PROVIDES_prepend = "${PN}-${NAME} ${PN}-${NAME}-headers ${PN}-${NAME}-handlers ${PN}-${NAME}-validate ${PN}-${NAME}-simple_server ${PN}-${NAME}-util "
-PACKAGES_prepend = "${PN}-${NAME} ${PN}-${NAME}-headers ${PN}-${NAME}-handlers ${PN}-${NAME}-validate ${PN}-${NAME}-simple_server ${PN}-${NAME}-util "
-
-package_dir = "${libdir}/python${PYTHON_MAJMIN}/${NAME}"
-
-SUMMARY_${PN}-${NAME}-handlers = "${NAME} handlers"
-RDEPENDS_${PN}-${NAME}-handlers = "${PN}-${NAME}-util ${PN}-${NAME}-headers"
-FILES_${PN}-${NAME}-handlers = "${package_dir}/handlers.py*"
-
-SUMMARY_${PN}-${NAME}-headers = "${NAME} headers"
-RDEPENDS_${PN}-${NAME}-headers = "${PN}-${NAME}"
-FILES_${PN}-${NAME}-headers = "${package_dir}/headers.py*"
-
-SUMMARY_${PN}-${NAME}-simple_server = "${NAME} simple server"
-RDEPENDS_${PN}-${NAME}-simple_server = "${PN}-${NAME}-handlers"
-FILES_${PN}-${NAME}-simple_server = "${package_dir}/simple_server.py*"
-
-SUMMARY_${PN}-${NAME}-util = "${NAME} util"
-RDEPENDS_${PN}-${NAME}-util = "${PN}-${NAME}"
-FILES_${PN}-${NAME}-util = "${package_dir}/util.py*"
-
-SUMMARY_${PN}-${NAME}-validate = "${NAME} validate"
-RDEPENDS_${PN}-${NAME}-validate = "${PN}-${NAME}"
-FILES_${PN}-${NAME}-validate = "${package_dir}/validate.py*"
-
-SUMMARY_${PN}-${NAME} = "WSGI (PEP 333) Reference Library"
-RDEPENDS_${PN}-${NAME} = "${PN}-core"
-FILES_${PN}-${NAME} = " \
- ${package_dir}/__init__.py* \
- ${package_dir}.egg-info \
- "
OpenPOWER on IntegriCloud