summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/recipes-connectivity
diff options
context:
space:
mode:
authorAdriana Kobylak <anoo@us.ibm.com>2018-10-24 13:31:40 -0500
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-11-08 19:34:28 -0500
commit329a80526e5a88aa826017bbee0049dc87f2d7d4 (patch)
tree81e66567f9b793d6b08602150bcbf1c97c4446e1 /meta-phosphor/recipes-connectivity
parent75361a9829e881e69326b026a32c0402937e2e10 (diff)
downloadtalos-openbmc-329a80526e5a88aa826017bbee0049dc87f2d7d4.tar.gz
talos-openbmc-329a80526e5a88aa826017bbee0049dc87f2d7d4.zip
jsnbd: Add config.json file
The nbd-proxy app expects a config.json file installed in /etc/nbd-proxy/, use the default file provided in the repo. This file can be overridden by creating a new file in a meta layer, then adding the following lines to a jsnbd_%.bbappend: FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" SRC_URI += "file://config.json" NBD_PROXY_CONFIG_JSON = "${WORKDIR}/config.json" Tested: Verified the default file is installed in the image and that the nbd-proxy app finds it. Also checked that the file can be overridden with a bbappend. (From meta-phosphor rev: 88a54abe79d9dd5c9fd3df66bf48b3d0ce1a4f12) Change-Id: I92b1e69453f7b945b9bee2953625218b13a96dc8 Signed-off-by: Adriana Kobylak <anoo@us.ibm.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-connectivity')
-rw-r--r--meta-phosphor/recipes-connectivity/jsnbd/jsnbd_git.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-connectivity/jsnbd/jsnbd_git.bb b/meta-phosphor/recipes-connectivity/jsnbd/jsnbd_git.bb
index b5e124081..f9195476d 100644
--- a/meta-phosphor/recipes-connectivity/jsnbd/jsnbd_git.bb
+++ b/meta-phosphor/recipes-connectivity/jsnbd/jsnbd_git.bb
@@ -16,3 +16,10 @@ S = "${WORKDIR}/git"
SRC_URI = "git://github.com/openbmc/jsnbd"
SRCREV = "d5b9857609401e3cf9c53b111134a6aab8e4573c"
+
+NBD_PROXY_CONFIG_JSON ??= "${S}/config.sample.json"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/nbd-proxy/
+ install -m 0644 ${NBD_PROXY_CONFIG_JSON} ${D}${sysconfdir}/nbd-proxy/config.json
+}
OpenPOWER on IntegriCloud