summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/recipes-connectivity
diff options
context:
space:
mode:
authorEd Tanous <ed.tanous@intel.com>2018-09-07 10:18:44 -0700
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-11 21:33:51 -0400
commit2ee96f54765655f3a7b850c2b9fb4db27a2411de (patch)
tree11b3af2eb6a978ed9ddda1ab1b2b493aab2d1ff3 /meta-phosphor/recipes-connectivity
parent9392c69cb94f33ad32d35e907d14da19eeb88986 (diff)
downloadtalos-openbmc-2ee96f54765655f3a7b850c2b9fb4db27a2411de.tar.gz
talos-openbmc-2ee96f54765655f3a7b850c2b9fb4db27a2411de.zip
Allow use of insecure hashes in openssl-native
Because of this commit here: https://github.com/webpack/webpack/pull/6549/commits The newest version of webpack chooses to use md4 for compile time hashing instead of something more useful like md5/sha1/sha256. In the openbmc openssl.bbappend, we override and disable some of the ciphers we should not be using on target. This patchset adjusts the recipe to only disable the insecure hashes on the target, so openssl-native still compiles and allows them. This patchset is the first in a series to upgrade phosphor-webui to the latest versions of the packages we use. Originally opened as: https://gerrit.openbmc-project.xyz/#/c/openbmc/openbmc/+/12561/ (From meta-phosphor rev: e5217200adeed14222afde2b3ff6b972173a938f) Change-Id: Ic68b8cb9f2277cfca78f75aac0640b363640c61d Signed-off-by: Ed Tanous <ed.tanous@intel.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-connectivity')
-rw-r--r--meta-phosphor/recipes-connectivity/openssl/openssl_%.bbappend6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-phosphor/recipes-connectivity/openssl/openssl_%.bbappend b/meta-phosphor/recipes-connectivity/openssl/openssl_%.bbappend
index 44898f0de..8c88c3eae 100644
--- a/meta-phosphor/recipes-connectivity/openssl/openssl_%.bbappend
+++ b/meta-phosphor/recipes-connectivity/openssl/openssl_%.bbappend
@@ -1,13 +1,13 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
# General config settings.
-EXTRA_OECONF_append = " shared no-hw no-err no-psk no-srp no-engines "
+EXTRA_OECONF_append_class-target = " shared no-hw no-err no-psk no-srp no-engines "
# Disable SSL (keep TLS only).
-EXTRA_OECONF_append = " no-ssl2 no-ssl3 "
+EXTRA_OECONF_append_class-target = " no-ssl2 no-ssl3 "
# Disable various algorithms.
-EXTRA_OECONF_append = " no-idea no-md2 no-mdc2 no-rc5 no-md4 \
+EXTRA_OECONF_append_class-target = " no-idea no-md2 no-mdc2 no-rc5 no-md4 \
no-ripemd160 no-rmd160 no-whirlpool no-sha0 no-camellia \
no-rc2 no-rc4 no-bf no-cast no-seed no-gost "
OpenPOWER on IntegriCloud