summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2017-03-01 15:33:25 -0500
committerPatrick Williams <patrick@stwcx.xyz>2017-03-02 20:37:12 +0000
commitef12c506d04c642f21c17aa9d50f0e54d3ea7a40 (patch)
tree0302a3bfe7a1c3e312d9c25392c0a9ebe65451c2 /meta-phosphor/common
parent720ec82458f06affca2d2c1baac2c5e951c37286 (diff)
downloadtalos-openbmc-ef12c506d04c642f21c17aa9d50f0e54d3ea7a40.tar.gz
talos-openbmc-ef12c506d04c642f21c17aa9d50f0e54d3ea7a40.zip
leds: Make phosphor-led-manager-config native
phosphor-led-manager-config is a meta-recipe that pulls in other native recipes based on mrw enablement. Switch from being a target recipe to a native recipe. A native recipe is more appropriate since a target recipe will cause bitbake to create -dev packages and attempt to install those into an SDK. Change-Id: I42af0796960cefe19d182afb2957e5c4853c6d28 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/common')
-rw-r--r--meta-phosphor/common/recipes-phosphor/leds/phosphor-led-manager-config-native.bb (renamed from meta-phosphor/common/recipes-phosphor/leds/phosphor-led-manager-config.bb)5
-rw-r--r--meta-phosphor/common/recipes-phosphor/leds/phosphor-led-manager.bb2
2 files changed, 4 insertions, 3 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/leds/phosphor-led-manager-config.bb b/meta-phosphor/common/recipes-phosphor/leds/phosphor-led-manager-config-native.bb
index 7d4b81a31..73812eab5 100644
--- a/meta-phosphor/common/recipes-phosphor/leds/phosphor-led-manager-config.bb
+++ b/meta-phosphor/common/recipes-phosphor/leds/phosphor-led-manager-config-native.bb
@@ -3,14 +3,15 @@ PR = "r1"
inherit obmc-phosphor-utils
inherit obmc-phosphor-license
+inherit native
# Default is the example set of data.
-PHOSPHOR_LED_MANAGER_CONFIG ??= "${PN}-example-native"
+PHOSPHOR_LED_MANAGER_CONFIG ??= "${BPN}-example-native"
# Choose appropriate yaml file
def get_depends(d):
if d.getVar('USE_MRW', 'yes'):
- return "${PN}-mrw-native"
+ return "${BPN}-mrw-native"
else:
return "${PHOSPHOR_LED_MANAGER_CONFIG}"
diff --git a/meta-phosphor/common/recipes-phosphor/leds/phosphor-led-manager.bb b/meta-phosphor/common/recipes-phosphor/leds/phosphor-led-manager.bb
index 4757aa850..54996f999 100644
--- a/meta-phosphor/common/recipes-phosphor/leds/phosphor-led-manager.bb
+++ b/meta-phosphor/common/recipes-phosphor/leds/phosphor-led-manager.bb
@@ -9,7 +9,7 @@ require ${PN}.inc
DEPENDS += "python-pyyaml-native"
DEPENDS += "autoconf-archive-native"
DEPENDS += "sdbusplus sdbusplus-native"
-DEPENDS += "${PN}-config"
+DEPENDS += "${PN}-config-native"
RDEPENDS_${PN} += "libsystemd"
S = "${WORKDIR}/git"
OpenPOWER on IntegriCloud