summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-06-07 19:53:58 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-06-25 16:05:24 -0400
commit0257c2c572f4aac5e7c6fb13e66217317a30c569 (patch)
treeea4ceb4ea1adad883ad8ae9a44f98ccf82ae5a80 /meta-phosphor/common
parentf1f0262f003ce7978a0cfad53ed50eb75cc339d5 (diff)
downloadtalos-openbmc-0257c2c572f4aac5e7c6fb13e66217317a30c569.tar.gz
talos-openbmc-0257c2c572f4aac5e7c6fb13e66217317a30c569.zip
systemd: Use systemd_unitdir
Somewhere between systemd 234 and 237 the install process stopped making /usr/lib/systemd/network for us. When we move to Yocto 2.5 this will result in an install failure. bitbake.conf provides a variable for /lib/systemd. Use it, as it's the correct location for these configuration/unit files anyhow. Tested: Booted QEMU witherspoon image to shell Change-Id: Ia863473539378ef07f652ae3820b9c22ce5f6900 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/common')
-rw-r--r--meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend b/meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend
index 471fd55e0..539c2d921 100644
--- a/meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend
@@ -22,14 +22,14 @@ SRC_URI += "file://0001-watchdog-allow-a-device-path-to-be-specified.patch"
SRC_URI += "file://0002-core-Add-WatchdogDevice-config-option-and-implement-.patch"
RRECOMMENDS_${PN} += "obmc-targets"
-FILES_${PN} += "${libdir}/systemd/network/default.network"
-FILES_${PN} += "${libdir}/systemd/system.conf.d/service-restart-policy.conf"
+FILES_${PN} += "${systemd_unitdir}/network/default.network"
+FILES_${PN} += "${systemd_unitdir}/system.conf.d/service-restart-policy.conf"
EXTRA_OECONF += " --disable-hwdb"
do_install_append() {
- install -m 644 ${WORKDIR}/default.network ${D}${libdir}/systemd/network/
- install -m 644 -D ${WORKDIR}/service-restart-policy.conf ${D}${libdir}/systemd/system.conf.d/service-restart-policy.conf
+ install -m 644 ${WORKDIR}/default.network ${D}${systemd_unitdir}/network/
+ install -m 644 -D ${WORKDIR}/service-restart-policy.conf ${D}${systemd_unitdir}/system.conf.d/service-restart-policy.conf
}
do_install_append_df-obmc-ubi-fs() {
OpenPOWER on IntegriCloud