summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/state
diff options
context:
space:
mode:
authorAndrew Geissler <andrewg@us.ibm.com>2017-01-17 15:08:44 -0600
committerPatrick Williams <patrick@stwcx.xyz>2017-01-18 21:39:56 +0000
commit268ab21e3d030d462e8e6755547b389a9a292987 (patch)
treee158857f50840c533063db933adb6000946be722 /meta-phosphor/common/recipes-phosphor/state
parent5256e0ec55cc4f6386f0cc3858d127173c238765 (diff)
downloadtalos-openbmc-268ab21e3d030d462e8e6755547b389a9a292987.tar.gz
talos-openbmc-268ab21e3d030d462e8e6755547b389a9a292987.zip
Initial recipe for phosphor-chassis-state-manager
Delivers the phosphor-chassis-state-manager application which provides control and query functions on the chassis object in the system Change-Id: I6b0da8e3162b1c617743f979e8b7328b456530ec Signed-off-by: Andrew Geissler <andrewg@us.ibm.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/state')
-rw-r--r--meta-phosphor/common/recipes-phosphor/state/phosphor-chassis-state-manager.bb26
-rw-r--r--meta-phosphor/common/recipes-phosphor/state/phosphor-chassis-state-manager/xyz.openbmc_project.State.Chassis.service14
2 files changed, 40 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/state/phosphor-chassis-state-manager.bb b/meta-phosphor/common/recipes-phosphor/state/phosphor-chassis-state-manager.bb
new file mode 100644
index 000000000..d81277c58
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/state/phosphor-chassis-state-manager.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Phosphor Chassis State Management"
+DESCRIPTION = "Phosphor Chassis State Manager provides a chassis state \
+object which manages the chassis's in the system. It is suitable for use on \
+a wide variety of OpenBMC platforms."
+HOMEPAGE = "https://github.com/openbmc/phosphor-state-manager"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+inherit autotools pkgconfig
+inherit obmc-phosphor-dbus-service
+
+DBUS_SERVICE_${PN} += "xyz.openbmc_project.State.Chassis.service"
+
+RDEPENDS_${PN} += "libsystemd"
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "sdbusplus"
+DEPENDS += "phosphor-logging"
+
+PROVIDES += "virtual/obmc-chassis-state-mgmt"
+RPROVIDES_${PN} += "virtual-obmc-chassis-state-mgmt"
+
+SRC_URI += "git://github.com/openbmc/phosphor-state-manager"
+SRCREV = "794baed325213d39d75e5f8c3374177891ef70ec"
+
+S = "${WORKDIR}/git"
diff --git a/meta-phosphor/common/recipes-phosphor/state/phosphor-chassis-state-manager/xyz.openbmc_project.State.Chassis.service b/meta-phosphor/common/recipes-phosphor/state/phosphor-chassis-state-manager/xyz.openbmc_project.State.Chassis.service
new file mode 100644
index 000000000..5133fad04
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/state/phosphor-chassis-state-manager/xyz.openbmc_project.State.Chassis.service
@@ -0,0 +1,14 @@
+[Unit]
+Description=Phosphor Chassis State Manager
+Wants=mapper-wait@-org-openbmc-managers-System.service
+After=mapper-wait@-org-openbmc-managers-System.service
+Before=mapper-wait@-xyz-openbmc_project-state-chassis.service
+
+[Service]
+ExecStart={sbindir}/phosphor-chassis-state-manager
+Restart=always
+Type=dbus
+BusName={BUSNAME}
+
+[Install]
+WantedBy={SYSTEMD_DEFAULT_TARGET}
OpenPOWER on IntegriCloud