summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/packagegroups
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2018-02-09 12:50:57 -0800
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-02-23 16:08:34 +0000
commita30470fe5302f6eb35bc961bf644f6ec03fa44fa (patch)
treeedbf27af8a90aaa826c2ee6dab3b7bb8d7e1c2b9 /meta-phosphor/common/recipes-phosphor/packagegroups
parent2697c0768fccea8c9f74c51a9256ad50116e40a3 (diff)
downloadtalos-openbmc-a30470fe5302f6eb35bc961bf644f6ec03fa44fa.tar.gz
talos-openbmc-a30470fe5302f6eb35bc961bf644f6ec03fa44fa.zip
Don't load non-UBI flash packages on UBI systems
Two un-needed applications are getting installed and started on UBI enabled systems: - download_manager.py (obmc-mgr-download.bb) - bmc_update.py (obmc-flash-bmc.bb) Remove these if it is a BMC UBI enabled system. Moved all of the BMC flash logic to the phosphor layer where it really belongs since the ability to update your OpenBMC should come by default when bringing in phosphor. Tested: Verified 2 python applications not present on witherspoon and system boots and code updates fine. Verified romulus image still had python applications and made it to Ready states. Resolves openbmc/openbmc#2480 Change-Id: I42317ece1b75fd6bb05e766e486dfecdb7d4ccf3 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/packagegroups')
-rw-r--r--meta-phosphor/common/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb b/meta-phosphor/common/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb
index 2f4b50d1c..f014f1751 100644
--- a/meta-phosphor/common/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb
+++ b/meta-phosphor/common/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb
@@ -93,7 +93,15 @@ SUMMARY_${PN}-software = "Software applications"
RDEPENDS_${PN}-software = " \
${VIRTUAL-RUNTIME_obmc-bmc-download-mgr} \
${VIRTUAL-RUNTIME_obmc-bmc-updater} \
+ ${VIRTUAL-RUNTIME_obmc-bmc-version} \
"
+# Determine if the non-UBI flash packages are required
+RDEPENDS_${PN}-software += " \
+ ${@mf_enabled(d, 'obmc-ubi-fs', \
+ '', \
+ 'obmc-flash-bmc obmc-mgr-download')} \
+ "
+
SUMMARY_${PN}-debug-collector = "BMC debug collector"
RDEPENDS_${PN}-debug-collector = " \
${VIRTUAL-RUNTIME_obmc-dump-manager} \
OpenPOWER on IntegriCloud