summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/obmc-phosphor-chassis
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2016-06-27 14:53:52 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2016-06-30 13:41:15 -0400
commit5f9be075e0739c7d0abbb78ae9c189a0766eab3a (patch)
treed92e9692dba433625f5c351a67af147c39d0725c /meta-phosphor/common/recipes-phosphor/obmc-phosphor-chassis
parent6f286af2d6e137498c87933445dbe512bb21bc00 (diff)
downloadtalos-openbmc-5f9be075e0739c7d0abbb78ae9c189a0766eab3a.tar.gz
talos-openbmc-5f9be075e0739c7d0abbb78ae9c189a0766eab3a.zip
Add independent recipes for skeleton applications
This will enable more fine-grained control over what parts of skeleton satisfy the different openbmc build requirements, further enabling things like alternate implementations. Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/obmc-phosphor-chassis')
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-chassis/obmc-button-power.bb7
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-chassis/obmc-button-reset.bb6
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-chassis/obmc-control-chassis.bb14
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-chassis/obmc-hostcheckstop.bb8
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-chassis/obmc-mgr-inventory.bb18
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-chassis/obmc-op-control-power.bb7
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-chassis/obmc-pcie-detect.bb7
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-chassis/obmc-watchdog.bb7
8 files changed, 74 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-chassis/obmc-button-power.bb b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-chassis/obmc-button-power.bb
new file mode 100644
index 000000000..7adda51a4
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-chassis/obmc-button-power.bb
@@ -0,0 +1,7 @@
+SUMMARY = "OpenBMC org.openbmc.Button example implementation"
+DESCRIPTION = "A sample implementation for a button controlling a power domain."
+PR = "r1"
+
+inherit skeleton-gdbus
+
+SKELETON_DIR = "pwrbutton"
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-chassis/obmc-button-reset.bb b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-chassis/obmc-button-reset.bb
new file mode 100644
index 000000000..ba83a26f9
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-chassis/obmc-button-reset.bb
@@ -0,0 +1,6 @@
+SUMMARY = "OpenBMC org.openbmc.Button example implementation"
+DESCRIPTION = "A sample implementation for a reset button."
+PR = "r1"
+
+inherit skeleton-gdbus
+SKELETON_DIR = "rstbutton"
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-chassis/obmc-control-chassis.bb b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-chassis/obmc-control-chassis.bb
new file mode 100644
index 000000000..ca807153a
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-chassis/obmc-control-chassis.bb
@@ -0,0 +1,14 @@
+SUMMARY = "OpenBMC org.openbmc.control.Chassis example implementation"
+DESCRIPTION = "An example implementation of the org.openbmc.control.Chassis DBUS API."
+PR = "r1"
+
+inherit skeleton-python
+
+RDEPENDS_${PN} += "\
+ python-dbus \
+ python-pygobject \
+ python-netclient \
+ pyphosphor \
+ "
+
+SKELETON_DIR = "pychassisctl"
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-chassis/obmc-hostcheckstop.bb b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-chassis/obmc-hostcheckstop.bb
new file mode 100644
index 000000000..d0546944c
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-chassis/obmc-hostcheckstop.bb
@@ -0,0 +1,8 @@
+SUMMARY = "OpenBMC checkstop monitor."
+DESCRIPTION = "The checkstop monitor watches a GPIO for a checkstop signal \
+and reboots a server."
+PR = "r1"
+
+inherit skeleton-gdbus
+
+SKELETON_DIR = "hostcheckstop"
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-chassis/obmc-mgr-inventory.bb b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-chassis/obmc-mgr-inventory.bb
new file mode 100644
index 000000000..8c1a309fb
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-chassis/obmc-mgr-inventory.bb
@@ -0,0 +1,18 @@
+SUMMARY = "OpenBMC inventory manager"
+DESCRIPTION = "OpenBMC inventory manager."
+PR = "r1"
+
+inherit skeleton-python
+
+VIRTUAL-RUNTIME_skeleton_workbook ?= ""
+
+RDEPENDS_${PN} += "\
+ python-dbus \
+ python-json \
+ python-pickle \
+ python-pygobject \
+ pyphosphor \
+ ${VIRTUAL-RUNTIME_skeleton_workbook} \
+ "
+
+SKELETON_DIR = "pyinventorymgr"
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-chassis/obmc-op-control-power.bb b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-chassis/obmc-op-control-power.bb
new file mode 100644
index 000000000..e7244725b
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-chassis/obmc-op-control-power.bb
@@ -0,0 +1,7 @@
+SUMMARY = "org.openbmc.control.Power implemention for OpenPOWER"
+DESCRIPTION = "A power control implementation suitable for OpenPOWER systems."
+PR = "r1"
+
+inherit skeleton-gdbus
+
+SKELETON_DIR = "op-pwrctl"
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-chassis/obmc-pcie-detect.bb b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-chassis/obmc-pcie-detect.bb
new file mode 100644
index 000000000..e134cf0c2
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-chassis/obmc-pcie-detect.bb
@@ -0,0 +1,7 @@
+SUMMARY = "OpenBMC PCIE slot detection utility"
+DESCRIPTION = "OpenBMC PCIE slot detection utility."
+PR = "r1"
+
+inherit skeleton-gdbus
+
+SKELETON_DIR = "pciedetect"
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-chassis/obmc-watchdog.bb b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-chassis/obmc-watchdog.bb
new file mode 100644
index 000000000..821b7f03d
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-chassis/obmc-watchdog.bb
@@ -0,0 +1,7 @@
+SUMMARY = "OpenBMC org.openbmc.Watchdog example implementation"
+DESCRIPTION = "A sample implementation for the org.openbmc.Watchdog DBUS API."
+PR = "r1"
+
+inherit skeleton-gdbus
+
+SKELETON_DIR = "hostwatchdog"
OpenPOWER on IntegriCloud