summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-properties-mrw-native.bb
diff options
context:
space:
mode:
authorDeepak Kodihalli <dkodihal@in.ibm.com>2017-02-20 04:55:20 -0600
committerPatrick Williams <patrick@stwcx.xyz>2017-02-23 21:57:30 +0000
commit48be0fd82c11f3a32304d680b004e0191cfbb889 (patch)
tree74b30dc6af2b3503e50e21349295259190ab6bfe /meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-properties-mrw-native.bb
parent6f8fdabe9068570abecb135c4d81768263811c50 (diff)
downloadtalos-openbmc-48be0fd82c11f3a32304d680b004e0191cfbb889.tar.gz
talos-openbmc-48be0fd82c11f3a32304d680b004e0191cfbb889.zip
Add virtual/phosphor-ipmi-fru-properties
This virtual provides an output file in YAML format, which has property:value pairs for FRUs of interest. Add a native recipe that builds the configuration from MRW. Set this recipe as the default for OpenPOWER systems. Change-Id: Icc816b777189a48aff79a958f38ad22d7002bfdc Signed-off-by: Deepak Kodihalli <dkodihal@in.ibm.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-properties-mrw-native.bb')
-rw-r--r--meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-properties-mrw-native.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-properties-mrw-native.bb b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-properties-mrw-native.bb
new file mode 100644
index 000000000..2188f043a
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-properties-mrw-native.bb
@@ -0,0 +1,28 @@
+SUMMARY = "FRU properties config for ipmi-fru-parser"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit phosphor-ipmi-fru
+
+SRC_URI += "file://config.yaml"
+
+DEPENDS += " \
+ mrw-native \
+ mrw-perl-tools-native \
+ "
+
+PROVIDES += "virtual/phosphor-ipmi-fru-properties"
+
+S = "${WORKDIR}"
+
+do_install() {
+ DEST=${D}${properties_datadir}
+ install -d ${DEST}
+
+ ${bindir}/perl-native/perl \
+ ${bindir}/gen_fru_properties.pl \
+ -m ${datadir}/obmc-mrw/${MACHINE}.xml \
+ -c config.yaml \
+ -o ${DEST}/out.yaml
+}
OpenPOWER on IntegriCloud