summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/interfaces
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2016-08-30 08:54:14 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2016-09-08 14:44:29 -0400
commitf2dd552b2491fc35f0bf6f9328e57d4c75ea34d6 (patch)
treeb0d0889e72df03f116f11fc730f13d1f18ba5549 /meta-phosphor/common/recipes-phosphor/interfaces
parent5104c2f5e1566baefffc43c77f86aaadbc4bbab5 (diff)
downloadtalos-openbmc-f2dd552b2491fc35f0bf6f9328e57d4c75ea34d6.tar.gz
talos-openbmc-f2dd552b2491fc35f0bf6f9328e57d4c75ea34d6.zip
Add phosphor-gevent recipe
And make it the default for Phosphor. Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com> Change-Id: I531aa457bcc0fae4d4fff833fb1815a12af53edc
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/interfaces')
-rw-r--r--meta-phosphor/common/recipes-phosphor/interfaces/phosphor-gevent.bb24
-rw-r--r--meta-phosphor/common/recipes-phosphor/interfaces/phosphor-gevent/phosphor-gevent.service10
-rw-r--r--meta-phosphor/common/recipes-phosphor/interfaces/phosphor-gevent/phosphor-gevent.socket9
-rw-r--r--meta-phosphor/common/recipes-phosphor/interfaces/phosphor-rest.bb2
-rw-r--r--meta-phosphor/common/recipes-phosphor/interfaces/phosphor-rocket.bb2
5 files changed, 45 insertions, 2 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/interfaces/phosphor-gevent.bb b/meta-phosphor/common/recipes-phosphor/interfaces/phosphor-gevent.bb
new file mode 100644
index 000000000..91fea1056
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/interfaces/phosphor-gevent.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Phosphor Rocket startup script"
+DESCRIPTION = "Phosphor Rocket startup script."
+HOMEPAGE = "http://github.com/openbmc/phosphor-rest-server"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/git/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
+
+inherit allarch
+inherit setuptools
+inherit obmc-phosphor-systemd
+
+PROVIDES += "virtual/obmc-wsgihost"
+RPROVIDES_${PN} += "virtual-obmc-wsgihost"
+
+RDEPENDS_${PN} += " \
+ python-gevent \
+ "
+SRC_URI += "git://github.com/openbmc/phosphor-rest-server"
+
+SRCREV = "7bc6d8d39daebe3529c4c31a8caa0288dfb0ecd5"
+
+S = "${WORKDIR}/git/servers/gevent"
+
+SYSTEMD_SERVICE_${PN} += "${PN}.service ${PN}.socket"
diff --git a/meta-phosphor/common/recipes-phosphor/interfaces/phosphor-gevent/phosphor-gevent.service b/meta-phosphor/common/recipes-phosphor/interfaces/phosphor-gevent/phosphor-gevent.service
new file mode 100644
index 000000000..e5dd7078c
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/interfaces/phosphor-gevent/phosphor-gevent.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Phosphor Webserver
+PartOf=systemd-networkd.service
+After=phosphor-gevent.socket
+
+[Service]
+Restart=always
+ExecStart={sbindir}/phosphor-gevent $APPLICATION
+Environment="PYTHONUNBUFFERED=1"
+EnvironmentFile={envfiledir}/obmc/wsgi_app
diff --git a/meta-phosphor/common/recipes-phosphor/interfaces/phosphor-gevent/phosphor-gevent.socket b/meta-phosphor/common/recipes-phosphor/interfaces/phosphor-gevent/phosphor-gevent.socket
new file mode 100644
index 000000000..ed066e638
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/interfaces/phosphor-gevent/phosphor-gevent.socket
@@ -0,0 +1,9 @@
+[Unit]
+Description=Phosphor Webserver socket
+PartOf=systemd-networkd.service
+
+[Socket]
+ListenStream=443
+
+[Install]
+WantedBy=sockets.target
diff --git a/meta-phosphor/common/recipes-phosphor/interfaces/phosphor-rest.bb b/meta-phosphor/common/recipes-phosphor/interfaces/phosphor-rest.bb
index b03b24579..a44258fa0 100644
--- a/meta-phosphor/common/recipes-phosphor/interfaces/phosphor-rest.bb
+++ b/meta-phosphor/common/recipes-phosphor/interfaces/phosphor-rest.bb
@@ -23,7 +23,7 @@ RDEPENDS_${PN} += " \
"
SRC_URI += "git://github.com/openbmc/phosphor-rest-server"
-SRCREV = "2c6fc760919cc214413874d60489e3643b639692"
+SRCREV = "7bc6d8d39daebe3529c4c31a8caa0288dfb0ecd5"
S = "${WORKDIR}/git/module"
SYSTEMD_SERVICE_${PN} = ""
diff --git a/meta-phosphor/common/recipes-phosphor/interfaces/phosphor-rocket.bb b/meta-phosphor/common/recipes-phosphor/interfaces/phosphor-rocket.bb
index 0d93f236c..9e9531573 100644
--- a/meta-phosphor/common/recipes-phosphor/interfaces/phosphor-rocket.bb
+++ b/meta-phosphor/common/recipes-phosphor/interfaces/phosphor-rocket.bb
@@ -17,6 +17,6 @@ RDEPENDS_${PN} += " \
"
SRC_URI += "git://github.com/openbmc/phosphor-rest-server"
-SRCREV = "2c6fc760919cc214413874d60489e3643b639692"
+SRCREV = "7bc6d8d39daebe3529c4c31a8caa0288dfb0ecd5"
S = "${WORKDIR}/git/servers/rocket"
OpenPOWER on IntegriCloud