summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/flash/phosphor-software-manager-error-native.bb
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2018-06-21 14:23:47 -0500
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-07-19 12:46:02 +0000
commitb640b0ba83fdc076ba56b5ff98b96b3260b53607 (patch)
treee41d7545406ca6d0e1b770f8d236fa22ebc83bd4 /meta-phosphor/common/recipes-phosphor/flash/phosphor-software-manager-error-native.bb
parenta48f7f6fc06351794f348633f2db4c105a437961 (diff)
downloadtalos-openbmc-b640b0ba83fdc076ba56b5ff98b96b3260b53607.tar.gz
talos-openbmc-b640b0ba83fdc076ba56b5ff98b96b3260b53607.zip
Tell phosphor-logging about the sw-mgr error yaml
This needs to be done so phosphor-logging will know to grab the error log's metadata from the journal and add it to the log in the AdditionalData field. Tested: Check that the errors now show up in the elog-lookup.cpp file generated during the build by phosphor-logging. Change-Id: I59e357986ac56ea752c9f7241a5138eb4985ceb6 Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/flash/phosphor-software-manager-error-native.bb')
-rw-r--r--meta-phosphor/common/recipes-phosphor/flash/phosphor-software-manager-error-native.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/flash/phosphor-software-manager-error-native.bb b/meta-phosphor/common/recipes-phosphor/flash/phosphor-software-manager-error-native.bb
new file mode 100644
index 000000000..bf55058de
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/flash/phosphor-software-manager-error-native.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Copy error yaml files to known path for elog parsing"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit native
+inherit phosphor-dbus-yaml
+
+require phosphor-software-manager.inc
+
+S = "${WORKDIR}/git"
+
+do_install_append() {
+ SRC=${S}/xyz/openbmc_project/Software/
+ DEST=${D}${yaml_dir}/xyz/openbmc_project/Software/
+ install -d ${DEST}
+ install ${SRC}/*.errors.yaml ${DEST}
+ install ${SRC}/*.metadata.yaml ${DEST}
+}
OpenPOWER on IntegriCloud