summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-control-fan-config-mrw-native.bb
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2017-12-14 13:31:55 -0600
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-01-30 20:37:44 +0000
commit0a8ea6354dd6b906f310316315fc49ace110a1ea (patch)
tree208ebd0de7c036c3b1d8b5cfe5037e27f4b60eaa /meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-control-fan-config-mrw-native.bb
parent95eaf4978f6f92a848ba53accf02dcb52cee29b6 (diff)
downloadtalos-openbmc-0a8ea6354dd6b906f310316315fc49ace110a1ea.tar.gz
talos-openbmc-0a8ea6354dd6b906f310316315fc49ace110a1ea.zip
Use variables for MRW XML filename and path
Create an mrw-xml bbclass that has variables for the MRW XML filename and path to it. Then, changes all users of the MRW XML to inherit that class and use those variables. The filename will default to ${MACHINE}.xml if it hasn't already been set to something else, such as in a .conf file. This is done so that the file can be something other than ${MACHINE}.xml. Change-Id: Ia7021e5a5d5e7946829e58688250aa64250cb00e Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-control-fan-config-mrw-native.bb')
-rw-r--r--meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-control-fan-config-mrw-native.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-control-fan-config-mrw-native.bb b/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-control-fan-config-mrw-native.bb
index 1eadadf52..7ae05ce80 100644
--- a/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-control-fan-config-mrw-native.bb
+++ b/meta-phosphor/common/recipes-phosphor/fans/phosphor-fan-control-fan-config-mrw-native.bb
@@ -4,6 +4,7 @@ PR = "r1"
inherit native
inherit obmc-phosphor-license
inherit phosphor-fan
+inherit mrw-xml
DEPENDS += " \
mrw-native \
@@ -17,7 +18,7 @@ S = "${WORKDIR}"
do_compile() {
${bindir}/perl-native/perl \
${bindir}/gen_fan_zone_yaml.pl \
- -i ${datadir}/obmc-mrw/${MACHINE}.xml \
+ -i ${mrw_datadir}/${MRW_XML} \
-o ${S}/fans.yaml
}
OpenPOWER on IntegriCloud