summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-phosphor/chassis/obmc-fsi-scan.bb
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2017-02-17 12:34:40 -0600
committerMatt Spinler <spinler@us.ibm.com>2017-02-24 16:13:47 -0600
commit3eb55d4f482004465169044b56a21be2ed1e368b (patch)
treebbc80cec2ff0a01112b07a32b22e0b7219ecf7ab /meta-phosphor/common/recipes-phosphor/chassis/obmc-fsi-scan.bb
parent9ecda09f191d16fe26dc36eca41355ffea08f12b (diff)
downloadtalos-openbmc-3eb55d4f482004465169044b56a21be2ed1e368b.tar.gz
talos-openbmc-3eb55d4f482004465169044b56a21be2ed1e368b.zip
Add service to trigger OpenFSI driver to do a scan
After PGOOD comes up, the FSI driver needs to do a scan to find the FSI devices. Change-Id: I1b4eeec191408a36b37d9044279bdf067deb2b15 Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/chassis/obmc-fsi-scan.bb')
-rw-r--r--meta-phosphor/common/recipes-phosphor/chassis/obmc-fsi-scan.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/chassis/obmc-fsi-scan.bb b/meta-phosphor/common/recipes-phosphor/chassis/obmc-fsi-scan.bb
new file mode 100644
index 000000000..4a4fdd760
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/chassis/obmc-fsi-scan.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Scan for FSI devices"
+DESCRIPTION = "Tells the OpenFSI device driver to scan for FSI devices"
+PR = "r1"
+
+inherit obmc-phosphor-dbus-service
+inherit obmc-phosphor-license
+
+TMPL = "fsi-scan@.service"
+INSTFMT = "fsi-scan@{0}.service"
+TGTFMT = "obmc-power-chassis-on@{0}.target"
+FMT = "../${TMPL}:${TGTFMT}.requires/${INSTFMT}"
+
+SYSTEMD_SERVICE_${PN} += "${TMPL}"
+SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_SUBSTITUTIONS += "MACHINE:${MACHINE}:${TMPL}"
OpenPOWER on IntegriCloud