summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-devtools/python
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@us.ibm.com>2015-11-13 09:07:15 -0500
committerBrad Bishop <bradleyb@us.ibm.com>2015-11-13 09:19:06 -0500
commit5f05288a2273879c4acd7479ddd1a5ec6abc2687 (patch)
treecad9ec8f57793f8b76b557bd9c5c343cc01a8239 /meta-phosphor/common/recipes-devtools/python
parente545fa37f9b8725a0e61b22a74064536d090952f (diff)
downloadtalos-openbmc-5f05288a2273879c4acd7479ddd1a5ec6abc2687.tar.gz
talos-openbmc-5f05288a2273879c4acd7479ddd1a5ec6abc2687.zip
Add python-rocket recipe
Rocket is an minimal wsgi http server.
Diffstat (limited to 'meta-phosphor/common/recipes-devtools/python')
-rw-r--r--meta-phosphor/common/recipes-devtools/python/python-rocket.inc23
-rw-r--r--meta-phosphor/common/recipes-devtools/python/python-rocket/LICENSE21
-rw-r--r--meta-phosphor/common/recipes-devtools/python/python-rocket/setup.patch13
-rw-r--r--meta-phosphor/common/recipes-devtools/python/python-rocket_1.2.4.bb5
4 files changed, 62 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-devtools/python/python-rocket.inc b/meta-phosphor/common/recipes-devtools/python/python-rocket.inc
new file mode 100644
index 000000000..b2e6d31bf
--- /dev/null
+++ b/meta-phosphor/common/recipes-devtools/python/python-rocket.inc
@@ -0,0 +1,23 @@
+SUMMARY = "Modern, multi-threaded and extensible web server."
+DESCRIPTION = "The Rocket web server is a server designed to handle the increased \
+needs of modern web applications implemented in pure Python. It can serve WSGI \
+applications and static files. Rocket has the ability to be extended to handle \
+different types of networked request-response jobs. Rocket runs on cPython 2.5- 3.x \
+and Jython 2.5 (without the need to run through the 2to3 translation tool). Rocket \
+is similar in purpose to Cherrypy’s Wsgiserver but with added flexibility and concurrency."
+HOMEPAGE = "http://launchpad.net/rocket"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=b364bdf3116b1cbc1e30a6aff3224019"
+
+inherit allarch
+inherit setuptools
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+RDEPENDS_${PN} += "\
+ python-wsgiref-standalone-util \
+ python-wsgiref-standalone-headers \
+ python-email-utils-standalone \
+ "
+
+BBCLASSEXTEND = "nativesdk"
diff --git a/meta-phosphor/common/recipes-devtools/python/python-rocket/LICENSE b/meta-phosphor/common/recipes-devtools/python/python-rocket/LICENSE
new file mode 100644
index 000000000..29b8ae951
--- /dev/null
+++ b/meta-phosphor/common/recipes-devtools/python/python-rocket/LICENSE
@@ -0,0 +1,21 @@
+The MIT License
+
+Copyright (c) 2011 Timothy Farrell
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/meta-phosphor/common/recipes-devtools/python/python-rocket/setup.patch b/meta-phosphor/common/recipes-devtools/python/python-rocket/setup.patch
new file mode 100644
index 000000000..7affb2f7e
--- /dev/null
+++ b/meta-phosphor/common/recipes-devtools/python/python-rocket/setup.patch
@@ -0,0 +1,13 @@
+Index: Rocket-1.2.4/setup.py
+===================================================================
+--- Rocket-1.2.4.orig/setup.py
++++ Rocket-1.2.4/setup.py
+@@ -4,8 +4,6 @@
+ # This file is part of the Rocket Web Server
+ # Copyright (c) 2009 Timothy Farrell
+
+-from distribute_setup import use_setuptools
+-use_setuptools()
+ from setuptools import setup, find_packages
+
+ import os
diff --git a/meta-phosphor/common/recipes-devtools/python/python-rocket_1.2.4.bb b/meta-phosphor/common/recipes-devtools/python/python-rocket_1.2.4.bb
new file mode 100644
index 000000000..8d8008ae9
--- /dev/null
+++ b/meta-phosphor/common/recipes-devtools/python/python-rocket_1.2.4.bb
@@ -0,0 +1,5 @@
+SRCNAME = "Rocket"
+SRC_URI = "https://pypi.python.org/packages/source/r/rocket/${SRCNAME}-${PV}.zip;name=tarball file://LICENSE file://setup.patch"
+SRC_URI[tarball.sha256sum] = "7b7a3df4d9257e369d85bcc2013351704ffe364ff45d4710e6a30b2efc63a731"
+SRC_URI[tarball.md5sum] = "fa611955154b486bb91e632a43e90f4b"
+require python-rocket.inc
OpenPOWER on IntegriCloud