summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-devtools/python
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2016-06-22 17:01:04 -0500
committerPatrick Williams <patrick@stwcx.xyz>2016-06-24 15:22:21 -0500
commit114134eee0c34b20383e4d083da9a1ba9020cdf6 (patch)
tree35800318b4cf954f3fc3e6ceb4aa08298a536499 /meta-phosphor/common/recipes-devtools/python
parenta369e9f7b9c3e9e17104c2d40e93c38ea333d812 (diff)
downloadtalos-openbmc-114134eee0c34b20383e4d083da9a1ba9020cdf6.tar.gz
talos-openbmc-114134eee0c34b20383e4d083da9a1ba9020cdf6.zip
python-pexpect: Fix runtime failure with ptyprocess
python-pexpect needs python-ptyprocess and this was not specified in the .bb file. This is fixed upstream with python-pexpect_4.1.0, but not backported for 4.0.1, which is the current version used in the yocto 2.1 tree. Also, needed to backport the ptyprocess package itself. Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Diffstat (limited to 'meta-phosphor/common/recipes-devtools/python')
-rw-r--r--meta-phosphor/common/recipes-devtools/python/python-pexpect_4.0.1.bbappend1
-rw-r--r--meta-phosphor/common/recipes-devtools/python/python-ptyprocess_0.5.1.bb23
2 files changed, 24 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-devtools/python/python-pexpect_4.0.1.bbappend b/meta-phosphor/common/recipes-devtools/python/python-pexpect_4.0.1.bbappend
new file mode 100644
index 000000000..25e28098a
--- /dev/null
+++ b/meta-phosphor/common/recipes-devtools/python/python-pexpect_4.0.1.bbappend
@@ -0,0 +1 @@
+RDEPENDS_${PN}_append = "python-ptyprocess"
diff --git a/meta-phosphor/common/recipes-devtools/python/python-ptyprocess_0.5.1.bb b/meta-phosphor/common/recipes-devtools/python/python-ptyprocess_0.5.1.bb
new file mode 100644
index 000000000..931e5a7d4
--- /dev/null
+++ b/meta-phosphor/common/recipes-devtools/python/python-ptyprocess_0.5.1.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Run a subprocess in a pseudo terminal"
+HOMEPAGE = "http://ptyprocess.readthedocs.io/en/latest/"
+SECTION = "devel/python"
+LICENSE = "ISC"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=cfdcd51fa7d5808da4e74346ee394490"
+
+SRCNAME = "ptyprocess"
+
+SRC_URI = "https://files.pythonhosted.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+SRC_URI[md5sum] = "94e537122914cc9ec9c1eadcd36e73a1"
+SRC_URI[sha256sum] = "0530ce63a9295bfae7bd06edc02b6aa935619f486f0f1dc0972f516265ee81a6"
+
+UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/ptyprocess"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+RDEPENDS_${PN} = "\
+ python-core \
+"
+
+BBCLASSEXTEND = "nativesdk"
OpenPOWER on IntegriCloud