summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/common/recipes-core/systemd
diff options
context:
space:
mode:
authorJosh D. King <jdking@us.ibm.com>2017-04-06 14:43:46 -0500
committerPatrick Williams <patrick@stwcx.xyz>2017-04-20 15:43:44 +0000
commitb9ee536d0aae31718054ddad187a93d761d9dea2 (patch)
tree95bd59def58214239025ac679138dfb9f82fc22c /meta-phosphor/common/recipes-core/systemd
parent360a31bed22a78cf09ed2df7f54dac7a700beacd (diff)
downloadtalos-openbmc-b9ee536d0aae31718054ddad187a93d761d9dea2.tar.gz
talos-openbmc-b9ee536d0aae31718054ddad187a93d761d9dea2.zip
Refactor action target names Power-on-off
The target change is: obmc-power-chassis-on -> obmc-chassis-poweron obmc-power-chassis-off -> obmc-chassis-poweroff Also updated phosphor-state-manager.bb to now have correct commit id. Change-Id: I15aae803e5f0d44d4e6a137278f93e91f848b2c0 Signed-off-by: Josh D. King <jdking@us.ibm.com>
Diffstat (limited to 'meta-phosphor/common/recipes-core/systemd')
-rw-r--r--meta-phosphor/common/recipes-core/systemd/obmc-targets.bb4
-rw-r--r--meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-chassis-poweroff@.target (renamed from meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-chassis-off@.target)2
-rw-r--r--meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-chassis-poweron@.target (renamed from meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-chassis-on@.target)4
-rw-r--r--meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-chassis-reset@.target2
-rw-r--r--meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-chassis-stop@.target2
-rw-r--r--meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-off@.target2
-rw-r--r--meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-on@.target2
-rw-r--r--meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-reset-on@.target2
-rw-r--r--meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-start-pre@.target2
-rw-r--r--meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-start@.target2
-rw-r--r--meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-stop-pre@.target2
-rw-r--r--meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-stop@.target2
-rw-r--r--meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-quiesce-host@.target2
13 files changed, 15 insertions, 15 deletions
diff --git a/meta-phosphor/common/recipes-core/systemd/obmc-targets.bb b/meta-phosphor/common/recipes-core/systemd/obmc-targets.bb
index 1cca3662a..265ea1e30 100644
--- a/meta-phosphor/common/recipes-core/systemd/obmc-targets.bb
+++ b/meta-phosphor/common/recipes-core/systemd/obmc-targets.bb
@@ -48,7 +48,7 @@ HOST_ACTION_TARGETS_2 = "reset"
CHASSIS_FMT = "obmc-chassis-{0}@.target"
SYNCH_POWER_FMT = "obmc-power-{0}@.target"
-CHASSIS_POWER_FMT = "obmc-power-chassis-{0}@.target"
+CHASSIS_POWER_FMT = "obmc-chassis-power{0}@.target"
CHASSIS_POWER_FMT_2 = "obmc-chassis-{0}@.target"
HOST_SYNCH_FMT = "obmc-host-{0}@.target"
HOST_ACTION_FMT = "obmc-{0}-host@.target"
@@ -56,7 +56,7 @@ HOST_ACTION_FMT_2 = "obmc-host-{0}@.target"
CHASSIS_LINK_FMT = "${CHASSIS_FMT}:obmc-chassis-{0}@{1}.target"
SYNCH_POWER_LINK_FMT = "${SYNCH_POWER_FMT}:obmc-power-{0}@{1}.target"
-CHASSIS_POWER_LINK_FMT = "${CHASSIS_POWER_FMT}:obmc-power-chassis-{0}@{1}.target"
+CHASSIS_POWER_LINK_FMT = "${CHASSIS_POWER_FMT}:obmc-chassis-power{0}@{1}.target"
CHASSIS_POWER_LINK_FMT_2 = "${CHASSIS_POWER_FMT_2}:obmc-chassis-{0}@{1}.target"
HOST_LINK_SYNCH_FMT = "${HOST_SYNCH_FMT}:obmc-host-{0}@{1}.target"
HOST_LINK_ACTION_FMT = "${HOST_ACTION_FMT}:obmc-{0}-host@{1}.target"
diff --git a/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-chassis-off@.target b/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-chassis-poweroff@.target
index ceba1e39a..bf775fd7b 100644
--- a/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-chassis-off@.target
+++ b/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-chassis-poweroff@.target
@@ -4,6 +4,6 @@ Wants={SYSTEMD_DEFAULT_TARGET}
After={SYSTEMD_DEFAULT_TARGET}
Wants=mapper-wait@-xyz-openbmc_project-state-chassis%i.service
After=mapper-wait@-xyz-openbmc_project-state-chassis%i.service
-Conflicts=obmc-power-chassis-on@%i.target
+Conflicts=obmc-chassis-poweron@%i.target
Conflicts=obmc-chassis-reset@%i.target
RefuseManualStop=yes
diff --git a/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-chassis-on@.target b/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-chassis-poweron@.target
index 32250a419..bb7e7978e 100644
--- a/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-chassis-on@.target
+++ b/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-chassis-poweron@.target
@@ -4,7 +4,7 @@ Wants={SYSTEMD_DEFAULT_TARGET}
After={SYSTEMD_DEFAULT_TARGET}
Wants=mapper-wait@-xyz-openbmc_project-state-chassis%i.service
After=mapper-wait@-xyz-openbmc_project-state-chassis%i.service
-Conflicts=obmc-power-chassis-off@%i.target
+Conflicts=obmc-chassis-poweroff@%i.target
RefuseManualStop=yes
-OnFailure=obmc-power-chassis-off@%i.target
+OnFailure=obmc-chassis-poweroff@%i.target
OnFailureJobMode=flush
diff --git a/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-chassis-reset@.target b/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-chassis-reset@.target
index ce9e3b015..2ef6c7053 100644
--- a/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-chassis-reset@.target
+++ b/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-chassis-reset@.target
@@ -1,6 +1,6 @@
[Unit]
Description=Chassis%i (Reset Check)
-Conflicts=obmc-power-chassis-off%i.target
+Conflicts=obmc-chassis-poweroff%i.target
RefuseManualStop=yes
[Install]
diff --git a/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-chassis-stop@.target b/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-chassis-stop@.target
index 0fccea219..bc887b311 100644
--- a/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-chassis-stop@.target
+++ b/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-chassis-stop@.target
@@ -6,5 +6,5 @@ Wants=mapper-wait@-org-openbmc-control-chassis%i.service
After=mapper-wait@-org-openbmc-control-chassis%i.service
Conflicts=obmc-chassis-start@%i.target
RefuseManualStop=yes
-OnFailure=obmc-power-chassis-off@%i.target
+OnFailure=obmc-chassis-poweroff@%i.target
OnFailureJobMode=flush
diff --git a/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-off@.target b/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-off@.target
index 0ca4aa9ea..c47b21e47 100644
--- a/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-off@.target
+++ b/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-off@.target
@@ -2,6 +2,6 @@
Description=Power%i (Off)
Wants={SYSTEMD_DEFAULT_TARGET}
After=obmc-power-stop@%i.target
-Conflicts=obmc-power-chassis-on@%i.target
+Conflicts=obmc-chassis-poweron@%i.target
RefuseManualStart=yes
RefuseManualStop=yes
diff --git a/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-on@.target b/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-on@.target
index 6eefba044..52135ffc9 100644
--- a/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-on@.target
+++ b/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-on@.target
@@ -2,6 +2,6 @@
Description=Power%i (On)
Wants={SYSTEMD_DEFAULT_TARGET}
After=obmc-power-start@%i.target
-Conflicts=obmc-power-chassis-off@%i.target
+Conflicts=obmc-chassis-poweroff@%i.target
RefuseManualStart=yes
RefuseManualStop=yes
diff --git a/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-reset-on@.target b/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-reset-on@.target
index 5c8d3e6f0..d24d401bf 100644
--- a/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-reset-on@.target
+++ b/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-reset-on@.target
@@ -1,5 +1,5 @@
[Unit]
Description=Chassis%i power on after reset
-Conflicts=obmc-power-chassis-off@%i.target
+Conflicts=obmc-chassis-poweroff@%i.target
RefuseManualStart=yes
RefuseManualStop=yes
diff --git a/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-start-pre@.target b/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-start-pre@.target
index 2900d16b5..1a1ea6319 100644
--- a/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-start-pre@.target
+++ b/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-start-pre@.target
@@ -2,6 +2,6 @@
Description=Power%i On (Pre)
Wants={SYSTEMD_DEFAULT_TARGET}
After={SYSTEMD_DEFAULT_TARGET}
-Conflicts=obmc-power-chassis-off@%i.target
+Conflicts=obmc-chassis-poweroff@%i.target
RefuseManualStart=yes
RefuseManualStop=yes
diff --git a/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-start@.target b/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-start@.target
index 355ab1c56..a977d5ad3 100644
--- a/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-start@.target
+++ b/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-start@.target
@@ -2,6 +2,6 @@
Description=Power%i On
After=obmc-power-start-pre@%i.target
Wants={SYSTEMD_DEFAULT_TARGET}
-Conflicts=obmc-power-chassis-off@%i.target
+Conflicts=obmc-chassis-poweroff@%i.target
RefuseManualStart=yes
RefuseManualStop=yes
diff --git a/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-stop-pre@.target b/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-stop-pre@.target
index d28871b4b..2f130c9dc 100644
--- a/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-stop-pre@.target
+++ b/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-stop-pre@.target
@@ -2,6 +2,6 @@
Description=Power%i Off (Pre)
Wants={SYSTEMD_DEFAULT_TARGET}
After={SYSTEMD_DEFAULT_TARGET}
-Conflicts=obmc-power-chassis-on@%i.target
+Conflicts=obmc-chassis-poweron@%i.target
RefuseManualStart=yes
RefuseManualStop=yes
diff --git a/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-stop@.target b/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-stop@.target
index edf669724..b32d76f9b 100644
--- a/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-stop@.target
+++ b/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-power-stop@.target
@@ -2,7 +2,7 @@
Description=Power%i Off
After=obmc-power-stop-pre@%i.target
Wants={SYSTEMD_DEFAULT_TARGET}
-Conflicts=obmc-power-chassis-on@%i.target
+Conflicts=obmc-chassis-poweron@%i.target
Conflicts=fsi-disable.service
RefuseManualStart=yes
RefuseManualStop=yes
diff --git a/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-quiesce-host@.target b/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-quiesce-host@.target
index d0473b091..4f10419ab 100644
--- a/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-quiesce-host@.target
+++ b/meta-phosphor/common/recipes-core/systemd/obmc-targets/obmc-quiesce-host@.target
@@ -3,4 +3,4 @@ Description=Quiesce Target
Wants={SYSTEMD_DEFAULT_TARGET}
After={SYSTEMD_DEFAULT_TARGET}
RefuseManualStop=yes
-Conflicts=obmc-power-chassis-off@%i.target
+Conflicts=obmc-chassis-poweroff@%i.target
OpenPOWER on IntegriCloud