summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/aspeed-layer
diff options
context:
space:
mode:
authorJoel Stanley <joel@jms.id.au>2018-06-20 15:49:51 +0930
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-06-27 03:52:12 +0000
commitf3848610f9ea3a2d5c13dcf5dac368fbc5283886 (patch)
tree5d1246c3d0528a15a792e1151025a01ce6805c63 /meta-phosphor/aspeed-layer
parenta776b75b906206f85cd423bd1b24a958c2a1bd3b (diff)
downloadtalos-openbmc-f3848610f9ea3a2d5c13dcf5dac368fbc5283886.tar.gz
talos-openbmc-f3848610f9ea3a2d5c13dcf5dac368fbc5283886.zip
aspeed: Add cf-fsi firmware
This project installs the machine specific ColdFire firmware file into /lib/firmware for using the ColdFire FSI master kenrel driver. The repository contains source and corresponding assembled binaries. We do not assemble our own binaries as that would require building binutils for the 68k. Change-Id: Iac13f94532e0cdf92814f2521f170778505f30f7 Signed-off-by: Joel Stanley <joel@jms.id.au>
Diffstat (limited to 'meta-phosphor/aspeed-layer')
-rw-r--r--meta-phosphor/aspeed-layer/recipes-kernel/cf-fsi-firmware/cf-fsi-firmware.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-phosphor/aspeed-layer/recipes-kernel/cf-fsi-firmware/cf-fsi-firmware.bb b/meta-phosphor/aspeed-layer/recipes-kernel/cf-fsi-firmware/cf-fsi-firmware.bb
new file mode 100644
index 000000000..5e864e695
--- /dev/null
+++ b/meta-phosphor/aspeed-layer/recipes-kernel/cf-fsi-firmware/cf-fsi-firmware.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Firmware for using the ASPEED ColdFire FSI master"
+SECTION = "kenrel"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
+
+SRCREV = "0573025f0147171297c770f31619bd19afe971cf"
+SRC_URI = "git://github.com/ozbenh/cf-fsi.git"
+
+S = "${WORKDIR}/git"
+
+inherit allarch
+
+do_compile() {
+ :
+}
+
+firmware_dir="${nonarch_base_libdir}/firmware/"
+
+do_install() {
+ install -d ${D}${firmware_dir}
+ install -m 0644 ${S}/dist-bin/cf-fsi-${MACHINE}.bin ${D}${firmware_dir}
+}
+
+FILES_${PN} = "${firmware_dir}"
OpenPOWER on IntegriCloud