summaryrefslogtreecommitdiffstats
path: root/meta-phosphor/aspeed-layer
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-03-24 01:42:56 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-06-15 13:03:37 +0000
commitac7284629ea572cf27d69949dc4014b3b226f14f (patch)
tree5fc089f2688322722a46f0dcfe12e608a1be59af /meta-phosphor/aspeed-layer
parentdf497e2c06efce859fa48082d3fba69a42a47842 (diff)
downloadtalos-openbmc-ac7284629ea572cf27d69949dc4014b3b226f14f.tar.gz
talos-openbmc-ac7284629ea572cf27d69949dc4014b3b226f14f.zip
Rename and move kernel recipe
Rename linux-obmc to linux-aspeed and move to the Aspeed layer. Like recipes for u-boot forks, recipes for kernel forks in support of different SOCs are typically provided in the BSP supporting the SOC. Moved a number of phosphor-isms out of the kernel recipe and put those in a bbappend in aspeed-layer/bbappend. Removed COMPATIBLE_MACHINE setting. We simply use PREFERRED_PROVIDER in machine configuration files to set the default kernel recipe. Tested: Booted spoon/palmetto images using QEMU Change-Id: I7dc73629cad4789dcd5aeb0f7b6214fe064c6adc Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/aspeed-layer')
-rw-r--r--meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/0001-ARM-dts-Aspeed-Witherspoon-Update-BMC-partitioning.patch89
-rw-r--r--meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/phosphor-gpio-keys.cfg7
-rw-r--r--meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/phosphor-gpio-keys.scc2
-rw-r--r--meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/phosphor-vlan.cfg1
-rw-r--r--meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/phosphor-vlan.scc2
-rw-r--r--meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/phosphor-wdt-on-panic.cfg2
-rw-r--r--meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/phosphor-wdt-on-panic.scc2
-rw-r--r--meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed_%.bbappend12
8 files changed, 117 insertions, 0 deletions
diff --git a/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/0001-ARM-dts-Aspeed-Witherspoon-Update-BMC-partitioning.patch b/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/0001-ARM-dts-Aspeed-Witherspoon-Update-BMC-partitioning.patch
new file mode 100644
index 000000000..f514ef252
--- /dev/null
+++ b/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/0001-ARM-dts-Aspeed-Witherspoon-Update-BMC-partitioning.patch
@@ -0,0 +1,89 @@
+From 3e0b58ab998209b392a2870124503659245c2483 Mon Sep 17 00:00:00 2001
+From: "Edward A. James" <eajames@us.ibm.com>
+Date: Wed, 16 Aug 2017 07:58:56 -0500
+Subject: [PATCH] ARM: dts: Aspeed: Witherspoon: Update BMC partitioning
+
+Add simplified partitions for BMC and alternate flash. Include these by
+default in Witherspoon.
+
+Signed-off-by: Edward A. James <eajames@us.ibm.com>
+Signed-off-by: Joel Stanley <joel@jms.id.au>
+---
+ .../boot/dts/aspeed-bmc-alt-opp-flash-layout-ubi.dtsi | 18 ++++++++++++++++++
+ arch/arm/boot/dts/aspeed-bmc-opp-flash-layout-ubi.dtsi | 18 ++++++++++++++++++
+ arch/arm/boot/dts/aspeed-bmc-opp-witherspoon.dts | 3 ++-
+ 3 files changed, 38 insertions(+), 1 deletion(-)
+ create mode 100644 arch/arm/boot/dts/aspeed-bmc-alt-opp-flash-layout-ubi.dtsi
+ create mode 100644 arch/arm/boot/dts/aspeed-bmc-opp-flash-layout-ubi.dtsi
+
+diff --git a/arch/arm/boot/dts/aspeed-bmc-alt-opp-flash-layout-ubi.dtsi b/arch/arm/boot/dts/aspeed-bmc-alt-opp-flash-layout-ubi.dtsi
+new file mode 100644
+index 000000000000..927759950023
+--- /dev/null
++++ b/arch/arm/boot/dts/aspeed-bmc-alt-opp-flash-layout-ubi.dtsi
+@@ -0,0 +1,18 @@
++ label = "alt-bmc";
++ partitions {
++ #address-cells = < 1 >;
++ #size-cells = < 1 >;
++ compatible = "fixed-partitions";
++ u-boot@0 {
++ reg = < 0 0x60000 >;
++ label = "alt-u-boot";
++ };
++ u-boot-env@60000 {
++ reg = < 0x60000 0x20000 >;
++ label = "alt-u-boot-env";
++ };
++ obmc-ubi@80000 {
++ reg = < 0x80000 0x1F80000 >;
++ label = "alt-obmc-ubi";
++ };
++ };
+diff --git a/arch/arm/boot/dts/aspeed-bmc-opp-flash-layout-ubi.dtsi b/arch/arm/boot/dts/aspeed-bmc-opp-flash-layout-ubi.dtsi
+new file mode 100644
+index 000000000000..0059ad16d2ba
+--- /dev/null
++++ b/arch/arm/boot/dts/aspeed-bmc-opp-flash-layout-ubi.dtsi
+@@ -0,0 +1,18 @@
++ label = "bmc";
++ partitions {
++ #address-cells = < 1 >;
++ #size-cells = < 1 >;
++ compatible = "fixed-partitions";
++ u-boot@0 {
++ reg = < 0 0x60000 >;
++ label = "u-boot";
++ };
++ u-boot-env@60000 {
++ reg = < 0x60000 0x20000 >;
++ label = "u-boot-env";
++ };
++ obmc-ubi@80000 {
++ reg = < 0x80000 0x1F80000 >;
++ label = "obmc-ubi";
++ };
++ };
+diff --git a/arch/arm/boot/dts/aspeed-bmc-opp-witherspoon.dts b/arch/arm/boot/dts/aspeed-bmc-opp-witherspoon.dts
+index b24ea9967fc8..0b69aa942e18 100644
+--- a/arch/arm/boot/dts/aspeed-bmc-opp-witherspoon.dts
++++ b/arch/arm/boot/dts/aspeed-bmc-opp-witherspoon.dts
+@@ -182,13 +182,14 @@
+ status = "okay";
+ label = "bmc";
+ m25p,fast-read;
+-#include "openbmc-flash-layout.dtsi"
++#include "aspeed-bmc-opp-flash-layout-ubi.dtsi"
+ };
+
+ flash@1 {
+ status = "okay";
+ label = "alt";
+ m25p,fast-read;
++#include "aspeed-bmc-alt-opp-flash-layout-ubi.dtsi"
+ };
+ };
+
+--
+2.15.1
+
diff --git a/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/phosphor-gpio-keys.cfg b/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/phosphor-gpio-keys.cfg
new file mode 100644
index 000000000..f5c01bed7
--- /dev/null
+++ b/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/phosphor-gpio-keys.cfg
@@ -0,0 +1,7 @@
+CONFIG_INPUT_KEYBOARD=y
+# CONFIG_INPUT_LEDS is not set
+# CONFIG_INPUT_MOUSDEV is not set
+CONFIG_INPUT_EVDEV=y
+# CONFIG_KEYBOARD_ATKBD is not set
+CONFIG_KEYBOARD_GPIO=y
+# CONFIG_INPUT_MOUSE is not set
diff --git a/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/phosphor-gpio-keys.scc b/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/phosphor-gpio-keys.scc
new file mode 100644
index 000000000..78961af7a
--- /dev/null
+++ b/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/phosphor-gpio-keys.scc
@@ -0,0 +1,2 @@
+define KFEATURE_DESCRIPTION "Enable gpio-keys"
+kconf non-hardware phosphor-gpio-keys.cfg
diff --git a/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/phosphor-vlan.cfg b/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/phosphor-vlan.cfg
new file mode 100644
index 000000000..1ea3eed08
--- /dev/null
+++ b/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/phosphor-vlan.cfg
@@ -0,0 +1 @@
+CONFIG_VLAN_8021Q=y
diff --git a/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/phosphor-vlan.scc b/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/phosphor-vlan.scc
new file mode 100644
index 000000000..46d3bcec8
--- /dev/null
+++ b/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/phosphor-vlan.scc
@@ -0,0 +1,2 @@
+define KFEATURE_DESCRIPTION "Enable VLAN support"
+kconf non-hardware phosphor-vlan.cfg
diff --git a/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/phosphor-wdt-on-panic.cfg b/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/phosphor-wdt-on-panic.cfg
new file mode 100644
index 000000000..329b4df4b
--- /dev/null
+++ b/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/phosphor-wdt-on-panic.cfg
@@ -0,0 +1,2 @@
+CONFIG_PANIC_ON_OOPS=y
+CONFIG_PANIC_TIMEOUT=0
diff --git a/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/phosphor-wdt-on-panic.scc b/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/phosphor-wdt-on-panic.scc
new file mode 100644
index 000000000..7fc650799
--- /dev/null
+++ b/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed/phosphor-wdt-on-panic.scc
@@ -0,0 +1,2 @@
+define KFEATURE_DESCRIPTION "Require watchdog to reset SoC on panic"
+kconf non-hardware phosphor-wdt-on-panic.cfg
diff --git a/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed_%.bbappend b/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed_%.bbappend
new file mode 100644
index 000000000..b8c40c520
--- /dev/null
+++ b/meta-phosphor/aspeed-layer/recipes-kernel/linux/linux-aspeed_%.bbappend
@@ -0,0 +1,12 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://phosphor-gpio-keys.scc"
+SRC_URI += "file://phosphor-gpio-keys.cfg"
+SRC_URI += "file://phosphor-vlan.scc"
+SRC_URI += "file://phosphor-vlan.cfg"
+SRC_URI += "file://phosphor-wdt-on-panic.scc"
+SRC_URI += "file://phosphor-wdt-on-panic.cfg"
+SRC_URI_append_df-obmc-ubi-fs = " file://0001-ARM-dts-Aspeed-Witherspoon-Update-BMC-partitioning.patch"
+
+KERNEL_FEATURES_append = " phosphor-vlan"
+KERNEL_FEATURES_remove_qemuall = " phosphor-vlan"
OpenPOWER on IntegriCloud