summaryrefslogtreecommitdiffstats
path: root/meta-openpower/recipes-phosphor/host/hostboot-settings.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-31 06:30:50 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-04 17:28:29 -0400
commitd3f78932cf6b3063caceacdae9ddd6ca30d48786 (patch)
tree765de745d26798d7a37340d2851b86b57cda7eb8 /meta-openpower/recipes-phosphor/host/hostboot-settings.bb
parentf1ade61b5994799a4cffca0c124b2ed36e640cbf (diff)
downloadtalos-openbmc-d3f78932cf6b3063caceacdae9ddd6ca30d48786.tar.gz
talos-openbmc-d3f78932cf6b3063caceacdae9ddd6ca30d48786.zip
meta-openpower: Move layer content from common/
Adopt a more conventional directory hierarchy. meta-openpower is still a _long_ way from suitable for hosting on yoctoproject.org but things like this don't help. (From meta-openpower rev: 2c8db5661cecd7e4cc20bcb96df76490e62cfb67) Change-Id: I415caaa28ec728f24e755ddb549012f24874fefe Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openpower/recipes-phosphor/host/hostboot-settings.bb')
-rw-r--r--meta-openpower/recipes-phosphor/host/hostboot-settings.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-openpower/recipes-phosphor/host/hostboot-settings.bb b/meta-openpower/recipes-phosphor/host/hostboot-settings.bb
new file mode 100644
index 000000000..39beb480c
--- /dev/null
+++ b/meta-openpower/recipes-phosphor/host/hostboot-settings.bb
@@ -0,0 +1,19 @@
+SUMMARY = "OpenPower Hostboot Boot settings tool"
+PR = "r1"
+
+inherit obmc-phosphor-license
+inherit obmc-phosphor-systemd
+inherit allarch
+
+SRC_URI = "file://hb_settings"
+SYSTEMD_SERVICE_${PN} += "hostboot-settings.service"
+
+do_fetch[noexec] = "1"
+do_patch[noexec] = "1"
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/hb_settings ${D}${bindir}
+}
OpenPOWER on IntegriCloud