summaryrefslogtreecommitdiffstats
path: root/meta-openpower/common/recipes-phosphor/vpd
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-31 06:30:50 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-04 17:28:29 -0400
commitd3f78932cf6b3063caceacdae9ddd6ca30d48786 (patch)
tree765de745d26798d7a37340d2851b86b57cda7eb8 /meta-openpower/common/recipes-phosphor/vpd
parentf1ade61b5994799a4cffca0c124b2ed36e640cbf (diff)
downloadtalos-openbmc-d3f78932cf6b3063caceacdae9ddd6ca30d48786.tar.gz
talos-openbmc-d3f78932cf6b3063caceacdae9ddd6ca30d48786.zip
meta-openpower: Move layer content from common/
Adopt a more conventional directory hierarchy. meta-openpower is still a _long_ way from suitable for hosting on yoctoproject.org but things like this don't help. (From meta-openpower rev: 2c8db5661cecd7e4cc20bcb96df76490e62cfb67) Change-Id: I415caaa28ec728f24e755ddb549012f24874fefe Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openpower/common/recipes-phosphor/vpd')
-rw-r--r--meta-openpower/common/recipes-phosphor/vpd/openpower-fru-inventory-example-native.bb22
-rw-r--r--meta-openpower/common/recipes-phosphor/vpd/openpower-fru-inventory-example/inventory2
-rw-r--r--meta-openpower/common/recipes-phosphor/vpd/openpower-fru-inventory-mrw-native.bb28
-rw-r--r--meta-openpower/common/recipes-phosphor/vpd/openpower-fru-properties-example-native.bb22
-rw-r--r--meta-openpower/common/recipes-phosphor/vpd/openpower-fru-properties-example/example.yaml6
-rw-r--r--meta-openpower/common/recipes-phosphor/vpd/openpower-fru-properties-mrw-native.bb29
-rw-r--r--meta-openpower/common/recipes-phosphor/vpd/openpower-fru-properties-mrw/config.yaml11
-rw-r--r--meta-openpower/common/recipes-phosphor/vpd/openpower-fru-vpd-layout-native.bb19
-rw-r--r--meta-openpower/common/recipes-phosphor/vpd/openpower-fru-vpd-layout/layout.yaml15
-rw-r--r--meta-openpower/common/recipes-phosphor/vpd/openpower-fru-vpd.bb47
-rw-r--r--meta-openpower/common/recipes-phosphor/vpd/openpower-fru-vpd.inc5
-rw-r--r--meta-openpower/common/recipes-phosphor/vpd/openpower-fru-vpd/70-op-vpd.rules1
-rw-r--r--meta-openpower/common/recipes-phosphor/vpd/openpower-fru-vpd/op-vpd-parser.service12
13 files changed, 0 insertions, 219 deletions
diff --git a/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-inventory-example-native.bb b/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-inventory-example-native.bb
deleted file mode 100644
index 8f9bd050b..000000000
--- a/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-inventory-example-native.bb
+++ /dev/null
@@ -1,22 +0,0 @@
-SUMMARY = "Inventory config for openpower-vpd-parser"
-PR = "r1"
-
-inherit native
-inherit obmc-phosphor-license
-inherit openpower-fru-vpd
-
-SRC_URI += "file://inventory"
-
-PROVIDES += "virtual/openpower-fru-inventory"
-
-S = "${WORKDIR}"
-
-do_install() {
- # This recipe is supposed to create a systemd environment file
- # with values for FRU types and paths. This example recipe
- # uses a pre-defined file ($PN/inventory).
-
- DEST=${D}${inventory_datadir_native}
- install -d ${DEST}
- install inventory ${DEST}
-}
diff --git a/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-inventory-example/inventory b/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-inventory-example/inventory
deleted file mode 100644
index 1f6a5e349..000000000
--- a/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-inventory-example/inventory
+++ /dev/null
@@ -1,2 +0,0 @@
-FRUS=BMC
-PATHS=/system/chassis/bmc
diff --git a/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-inventory-mrw-native.bb b/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-inventory-mrw-native.bb
deleted file mode 100644
index 6eb76ac4e..000000000
--- a/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-inventory-mrw-native.bb
+++ /dev/null
@@ -1,28 +0,0 @@
-SUMMARY = "Inventory config for openpower-vpd-parser"
-PR = "r1"
-
-inherit native
-inherit obmc-phosphor-license
-inherit openpower-fru-vpd
-inherit mrw-xml
-
-DEPENDS += " \
- mrw-native \
- mrw-perl-tools-native \
- virtual/openpower-fru-vpd-layout \
- "
-
-PROVIDES += "virtual/openpower-fru-inventory"
-
-S = "${WORKDIR}"
-
-do_install() {
- DEST=${D}${inventory_datadir_native}
- install -d ${DEST}
-
- ${bindir}/perl-native/perl \
- ${bindir}/gen_openpower_fru.pl \
- -m ${mrw_datadir}/${MRW_XML} \
- -c ${vpdlayout_datadir}/layout.yaml \
- -o ${DEST}/inventory
-}
diff --git a/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-properties-example-native.bb b/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-properties-example-native.bb
deleted file mode 100644
index 7ed83b3a4..000000000
--- a/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-properties-example-native.bb
+++ /dev/null
@@ -1,22 +0,0 @@
-SUMMARY = "FRU properties config for openpower-vpd-parser"
-PR = "r1"
-
-inherit native
-inherit obmc-phosphor-license
-inherit openpower-fru-vpd
-
-SRC_URI += "file://example.yaml"
-
-PROVIDES += "virtual/openpower-fru-properties"
-
-S = "${WORKDIR}"
-
-do_install() {
- # This recipe is supposed to create an output yaml file with
- # FRU property values extracted from the MRW. This example recipe
- # provides a sample output file.
-
- DEST=${D}${properties_datadir}
- install -d ${DEST}
- install example.yaml ${DEST}/out.yaml
-}
diff --git a/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-properties-example/example.yaml b/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-properties-example/example.yaml
deleted file mode 100644
index 6ec9b0c35..000000000
--- a/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-properties-example/example.yaml
+++ /dev/null
@@ -1,6 +0,0 @@
-/system/chassis/motherboard/boxelder/bmc:
- xyz.openbmc_project.Inventory.Decorator.Replaceable:
- FieldReplaceable: 'false'
-/system/chassis/motherboard/boxelder/bmc/ethernet:
- xyz.openbmc_project.Inventory.Decorator.Replaceable:
- FieldReplaceable: 'false'
diff --git a/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-properties-mrw-native.bb b/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-properties-mrw-native.bb
deleted file mode 100644
index 2dc5820e3..000000000
--- a/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-properties-mrw-native.bb
+++ /dev/null
@@ -1,29 +0,0 @@
-SUMMARY = "FRU properties config for openpower-vpd-parser"
-PR = "r1"
-
-inherit native
-inherit obmc-phosphor-license
-inherit openpower-fru-vpd
-inherit mrw-xml
-
-SRC_URI += "file://config.yaml"
-
-DEPENDS += " \
- mrw-native \
- mrw-perl-tools-native \
- "
-
-PROVIDES += "virtual/openpower-fru-properties"
-
-S = "${WORKDIR}"
-
-do_install() {
- DEST=${D}${properties_datadir}
- install -d ${DEST}
-
- ${bindir}/perl-native/perl \
- ${bindir}/gen_fru_properties.pl \
- -m ${mrw_datadir}/${MRW_XML} \
- -c config.yaml \
- -o ${DEST}/out.yaml
-}
diff --git a/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-properties-mrw/config.yaml b/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-properties-mrw/config.yaml
deleted file mode 100644
index 7a9f34ec5..000000000
--- a/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-properties-mrw/config.yaml
+++ /dev/null
@@ -1,11 +0,0 @@
-BMC:
- xyz.openbmc_project.Inventory.Decorator.Replaceable:
- FieldReplaceable: 'false'
- xyz.openbmc_project.Inventory.Item:
- Present: 'true'
-
-ETHERNET:
- xyz.openbmc_project.Inventory.Decorator.Replaceable:
- FieldReplaceable: 'false'
- xyz.openbmc_project.Inventory.Item:
- Present: 'true'
diff --git a/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-vpd-layout-native.bb b/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-vpd-layout-native.bb
deleted file mode 100644
index de0cc649f..000000000
--- a/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-vpd-layout-native.bb
+++ /dev/null
@@ -1,19 +0,0 @@
-SUMMARY = "VPD layout for openpower-fru-vpd"
-PR = "r1"
-
-inherit native
-inherit openpower-fru-vpd
-inherit obmc-phosphor-license
-
-SRC_URI += "file://layout.yaml"
-
-PROVIDES += "virtual/openpower-fru-vpd-layout"
-
-S = "${WORKDIR}"
-
-do_install() {
- DEST=${D}${vpdlayout_datadir}
-
- install -d ${DEST}
- install layout.yaml ${DEST}
-}
diff --git a/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-vpd-layout/layout.yaml b/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-vpd-layout/layout.yaml
deleted file mode 100644
index 9aa746232..000000000
--- a/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-vpd-layout/layout.yaml
+++ /dev/null
@@ -1,15 +0,0 @@
-BMC:
- xyz.openbmc_project.Inventory.Decorator.Asset:
- OPFR,VP: PartNumber
- OPFR,VS: SerialNumber
- OPFR,VN: Manufacturer
- xyz.openbmc_project.Inventory.Item:
- VINI,DR: PrettyName
- xyz.openbmc_project.Common.UUID:
- OPFR,UD: UUID
- xyz.openbmc_project.Inventory.Item.Bmc:
-ETHERNET:
- xyz.openbmc_project.Inventory.Item.NetworkInterface:
- VINI,B1: MACAddress
- OPFR,B1: MACAddress
- xyz.openbmc_project.Inventory.Item.Ethernet:
diff --git a/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-vpd.bb b/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-vpd.bb
deleted file mode 100644
index 4d7114a73..000000000
--- a/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-vpd.bb
+++ /dev/null
@@ -1,47 +0,0 @@
-SUMMARY = "Parser for OpenPOWER-format FRU VPD"
-DESCRIPTION = "Parse OpenPOWER-format FRU VPD and update inventory"
-PR = "r1"
-
-inherit autotools pkgconfig
-inherit openpower-fru-vpd
-inherit pythonnative
-inherit obmc-phosphor-systemd
-
-require ${PN}.inc
-
-SRC_URI += "file://70-op-vpd.rules"
-
-DEPENDS += " \
- virtual/openpower-fru-vpd-layout \
- virtual/openpower-fru-inventory \
- virtual/openpower-fru-properties \
- sdbusplus \
- phosphor-logging \
- python-mako-native \
- python-pyyaml-native \
- autoconf-archive-native \
- "
-
-RDEPENDS_${PN} += " \
- sdbusplus \
- phosphor-logging \
- "
-
-SYSTEMD_SERVICE_${PN} += "op-vpd-parser.service"
-
-S = "${WORKDIR}/git"
-
-EXTRA_OECONF = " \
- FRU_YAML=${STAGING_DIR_NATIVE}${vpdlayout_datadir}/layout.yaml \
- PROP_YAML=${STAGING_DIR_NATIVE}${properties_datadir}/out.yaml \
- "
-
-do_install_append() {
- SRC=${STAGING_DATADIR_NATIVE}${inventory_datadir_name}
- DEST=${D}${inventory_envdir}
- install -d ${DEST}
- install ${SRC}/inventory ${DEST}
-
- install -d ${D}/${base_libdir}/udev/rules.d/
- install ${WORKDIR}/70-op-vpd.rules ${D}/${base_libdir}/udev/rules.d/
-}
diff --git a/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-vpd.inc b/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-vpd.inc
deleted file mode 100644
index db1b736d6..000000000
--- a/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-vpd.inc
+++ /dev/null
@@ -1,5 +0,0 @@
-HOMEPAGE = "https://github.com/openbmc/openpower-vpd-parser"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
-SRC_URI += "git://github.com/openbmc/openpower-vpd-parser"
-SRCREV = "0097cced1f5633d14e3304fbcc6279e7026c3abf"
diff --git a/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-vpd/70-op-vpd.rules b/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-vpd/70-op-vpd.rules
deleted file mode 100644
index 4b86b9186..000000000
--- a/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-vpd/70-op-vpd.rules
+++ /dev/null
@@ -1 +0,0 @@
-SUBSYSTEM=="i2c", ENV{OF_NAME}=="eeprom", ACTION=="add", TAG+="systemd", ENV{SYSTEMD_WANTS}+="op-vpd-parser"
diff --git a/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-vpd/op-vpd-parser.service b/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-vpd/op-vpd-parser.service
deleted file mode 100644
index 6eadebf8d..000000000
--- a/meta-openpower/common/recipes-phosphor/vpd/openpower-fru-vpd/op-vpd-parser.service
+++ /dev/null
@@ -1,12 +0,0 @@
-[Unit]
-Description=Read OpenPOWER-format VPD from EEPROM
-ConditionFileNotEmpty={envfiledir}/obmc/inventory
-Wants=mapper-wait@-xyz-openbmc_project-inventory.service
-After=mapper-wait@-xyz-openbmc_project-inventory.service
-
-[Service]
-Restart=no
-Type=oneshot
-EnvironmentFile={envfiledir}/obmc/inventory
-ExecStart=/usr/bin/env openpower-read-vpd --vpd $EEPROM --fru $FRUS --object $PATHS
-SyslogIdentifier=openpower-read-vpd
OpenPOWER on IntegriCloud