summaryrefslogtreecommitdiffstats
path: root/meta-openembedded/meta-oe/recipes-support
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-10 18:40:16 +0000
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-11-26 20:20:43 -0500
commit2eeb5257296f97a4a52f32580ebcfdc0d225c794 (patch)
treec73cb00c73a564b4e6fe4a1c155d47cfe31d6675 /meta-openembedded/meta-oe/recipes-support
parent16a32bd0d202065208cede54ea90855a3f6cf1bb (diff)
downloadtalos-openbmc-2eeb5257296f97a4a52f32580ebcfdc0d225c794.tar.gz
talos-openbmc-2eeb5257296f97a4a52f32580ebcfdc0d225c794.zip
meta-openembedded: refresh 2bb21ef27c..8760facba1
Update meta-openembedded to sumo HEAD. Armin Kuster (4): boinc: refresh patches postgresql: update to 9.4.20 sblim-sfc-common: use official SPDX license for EPL wireshark: 2.4.8 src moved to all-versions Gregory Vimont (1): tbb: check the version of the cross gcc instead of host gcc Leon Anavi (1): rygel: Update license to LGPLv2.1 Richard Purdie (1): xmlstarlet: Disable PARALLEL_MAKE (again) Change-Id: I3e00f68cb7c8c54c2457003d26da8992b1a953c3 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/tbb/tbb.bb1
-rw-r--r--meta-openembedded/meta-oe/recipes-support/tbb/tbb/0002-linux-Fix-gcc-version-check.patch57
-rw-r--r--meta-openembedded/meta-oe/recipes-support/xmlstarlet/xmlstarlet_1.6.1.bb5
3 files changed, 63 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/tbb/tbb.bb b/meta-openembedded/meta-oe/recipes-support/tbb/tbb.bb
index bad9481f7..f87010401 100644
--- a/meta-openembedded/meta-oe/recipes-support/tbb/tbb.bb
+++ b/meta-openembedded/meta-oe/recipes-support/tbb/tbb.bb
@@ -13,6 +13,7 @@ PV = "${PRDATE}+${SRCPV}"
SRC_URI = "git://github.com/01org/tbb;branch=${BRANCH} \
file://cross-compile.patch \
file://0001-mallinfo-is-glibc-specific-API-mark-it-so.patch \
+ file://0002-linux-Fix-gcc-version-check.patch \
file://tbb.pc \
"
diff --git a/meta-openembedded/meta-oe/recipes-support/tbb/tbb/0002-linux-Fix-gcc-version-check.patch b/meta-openembedded/meta-oe/recipes-support/tbb/tbb/0002-linux-Fix-gcc-version-check.patch
new file mode 100644
index 000000000..9824b61e9
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/tbb/tbb/0002-linux-Fix-gcc-version-check.patch
@@ -0,0 +1,57 @@
+From aee098f1bf0511c6b5544de3170a9e8b51673b60 Mon Sep 17 00:00:00 2001
+From: Pierre Le Magourou <plemagourou@softbankrobotics.com>
+Date: Tue, 23 Jan 2018 15:25:50 +0100
+Subject: [PATCH] linux.gcc: Fix cross compilation error.
+
+When cross compiling on linux with gcc, the host gcc was used instead of
+the cross gcc to set compilation flags according to gcc version.
+
+When the cross gcc was in version 5.X and the host gcc in version 7.X,
+tbb was compiled with the -flifetime-dse=1 flag that does not exist on
+gcc 5.X.
+---
+ build/linux.gcc.inc | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/build/linux.gcc.inc b/build/linux.gcc.inc
+index 5c1889c..a4d6698 100644
+--- a/build/linux.gcc.inc
++++ b/build/linux.gcc.inc
+@@ -41,29 +41,29 @@ LINK_FLAGS = -Wl,-rpath-link=. -rdynamic
+ C_FLAGS = $(CPLUS_FLAGS)
+
+ # gcc 4.2 and higher support OpenMP
+-ifneq (,$(shell gcc -dumpversion | egrep "^(4\.[2-9]|[5-9])"))
++ifneq (,$(shell $(CC) -dumpversion | egrep "^(4\.[2-9]|[5-9])"))
+ OPENMP_FLAG = -fopenmp
+ endif
+
+ # gcc 4.8 and later support RTM intrinsics, but require command line switch to enable them
+-ifneq (,$(shell gcc -dumpversion | egrep "^(4\.[8-9]|[5-9])"))
++ifneq (,$(shell $(CC) -dumpversion | egrep "^(4\.[8-9]|[5-9])"))
+ RTM_KEY = -mrtm
+ endif
+
+ # gcc 4.0 and later have -Wextra that is used by some our customers.
+-ifneq (,$(shell gcc -dumpversion | egrep "^([4-9])"))
++ifneq (,$(shell $(CC) -dumpversion | egrep "^([4-9])"))
+ TEST_WARNING_KEY += -Wextra
+ endif
+
+ # gcc 5.0 and later have -Wsuggest-override option
+ # enable it via a pre-included header in order to limit to C++11 and above
+-ifneq (,$(shell gcc -dumpversion | egrep "^([5-9])"))
++ifneq (,$(shell $(CC) -dumpversion | egrep "^([5-9])"))
+ INCLUDE_TEST_HEADERS = -include $(tbb_root)/src/test/harness_preload.h
+ endif
+
+ # gcc 6.0 and later have -flifetime-dse option that controls
+ # elimination of stores done outside the object lifetime
+-ifneq (,$(shell gcc -dumpversion | egrep "^([6-9])"))
++ifneq (,$(shell $(CC) -dumpversion | egrep "^([6-9])"))
+ # keep pre-contruction stores for zero initialization
+ DSE_KEY = -flifetime-dse=1
+ endif
+--
+2.15.1
+
diff --git a/meta-openembedded/meta-oe/recipes-support/xmlstarlet/xmlstarlet_1.6.1.bb b/meta-openembedded/meta-oe/recipes-support/xmlstarlet/xmlstarlet_1.6.1.bb
index e3d52e616..e28fd61a0 100644
--- a/meta-openembedded/meta-oe/recipes-support/xmlstarlet/xmlstarlet_1.6.1.bb
+++ b/meta-openembedded/meta-oe/recipes-support/xmlstarlet/xmlstarlet_1.6.1.bb
@@ -24,3 +24,8 @@ inherit autotools
EXTRA_OECONF="--disable-build-docs \
--with-libxml-prefix=${STAGING_LIBDIR}/.. \
--with-libxslt-prefix=${STAGING_LIBDIR}/.."
+
+# http://errors.yoctoproject.org/Errors/Details/157121/
+# /bin/bash: src/usage.c: No such file or directory
+# Makefile:2121: recipe for target 'src/usage.c' failed
+PARALLEL_MAKE = ""
OpenPOWER on IntegriCloud